Bitcoin Forum
June 20, 2019, 10:20:01 PM *
News: Latest Bitcoin Core release: 0.18.0 [Torrent] (New!)
 
   Home   Help Search Login Register More  
Pages: [1]
  Print  
Author Topic: Library loading error on the electrum app  (Read 77 times)
jackg
Copper Member
Legendary
*
Online Online

Activity: 1414
Merit: 1261


https://bit.ly/2FR9nyn - free python tutorials


View Profile
April 04, 2018, 11:05:49 PM
 #1

I just downloaded the latest electrum app and started it up and it says there's an SDL Error as it can't find "libpython3.6m.so" for "libmain.so".

I was wondering if anyone else has encountered this error?
Thought it is because I'm loading it through an old android version.

1561069201
Hero Member
*
Offline Offline

Posts: 1561069201

View Profile Personal Message (Offline)

Ignore
1561069201
Reply with quote  #2

1561069201
Report to moderator
PLAY NOW
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
HCP
Legendary
*
Offline Offline

Activity: 1008
Merit: 1615

<insert witty quote here>


View Profile
April 05, 2018, 05:29:21 AM
 #2

You'll need to provide a bit more info... like the actual version of the app ("the latest" is not terribly helpful)... also, the exact version of Android OS and the device you are running on.

One of the ongoing issues with Android is the huge number of different devices and custom ROMs etc. It's quite possible that if you are using an old version of Android, then it won't contain the appropriate libraries for running new apps... especially since the upgrade to Python 3 that came with Electrum v3+

Theoretically, the dev should specify the "minimum required SDK" target during compile, but it's possible that the app has been built without the correct minimum target... For instance, it should be "Android 5+" due to a particular library (or functionality not being available on earlier versions of the OS), but because the minimum was specified incorrectly (or not at all) you're trying to run it an Android 4 device and it crashes.

jackg
Copper Member
Legendary
*
Online Online

Activity: 1414
Merit: 1261


https://bit.ly/2FR9nyn - free python tutorials


View Profile
April 05, 2018, 06:10:15 PM
 #3

You'll need to provide a bit more info... like the actual version of the app ("the latest" is not terribly helpful)... also, the exact version of Android OS and the device you are running on.
Version 4.1.1
"The Latest" - the latest applied to Google Play, got no idea what it is - 3.1.2.1.

One of the ongoing issues with Android is the huge number of different devices and custom ROMs etc. It's quite possible that if you are using an old version of Android, then it won't contain the appropriate libraries for running new apps... especially since the upgrade to Python 3 that came with Electrum v3+
Yeah... Python3 upgrades really damaged a lot...
It was llike how it didn't run on some Windows machines either.

Theoretically, the dev should specify the "minimum required SDK" target during compile, but it's possible that the app has been built without the correct minimum target... For instance, it should be "Android 5+" due to a particular library (or functionality not being available on earlier versions of the OS), but because the minimum was specified incorrectly (or not at all) you're trying to run it an Android 4 device and it crashes.

It's more the compiler that gives them a label, and Google Play (if it has a good enough scanner for viruses, should technically try to build something in to make it specify the devices it can run on).

BitMaxz
Legendary
*
Online Online

Activity: 1470
Merit: 1192


Beware on fake trezor website from google ads.


View Profile WWW
April 05, 2018, 09:30:08 PM
 #4

My phone is samsung and we are the same version, but I didn't experience any error in my electrum wallet.

Possible your phone firmware is corrupted or maybe it's infected.

Try to scan your phone with free ESET anti virus or try to hard reset your phone, but first backup your important files before you do the hard reset just to refresh your phone firmware.

Anyway, I'm using electrum 3.0.6 for Android, but if you are using the latest one maybe it's a bug for low android version so I think better to report it to electrum team so that they can fix and release a latest one for android.

You can report it here https://github.com/spesmilo/electrum/issues

jackg
Copper Member
Legendary
*
Online Online

Activity: 1414
Merit: 1261


https://bit.ly/2FR9nyn - free python tutorials


View Profile
April 05, 2018, 09:56:55 PM
 #5

Thanks bitmaxz. I bought antivirus (Norton by Symantec) for myself and had a spare license, so I can almost catagorically say it doesn't have a virus (haven't scanned it recently though). Their responses to bug reports aren't so great but I'll give that a shot also.

Does 3.0.6 work alright on that version, is there a way I can pick up that version of electrum from somewhere do you know?

BitMaxz
Legendary
*
Online Online

Activity: 1470
Merit: 1192


Beware on fake trezor website from google ads.


View Profile WWW
April 05, 2018, 10:50:12 PM
Merited by jackg (2)
 #6

Does 3.0.6 work alright on that version, is there a way I can pick up that version of electrum from somewhere do you know?
Well, maybe you install the latest version of electrum with a bug and didn't work on jellybean version.

Anyway, you can download the APK version 3.0.6 in their electrum download directory check it here https://download.electrum.org/3.0.6/

Click the link with .apk and it should start downloading.

Let me know if it works in your phone or not and maybe I can suggest other solution if ever this version of electrum didn't work, but it should work because it works fine in my phone, my phone is Samsung note 2 4.1.1 jellybean version.

jackg
Copper Member
Legendary
*
Online Online

Activity: 1414
Merit: 1261


https://bit.ly/2FR9nyn - free python tutorials


View Profile
April 05, 2018, 11:16:28 PM
 #7

Thanks Bitmaxz, that worked!

It's not a great solution but it is quite a good option. Thanks for suggesting that!

HCP
Legendary
*
Offline Offline

Activity: 1008
Merit: 1615

<insert witty quote here>


View Profile
April 06, 2018, 03:59:12 AM
 #8

It's more the compiler that gives them a label, and Google Play (if it has a good enough scanner for viruses, should technically try to build something in to make it specify the devices it can run on).
No... it is the dev... there is a specific setting in a manifest file that you're supposed to set that specifies the target and/or minimum API level required for the application to run properly.

refer: https://developer.android.com/guide/topics/manifest/uses-sdk-element.html

Caution: If you do not declare this attribute, the system assumes a default value of "1", which indicates that your application is compatible with all versions of Android. If your application is not compatible with all versions (for instance, it uses APIs introduced in API Level 3) and you have not declared the proper minSdkVersion, then when installed on a system with an API Level less than 3, the application will crash during runtime when attempting to access the unavailable APIs. For this reason, be certain to declare the appropriate API Level in the minSdkVersion attribute.


Given that these values appear to be commented out in the kivy buildtools, it would seem that the APK is showing as being compatible with ALL versions of Android, when it clearly isn't... So, I'd say there is a good chance that this is the root cause of your issue (ie. the APK is using APIs/Libraries which just aren't available in such an old version of Android):
# (int) Android API to use
#android.api = 14

# (int) Minimum API required (8 = Android 2.2 devices)
#android.minapi = 8

# (int) Android SDK version to use
#android.sdk = 21

# (str) Android NDK version to use
#android.ndk = 9

Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!