Bitcoin Forum
May 29, 2017, 07:08:07 PM *
News: If the forum does not load normally for you, please send me a traceroute.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Cannot seem to toggle bit coins server switch. Help!  (Read 2298 times)
lettergram
Newbie
*
Offline Offline

Activity: 2


View Profile
February 12, 2011, 07:14:47 AM
 #1

I am running the current version of bitboin (bitcoin-0.3.19) on windows 7 and am attempting to make it run in server mode using the command 'bitcoin.exe -server' on the windows command line. I have everything set up properly using this guide

http://www.newslobster.com/random/how-to-get-started-using-your-gpu-to-mine-for-bitcoins-on-windows

The error I keep receiving is:

"Warning: to use the '-server' option, you must set rpcpassword = <password> in the configuration file 'C:/Users/[Username]/AppData/Roaming/Bitcoin/bitcoin.conf. If the file does not exist, create it with owner-readable-only file permissions"

I have tried everything from reinstalling to making all the files visible. I have spent at least a couple of hours on this, any suggestions or solutions?
1496084887
Hero Member
*
Offline Offline

Posts: 1496084887

View Profile Personal Message (Offline)

Ignore
1496084887
Reply with quote  #2

1496084887
Report to moderator
1496084887
Hero Member
*
Offline Offline

Posts: 1496084887

View Profile Personal Message (Offline)

Ignore
1496084887
Reply with quote  #2

1496084887
Report to moderator
1496084887
Hero Member
*
Offline Offline

Posts: 1496084887

View Profile Personal Message (Offline)

Ignore
1496084887
Reply with quote  #2

1496084887
Report to moderator
POLONIEX TRADING SIGNALS
+50% Profit and more via TELEGRAM
ALTCOINTRADER.CO
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1496084887
Hero Member
*
Offline Offline

Posts: 1496084887

View Profile Personal Message (Offline)

Ignore
1496084887
Reply with quote  #2

1496084887
Report to moderator
mail2345
Newbie
*
Offline Offline

Activity: 16


View Profile
February 12, 2011, 07:32:33 AM
 #2

Have you tried starting the command prompt as administrator?
I think Win7's UAC does some weird stuff with file paths.

BTC Address: 12TJbeJ2aCzCppJ6m1yYoPUdp9EHWRTQNv
lettergram
Newbie
*
Offline Offline

Activity: 2


View Profile
February 12, 2011, 09:18:41 AM
 #3

Yeah I did try that (just retried it to make sure). Still come up with the same warning and then my bitcoin closes.
Hal
VIP
Sr. Member
*
Offline Offline

Activity: 314



View Profile
February 12, 2011, 09:21:22 PM
 #4

Did you create the bitcoin.conf file? Should be in the same directory as wallet.dat. Also make sure you spell rpcpassword correctly.

Hal Finney
BitLex
Hero Member
*****
Offline Offline

Activity: 588


View Profile
February 12, 2011, 09:58:29 PM
 #5

Quote
...'C:/Users/[Username]/AppData/Roaming/Bitcoin/bitcoin.conf. If the file does not exist, create it with owner-readable-only file permissions..

create that file, open it with notepad (or any other txt-editor) and put these 3 lines in:
Code:
# JSON-RPC
server=1
rpcuser=sillyname
rpcpassword=sillypass

then just start bitcoin.exe (without -server, it's no longer needed if you put server=1 in the bitcoin.conf).


here's a bitcoin.conf sample with all (or most) possible options.

Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!