Bitcoin Forum
December 10, 2016, 12:55:55 PM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1] 2 »  All
  Print  
Author Topic: ATI Overdrive on Linux for 5850 and 5970?  (Read 12982 times)
Mahkul
Sr. Member
****
Offline Offline

Activity: 420


Be silent, or be silenced.


View Profile WWW
February 14, 2011, 01:57:01 PM
 #1

Anyone knows how to overclock these on Linux? I have ATI Catalyst on Ubuntu, but it's missing the overdrive section that windoze has...

Bitalo.com coming soon!

1MAHKULzqZb4evFFg9157LvnJhJQQbeYo7
1481374555
Hero Member
*
Offline Offline

Posts: 1481374555

View Profile Personal Message (Offline)

Ignore
1481374555
Reply with quote  #2

1481374555
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481374555
Hero Member
*
Offline Offline

Posts: 1481374555

View Profile Personal Message (Offline)

Ignore
1481374555
Reply with quote  #2

1481374555
Report to moderator
1481374555
Hero Member
*
Offline Offline

Posts: 1481374555

View Profile Personal Message (Offline)

Ignore
1481374555
Reply with quote  #2

1481374555
Report to moderator
Raulo
Full Member
***
Offline Offline

Activity: 238


View Profile
February 14, 2011, 02:55:47 PM
 #2

Anyone knows how to overclock these on Linux? I have ATI Catalyst on Ubuntu, but it's missing the overdrive section that windoze has...

First,

Code:
aticonfig --od-enable

Then

Code:
aticonfig --od-setclocks=coreclock,memclock --adapter=num

where num is 0,1,2,... or "all".

Commit is for setting it permanently (it will clock at this value after restart)

Code:
aticonfig --odcc --adapter=all

This command checks the clock
Code:
aticonfig --odgc --adapter=all

And this one temperature:
Code:
aticonfig --odgt --adapter=all

The list of these commands is avalable by
Code:
aticonfig --help

To set the fan at 70%

Code:
aticonfig --pplib-cmd "set fanspeed 0 70"

If you have multicard display, you need to set
export DISPLAY=:0.num,

where num is GPU num before submiiting the set fanspeed command.






1HAoJag4C3XtAmQJAhE9FTAAJWFcrvpdLM
Mahkul
Sr. Member
****
Offline Offline

Activity: 420


Be silent, or be silenced.


View Profile WWW
February 14, 2011, 03:41:22 PM
 #3

Anyone knows how to overclock these on Linux? I have ATI Catalyst on Ubuntu, but it's missing the overdrive section that windoze has...

First,

Code:
aticonfig --od-enable

Then

Code:
aticonfig --od-setclocks=coreclock,memclock --adapter=num

where num is 0,1,2,... or "all".

Commit is for setting it permanently (it will clock at this value after restart)

Code:
aticonfig --odcc --adapter=all

This command checks the clock
Code:
aticonfig --odgc --adapter=all

And this one temperature:
Code:
aticonfig --odgt --adapter=all

The list of these commands is avalable by
Code:
aticonfig --help

To set the fan at 70%

Code:
aticonfig --pplib-cmd "set fanspeed 0 70"

If you have multicard display, you need to set
export DISPLAY=:0.num,

where num is GPU num before submiiting the set fanspeed command.

You're just impossible man. I sent a few coins again. Wink

Bitalo.com coming soon!

1MAHKULzqZb4evFFg9157LvnJhJQQbeYo7
gusti
Legendary
*
Offline Offline

Activity: 1102


View Profile
February 14, 2011, 03:48:43 PM
 #4

Can you please share your best OC settings, when you find them ?

If you don't own the private keys, you don't own the coins.
tcatm
Sr. Member
****
Offline Offline

Activity: 337


View Profile
February 14, 2011, 03:58:58 PM
 #5

Best OC settings vary greatly. For 5970 it is usually around 800 MHz.
racerx
Jr. Member
*
Offline Offline

Activity: 37


View Profile
February 16, 2011, 05:00:30 PM
 #6

I have an HD6950 with extra shaders unlocked.

odgc shows a max peak range of 840.. is there any way to push this up more?
Code:
root@fry:~# aticonfig --odgc
Default Adapter - AMD Radeon HD 6900 Series
                            Core (MHz)    Memory (MHz)
           Current Clocks :    810           1250
             Current Peak :    810           1250
  Configurable Peak Range : [500-840]     [1250-1325]
                 GPU load :    99%

I set it to 840
Code:
root@fry:~# aticonfig --odsc=840,1250

Default Adapter - AMD Radeon HD 6900 Series
                  New Core Peak   : 840
                  New Memory Peak : 1250
root@fry:~# aticonfig --odcc
Clocks persisted for the Default Adapter - AMD Radeon HD 6900 Series

and get an extra 10,000khash/s but I'm curious how to push it outside this range. Seems possible in windows.

Also, does anyone know how to set fanspeed back to auto?
Code:
aticonfig --pplib-cmd "set fanspeed 0 auto"
seems to just turn the fan off..

Mahkul
Sr. Member
****
Offline Offline

Activity: 420


Be silent, or be silenced.


View Profile WWW
February 16, 2011, 05:06:51 PM
 #7

Guys, any idea what's the maximum temperature value that's "safe" for 5970?

Bitalo.com coming soon!

1MAHKULzqZb4evFFg9157LvnJhJQQbeYo7
Cryptoman
Hero Member
*****
Offline Offline

Activity: 728



View Profile
February 16, 2011, 06:56:26 PM
 #8

Mahkul, whose 5850 card are you running and which bios?  I have a Diamond 5850PE51G that won't let me go above 775 MHz using aticonfig.  I tried several overclocking bioses including MSI and ASUS, but Linux won't boot with them in.

"A small body of determined spirits fired by an unquenchable faith in their mission can alter the course of history." --Gandhi
Mahkul
Sr. Member
****
Offline Offline

Activity: 420


Be silent, or be silenced.


View Profile WWW
February 16, 2011, 10:08:21 PM
 #9

Mahkul, whose 5850 card are you running and which bios?  I have a Diamond 5850PE51G that won't let me go above 775 MHz using aticonfig.  I tried several overclocking bioses including MSI and ASUS, but Linux won't boot with them in.

They are Sapphire. As for the Bios version I will check that for you tomorrow; the clock... I think I was able to go up to 900MHz, but will let you know for definite tomorrow.

As for the 5970 it is a Sapphire as well and I was able to overclock it to 1010MHz (GPU core clock!). I must get some better cooling solution, because the temperature goes too high on them at that frequency, so I have to run them at 800MHz for now (getting 306Mhash/s each core).

Bitalo.com coming soon!

1MAHKULzqZb4evFFg9157LvnJhJQQbeYo7
Mahkul
Sr. Member
****
Offline Offline

Activity: 420


Be silent, or be silenced.


View Profile WWW
February 16, 2011, 10:22:41 PM
 #10

My very professional cooling solution for the 5970: Cheesy


Bitalo.com coming soon!

1MAHKULzqZb4evFFg9157LvnJhJQQbeYo7
BitLex
Hero Member
*****
Offline Offline

Activity: 588


View Profile WWW
February 24, 2011, 12:23:05 PM
 #11

is there any way to downclock my memory without flashing the BIOS?
don't really bother about the clockspeed, but i'd like to lower the memclock a bit, if possible.

Code:
noodles@ubuntu:~$ aticonfig --odgc --adapter=all

Adapter 0 - ATI Radeon HD 5800 Series
                            Core (MHz)    Memory (MHz)
           Current Clocks :    775           1125
             Current Peak :    775           1125
  Configurable Peak Range : [550-775]     [1125-1125]
                 GPU load :    99%

Adapter 1 - ATI Radeon HD 5800 Series
                            Core (MHz)    Memory (MHz)
           Current Clocks :    775           1125
             Current Peak :    775           1125
  Configurable Peak Range : [550-775]     [1125-1125]
                 GPU load :    99%

FooDSt4mP
Full Member
***
Offline Offline

Activity: 182


View Profile
February 24, 2011, 06:48:40 PM
 #12

First,

Code:
aticonfig --od-enable

Then

Code:
aticonfig --od-setclocks=coreclock,memclock --adapter=num

where num is 0,1,2,... or "all".

Commit is for setting it permanently (it will clock at this value after restart)

Code:
aticonfig --odcc --adapter=all


so if you want the GPU at 900MHz and the memory at 950 on all adapters, you'd do
Code:
aticonfig --od-setclocks=900,950 --adapter=all

As we slide down the banister of life, this is just another splinter in our ass.
FooDSt4mP
Full Member
***
Offline Offline

Activity: 182


View Profile
February 24, 2011, 06:50:01 PM
 #13

Sorry, I didn't look closely... it appears your memory isn't underclockable with your current bios.  Someone else might know how to set it to something outside of the range, but I don't.

As we slide down the banister of life, this is just another splinter in our ass.
BitLex
Hero Member
*****
Offline Offline

Activity: 588


View Profile WWW
February 24, 2011, 07:02:20 PM
 #14

well, it is "underclockable" on windows,
had it running at 800-900MHz the last week.

now i finally got ubuntu setup and running, just with some more degrees on the cards cuz of the higher memclock, which...well, kinda sucks.   Cheesy

FooDSt4mP
Full Member
***
Offline Offline

Activity: 182


View Profile
February 24, 2011, 07:18:53 PM
 #15

well, it is "underclockable" on windows,
had it running at 800-900MHz the last week.

now i finally got ubuntu setup and running, just with some more degrees on the cards cuz of the higher memclock, which...well, kinda sucks.   Cheesy

Maybe try the newest drivers direct from AMD (if you aren't already using them).

As we slide down the banister of life, this is just another splinter in our ass.
hippich
Hero Member
*****
Offline Offline

Activity: 546


View Profile
March 04, 2011, 04:36:53 AM
 #16

Any idea how to change voltage on these cards? AMDOverdriveCtrl tool do not allow to set it higher 1.05V

marcus_of_augustus
Legendary
*
Offline Offline

Activity: 2100



View Profile
March 05, 2011, 04:44:37 AM
 #17


Quote
Any idea how to change voltage on these cards? AMDOverdriveCtrl tool do not allow to set it higher 1.05V

http://bitcointalk.org/index.php?topic=3032.0
http://bitcointalk.org/index.php?topic=3032.20

Grinder
Legendary
*
Offline Offline

Activity: 1269


View Profile
March 05, 2011, 09:47:48 AM
 #18

Any idea how to change voltage on these cards? AMDOverdriveCtrl tool do not allow to set it higher 1.05V
I believe what moa tried to say was that you have to use the Radeon BIOS Editor (under Windows) and flash them.
hippich
Hero Member
*****
Offline Offline

Activity: 546


View Profile
March 05, 2011, 06:54:19 PM
 #19

actually, i found you can use RBE tool under wine and create usb boot disk with freedos to use dos atiflash tool. no windows required.

germanmkurylo
Newbie
*
Offline Offline

Activity: 2


View Profile
May 22, 2011, 12:21:56 PM
 #20

Anyone knows how to overclock these on Linux? I have ATI Catalyst on Ubuntu, but it's missing the overdrive section that windoze has...

First,

Code:
aticonfig --od-enable

Then

Code:
aticonfig --od-setclocks=coreclock,memclock --adapter=num

where num is 0,1,2,... or "all".

Commit is for setting it permanently (it will clock at this value after restart)

Code:
aticonfig --odcc --adapter=all

This command checks the clock
Code:
aticonfig --odgc --adapter=all

And this one temperature:
Code:
aticonfig --odgt --adapter=all

The list of these commands is avalable by
Code:
aticonfig --help

To set the fan at 70%

Code:
aticonfig --pplib-cmd "set fanspeed 0 70"

If you have multicard display, you need to set
export DISPLAY=:0.num,

where num is GPU num before submiiting the set fanspeed command.






my problem,  HELP MY pliss

root@sl3# aticonfig --odgt --adapter=all

Adapter 0 - ATI Radeon HD 5900 Series
            Sensor 0: Temperature - 51.50 C

Adapter 1 - ATI Radeon HD 5900 Series
            Sensor 0: Temperature - 52.50 C
ERROR - Get temperature failed for Adapter 2 - ATI Radeon HD 5900 Series

Adapter 3 - ATI Radeon HD 5900 Series
            Sensor 0: Temperature - 48.50 C
ERROR - Get temperature failed for Adapter 4 - ATI Radeon HD 5900 Series

Adapter 5 - ATI Radeon HD 5900 Series
            Sensor 0: Temperature - 52.00 C
Pages: [1] 2 »  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!