Bitcoin Forum
December 03, 2016, 03:51:48 PM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Cant start mining - X problem - 3 BTC OF REWARD  (Read 1663 times)
oo-oo
Jr. Member
*
Offline Offline

Activity: 37


View Profile
August 11, 2011, 01:58:19 AM
 #1

3 BTC WHO DARE ME SOLVE THIS

Hi, i have installed LinuxCoin and every time i try to use aticonfig i have this:

user@linuxcoin:~$ aticonfig --adapter=all --odgc
aticonfig: This program must be run as root when no X server is active

user@linuxcoin:~$ sudo aticonfig --adapter=all --odgc
PuTTY X11 proxy: wrong authorisation protocol attemptedPuTTY X11 proxy: wrong authorisation protocol attemptedPuTTY X11 proxy: wrong authorisation protocol attemptedPuTTY X11 proxy: wrong authorisation protocol attemptedERROR - X needs to be running to perform ATI Overdrive(TM) commands

I followed this guide ( http://www.linuxcoin.co.uk/wiki/index.php/SSH_X11forwarding ), and its not working...

What im missing ?

3 BTC WHO DARE ME SOLVE THIS
1480780308
Hero Member
*
Offline Offline

Posts: 1480780308

View Profile Personal Message (Offline)

Ignore
1480780308
Reply with quote  #2

1480780308
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1480780308
Hero Member
*
Offline Offline

Posts: 1480780308

View Profile Personal Message (Offline)

Ignore
1480780308
Reply with quote  #2

1480780308
Report to moderator
moocow1452
Sr. Member
****
Offline Offline

Activity: 240

Don't mind me.


View Profile
August 11, 2011, 02:21:57 AM
 #2

My Linux ain't what it used to be, but why is PuTTY running if you're messing around with your GFX? If it's not used in your client for some ssh or telnet weirdness, freeze/uninstall it, then see what happens.
oo-oo
Jr. Member
*
Offline Offline

Activity: 37


View Profile
August 12, 2011, 12:48:44 AM
 #3

Stills the same.
jh1523
Jr. Member
*
Offline Offline

Activity: 56


View Profile
August 12, 2011, 03:52:41 AM
 #4

I realize this isn't exactly the reply you're asking for, but you could give BAMT (https://bitcointalk.org/index.php?topic=28967.0) a try. Easy to control remotely through ssh since you don't need to forward X - all the config is in a text file which you can edit in a CLI text editor such as nano.

If you feel I have helped you, consider donating to 1BFLDATk4iE6R2hYTfqNjxBZYctU9eshCM
kjj
Legendary
*
Offline Offline

Activity: 1302



View Profile
August 12, 2011, 04:00:08 AM
 #5

Use "sudo su" to become root, or just start the Root Terminal instead of LXTerminal.

If you are connecting remotely, you need a startup script to store the DISPLAY environment variable in a file so that you can "export DISPLAY=`cat /home/usr/.display`" when you SSH in.  Or, you have a very good chance of getting it with "export DISPLAY=:0"

This is all covered in the linuxcoin thread, but it is buried deep.

p2pcoin: a USB/CD/PXE p2pool miner - 1N8ZXx2cuMzqBYSK72X4DAy1UdDbZQNPLf - todo
I routinely ignore posters with paid advertising in their sigs.  You should too.
aldiyen
Newbie
*
Offline Offline

Activity: 18


View Profile
August 12, 2011, 04:04:21 AM
 #6

user@linuxcoin:~$ sudo aticonfig --adapter=all --odgc
PuTTY X11 proxy: wrong authorisation protocol attemptedPuTTY X11 proxy: wrong authorisation protocol attemptedPuTTY X11 proxy: wrong authorisation protocol attemptedPuTTY X11 proxy: wrong authorisation protocol attemptedERROR - X needs to be running to perform ATI Overdrive(TM) commands

I followed this guide ( http://www.linuxcoin.co.uk/wiki/index.php/SSH_X11forwarding ), and its not working...

What im missing ?

3 BTC WHO DARE ME SOLVE THIS

did you do the "persistent way" or the "live way"? did you check the box to enable X11 forwarding in putty?
aldiyen
Newbie
*
Offline Offline

Activity: 18


View Profile
August 12, 2011, 04:08:19 AM
 #7

also, try: export DISPLAY=0.0
broken
Jr. Member
*
Offline Offline

Activity: 56


View Profile
August 12, 2011, 11:06:25 AM
 #8

I had the same problem when trying to run aticonfig from a remote shell.

aticonfig needs to be run from an active X Session, meaning you need to run it from withing gnome or kde.
You should try if this works.
There is a workaround to run aticonfig from a remote shell by using a screen session.
Install screen:
apt-get install screen

Login to your GUI (gnome) and open a screen via terminal:

screen -dmS ati
(creates a new screen in detached mode with name "ati")

Open a remote connection (ssh, with same user as above) and run:

screen -r ati
(attaches to screen)

from within this screen you should be able to run aticonfig.
I added a startup script for gnome which automatically starts a screen on startup, so i dont need a monitor  for that computer.

UPDATE: I´m using ubuntu 10.04 for mining and not LinuxCoin. I dont know if LinuxCoin comes with gnome or kde. I couldn´t find a way to run aticonfig without gnome or kde.

If you need a startup script, i will post one.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!