Bitcoin Forum
December 03, 2020, 08:15:13 AM *
News: Bitcointalk Community Awards
 
   Home   Help Search Login Register More  
Pages: [1]
  Print  
Author Topic: Amd 7950 low hashrate fastcoin in cgminer 3.72, max 300kh/s!!!!  (Read 2092 times)
NickPortland
Member
**
Offline Offline

Activity: 98
Merit: 10


View Profile
January 03, 2014, 08:23:12 PM
 #1

Here's my settings. I tried putting intensity up to 19 but it don't help!
Tried upping thread concurrency to 24,000 but that leads to kh/s in the double digits ?!?



"intensity" : "13",
"vectors" : "1",
"worksize" : "256",
"kernel" : "scrypt",
"lookup-gap" : "2",
"thread-concurrency" : "8192",
"shaders" : "1792",
"gpu-engine" : "0-1025",
"gpu-fan" : "65",
"gpu-memclock" : "1350",
"gpu-memdiff" : "0",
"gpu-powertune" : "0",
"gpu-vddc" : "0.000",
"temp-cutoff" : "95",
"temp-overheat" : "85",
"temp-target" : "75",
"api-port" : "4028",
"expiry" : "120",
"gpu-dyninterval" : "7",
"gpu-platform" : "0",
"gpu-threads" : "2",
"hotplug" : "5",
"log" : "5",
"queue" : "1",
"scan-time" : "30",
"scrypt" : true,
"temp-hysteresis" : "3",
"shares" : "0",

OS is Windows 8.1, gpu drivers are 13.251 (but I was using 13.10 up till today same results!)

Thanks in advance,

Nick

Official Ambassador for UTC-PND relations
*donations here*
 UTC: Ujff1xrc8brmHkRaFG3BcG5nVScXdh5Wu1 BTC: 159uuxJCfUsG44N52NUsydi2bCNeFSYyTi
1606983313
Hero Member
*
Offline Offline

Posts: 1606983313

View Profile Personal Message (Offline)

Ignore
1606983313
Reply with quote  #2

1606983313
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1606983313
Hero Member
*
Offline Offline

Posts: 1606983313

View Profile Personal Message (Offline)

Ignore
1606983313
Reply with quote  #2

1606983313
Report to moderator
1606983313
Hero Member
*
Offline Offline

Posts: 1606983313

View Profile Personal Message (Offline)

Ignore
1606983313
Reply with quote  #2

1606983313
Report to moderator
1606983313
Hero Member
*
Offline Offline

Posts: 1606983313

View Profile Personal Message (Offline)

Ignore
1606983313
Reply with quote  #2

1606983313
Report to moderator
pontiacg5
Sr. Member
****
Offline Offline

Activity: 364
Merit: 250



View Profile
January 03, 2014, 08:27:58 PM
 #2

Change GPU-threads to "1" and you should be able to run high TC and Intensity.

When stuck in -g 2 (threads) 7900 cards don't (seem to) like more than 4x shaders for TC, and I 13 is about max w/o hardware errors.

7950's seem best on -g 1 -I 19/20. 7970's always worked better at tc8192 I 13 for me.



Please DO NOT send me private messages asking for help setting up GPU miners. I will not respond!!!
NickPortland
Member
**
Offline Offline

Activity: 98
Merit: 10


View Profile
January 03, 2014, 08:35:17 PM
 #3

Change GPU-threads to "1" and you should be able to run high TC and Intensity.

When stuck in -g 2 (threads) 7900 cards don't (seem to) like more than 4x shaders for TC, and I 13 is about max w/o hardware errors.

7950's seem best on -g 1 -I 19/20. 7970's always worked better at tc8192 I 13 for me.



Ok thanks I'll try and report back asap


Ok with TC 16384 and G 1 I got 220 khs with intensity 13

Same settings with I=19 run at 300 khs, which was what I started with, plus make the pc unusable due to stuttering

Official Ambassador for UTC-PND relations
*donations here*
 UTC: Ujff1xrc8brmHkRaFG3BcG5nVScXdh5Wu1 BTC: 159uuxJCfUsG44N52NUsydi2bCNeFSYyTi
pontiacg5
Sr. Member
****
Offline Offline

Activity: 364
Merit: 250



View Profile
January 03, 2014, 08:41:31 PM
 #4

Change GPU-threads to "1" and you should be able to run high TC and Intensity.

When stuck in -g 2 (threads) 7900 cards don't (seem to) like more than 4x shaders for TC, and I 13 is about max w/o hardware errors.

7950's seem best on -g 1 -I 19/20. 7970's always worked better at tc8192 I 13 for me.



Ok thanks I'll try and report back asap


Ok with TC 16384 and G 1 I got 220 khs with intensity 13

Turn the intensity up, slowly. 20 is the max. You should see much closer to 600 at I19/20

You do understand WU and hardware errors right? Keep an eye out for each.

Edit: where did you come up with TC 16384? That value should be a multiple of your shader count, which is 1792 for a 7950. When using -g 1 you can get 8-12x shaders, with -g 2 4x shader count is probably max.

Does that make sense? I'm not the best at explaining...

Please DO NOT send me private messages asking for help setting up GPU miners. I will not respond!!!
NickPortland
Member
**
Offline Offline

Activity: 98
Merit: 10


View Profile
January 03, 2014, 09:24:23 PM
 #5

Change GPU-threads to "1" and you should be able to run high TC and Intensity.

When stuck in -g 2 (threads) 7900 cards don't (seem to) like more than 4x shaders for TC, and I 13 is about max w/o hardware errors.

7950's seem best on -g 1 -I 19/20. 7970's always worked better at tc8192 I 13 for me.



Ok thanks I'll try and report back asap


Ok with TC 16384 and G 1 I got 220 khs with intensity 13

Turn the intensity up, slowly. 20 is the max. You should see much closer to 600 at I19/20

You do understand WU and hardware errors right? Keep an eye out for each.

Edit: where did you come up with TC 16384? That value should be a multiple of your shader count, which is 1792 for a 7950. When using -g 1 you can get 8-12x shaders, with -g 2 4x shader count is probably max.

Does that make sense? I'm not the best at explaining...

Thanks a lot.

In order to get "16384" I  just doubled my previous TC which was 8192..

Anyway I think I found the problem.. monitoring GPU usage I noticed it went back and forth from 95% to 65%.

So I tried putting   "gpu-powertune" : "20" and that stopped it now going steady at 99% gpu usage.



However even reverting back to "gpu-powertune" : "0" the problem doesn't resurface and I (finally!) get a nice 500 kh/s with intensity: 13 and TC 8192 with g2



DO you know what "gpu-powertune"  is? What it does? I sure as heck don't?

If everything's fine I may tinker a bit with TC and G and intensity next.

I really appreciate your help,

Thanks.

Official Ambassador for UTC-PND relations
*donations here*
 UTC: Ujff1xrc8brmHkRaFG3BcG5nVScXdh5Wu1 BTC: 159uuxJCfUsG44N52NUsydi2bCNeFSYyTi
CoinThinker
Sr. Member
****
Offline Offline

Activity: 462
Merit: 250


Only the best is The be best...


View Profile
January 03, 2014, 09:46:15 PM
 #6

Powertune 20, means that it increase the power which is taken from the motherboard by 20%.

With one card you definitely shouldn't use this feature, unless you are overcloacking the gpu-engine, and gpu-memclock... You should be able to get out about 630 khash/sec with the right settings btw.

NickPortland
Member
**
Offline Offline

Activity: 98
Merit: 10


View Profile
January 04, 2014, 04:05:52 AM
 #7

Powertune 20, means that it increase the power which is taken from the motherboard by 20%.

With one card you definitely shouldn't use this feature, unless you are overcloacking the gpu-engine, and gpu-memclock... You should be able to get out about 630 khash/sec with the right settings btw.

Well they are overclocked from 925-1025 to the values above.

I know, I'm trying to get to 600 khs first.. I'd be happy about that already.

Official Ambassador for UTC-PND relations
*donations here*
 UTC: Ujff1xrc8brmHkRaFG3BcG5nVScXdh5Wu1 BTC: 159uuxJCfUsG44N52NUsydi2bCNeFSYyTi
CoinThinker
Sr. Member
****
Offline Offline

Activity: 462
Merit: 250


Only the best is The be best...


View Profile
January 04, 2014, 07:56:03 AM
 #8

Try with the following: I have changed some values, and removed some.
Once you start with this then please try to add thread-concurrency and increase the value until you can (up to 24000). After that try to increase intensity to 20. Forget about shaders.

Ps.: Also make sure that the config file is loaded correctly and no error message appears when you start cgminer.

"intensity" : "19",
"vectors" : "1",
"worksize" : "256",
"kernel" : "scrypt",
"lookup-gap" : "2",
"gpu-engine" : "1050",
"gpu-fan" : "85",
"gpu-memclock" : "1350",
"gpu-powertune" : "5",
"temp-cutoff" : "85",
"temp-overheat" : "80",
"temp-target" : "75",
"api-port" : "4028",
"expiry" : "120",
"gpu-dyninterval" : "7",
"gpu-platform" : "0",
"gpu-threads" : "1",
"hotplug" : "5",
"log" : "5",
"queue" : "1",
"scan-time" : "30",
"scrypt" : true,
"temp-hysteresis" : "3",
"shares" : "0",

NickPortland
Member
**
Offline Offline

Activity: 98
Merit: 10


View Profile
January 04, 2014, 08:39:00 AM
 #9

Try with the following: I have changed some values, and removed some.
Once you start with this then please try to add thread-concurrency and increase the value until you can (up to 24000). After that try to increase intensity to 20. Forget about shaders.

Ps.: Also make sure that the config file is loaded correctly and no error message appears when you start cgminer.

CUT


Hey bub I tried your settings, and managed to reach 24000 TC or whereabouts,  thanks, but:

- at I:19 the pc stutters so it's unusable (this is my main pc)

-I get lower kH/s than the current settings I have (which fare me 530 kH/s)

Which are as follows:
"intensity" : "13",
"vectors" : "1",
"worksize" : "256",
"kernel" : "scrypt",
"lookup-gap" : "2",
"thread-concurrency" : "8192",
"shaders" : "1792",
"gpu-engine" : "0-1025",
"gpu-fan" : "65-75",
"gpu-memclock" : "1350",
"gpu-memdiff" : "0",
"gpu-powertune" : "10",
"gpu-vddc" : "0.000",
"temp-cutoff" : "95",
"temp-overheat" : "85",
"temp-target" : "75",
"api-port" : "4028",
"expiry" : "120",
"gpu-dyninterval" : "7",
"gpu-platform" : "0",
"gpu-threads" : "2",
"hotplug" : "5",
"log" : "5",
"queue" : "1",
"scan-time" : "30",
"scrypt" : true,
"temp-hysteresis" : "3",
"shares" : "0",

It seems my card doesn't like gpu-threads:1 because no matter what other settings, it halves my khs.

Also worth mentioning I tried a lot of combos, be it higher intensity, TC, higher  powertune, but 530 seems to be an hardwall.

Official Ambassador for UTC-PND relations
*donations here*
 UTC: Ujff1xrc8brmHkRaFG3BcG5nVScXdh5Wu1 BTC: 159uuxJCfUsG44N52NUsydi2bCNeFSYyTi
Davidbc
Full Member
***
Offline Offline

Activity: 140
Merit: 100


View Profile
January 04, 2014, 09:53:50 AM
 #10

530 khash/s is a normal value for a stock 7950
NickPortland
Member
**
Offline Offline

Activity: 98
Merit: 10


View Profile
January 04, 2014, 11:21:24 AM
 #11

530 khash/s is a normal value for a stock 7950
Well it's not stock, it's overclocked and overvolted!

Ok I just tried oc'ing to 1100clock/1500mem + powertune upped to 20 and only gained approx 40kh/s to a whopping 570kh/s average..
Maybe a faulty card?

Official Ambassador for UTC-PND relations
*donations here*
 UTC: Ujff1xrc8brmHkRaFG3BcG5nVScXdh5Wu1 BTC: 159uuxJCfUsG44N52NUsydi2bCNeFSYyTi
pontiacg5
Sr. Member
****
Offline Offline

Activity: 364
Merit: 250



View Profile
January 04, 2014, 05:11:13 PM
 #12

530 khash/s is a normal value for a stock 7950
Well it's not stock, it's overclocked and overvolted!

Ok I just tried oc'ing to 1100clock/1500mem + powertune upped to 20 and only gained approx 40kh/s to a whopping 570kh/s average..
Maybe a faulty card?


No, you are just flogging it expecting huge numbers. Scrypt is not sha, it takes a delicate touch with tuning. 5mhz too much on memory or core can absolutely tank a good hashrate. It's all about finding the golden ratio. You are going about finding it wrong.

First, forget any and all overclock entirely. forget power tune, anything. Get the card running at it's absolute best, then start to overclock.

The PC is going to be unresponsive when mining at 100%. Sorry, but it's the nature of the beast. If you want the best hashrate you've got to deal with it.

8192 is also not a TC a 7950 should EVER run. I don't know how I can explain it any clearer, but the TC should be a multiple of the shader cores your GPU has. Shaders are irrelevant, except for finding the right TC.

8192 is 2048x4. 2048 shaders is a 7970, but you don't have a 7970. You have a 7950, so you should use 7168 or 7169 if g=2.








Please DO NOT send me private messages asking for help setting up GPU miners. I will not respond!!!
NickPortland
Member
**
Offline Offline

Activity: 98
Merit: 10


View Profile
January 04, 2014, 05:55:34 PM
 #13

530 khash/s is a normal value for a stock 7950
Well it's not stock, it's overclocked and overvolted!

Ok I just tried oc'ing to 1100clock/1500mem + powertune upped to 20 and only gained approx 40kh/s to a whopping 570kh/s average..
Maybe a faulty card?


No, you are just flogging it expecting huge numbers. Scrypt is not sha, it takes a delicate touch with tuning. 5mhz too much on memory or core can absolutely tank a good hashrate. It's all about finding the golden ratio. You are going about finding it wrong.

First, forget any and all overclock entirely. forget power tune, anything. Get the card running at it's absolute best, then start to overclock.

The PC is going to be unresponsive when mining at 100%. Sorry, but it's the nature of the beast. If you want the best hashrate you've got to deal with it.

8192 is also not a TC a 7950 should EVER run. I don't know how I can explain it any clearer, but the TC should be a multiple of the shader cores your GPU has. Shaders are irrelevant, except for finding the right TC.

8192 is 2048x4. 2048 shaders is a 7970, but you don't have a 7970. You have a 7950, so you should use 7168 or 7169 if g=2.


Pontiac I'm following people's suggestions, nothing more.
Believe me I tried dozens of settings with abysmail results. The only thing that boosted Khs is the powertune setting.

I got 8192 from posted settings by users, it seems lots of people are running that on 7950s. But I did try 7168 following your advice and khs was basically the same but a little lower.

So what do you suggest I should do next? I tried intensity settings from 13 to 14 to 16 to 17 to  19 and they improve things just slightly, 19 results in a 30khs increase only.

You say forget oc and powertune but what else should I tinker before that?

The latest try on oc values was from a guy with the same card as mine running the exact same settings but with 630 khs,so I gave it a shot, but to no avail.

Thanks in advance,

Nick.

Official Ambassador for UTC-PND relations
*donations here*
 UTC: Ujff1xrc8brmHkRaFG3BcG5nVScXdh5Wu1 BTC: 159uuxJCfUsG44N52NUsydi2bCNeFSYyTi
pontiacg5
Sr. Member
****
Offline Offline

Activity: 364
Merit: 250



View Profile
January 04, 2014, 06:18:47 PM
 #14

You are using the -setx varialbles, right? GPU_USE_SYNC_OBJECTS 1 and GPU_MAX_ALLOC_PERCENT 100?

This is how I start my batch files for launching cgminer

setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_USE_SYNC_OBJECTS 1
cgminer.exe --scrypt -o stratum+tcp://xxxx.com:3333 -u username.workername -p password --worksize 256 -g 1 --thread-concurrency XXXXX --I 19 --lookup-gap 2

This is where I would start. To find a good thread concurrency you can just wing it. There's another way, the scrypt-readme explains it better than I can.

Another thing, every time you run cgminer it makes a .bin file. It will look like this.

scrypt130511Tahitiglg2tc8192w256l4.bin

You need to delete all of these files in between setting changes, sometimes it does make a difference. You can also double check to see if your settings took in the filename...

Anyway, I'd start at 8x shaders for a TC. Keep increasing the multiplier value, deleting the bin file after every attempt. At some point cgminer will not start, that's the max TC you can run. Also, at some point too high of a TC might make a high hashrate, but with no WU or high HW errors. You need to watch that stuff while tuning. Don't be worried if the hashrate is low at this point, just watch the patterns.

After you've got the best TC you can start overclocking/matching clocks. Sometimes it's necessary to add "1" to the stable TC value to make it clock well. Anyway, I generally shoot for 1500 on the memory, and somewhere within .6-.8 of mem clock for the core clock. Start somewhere inside there and increase/decrease core clock 5mhz at a time. With only 1 gpu you shouldn't need powertune. When you are tuning this way you'll probably notice patterns. At some point the hashrate will deviate from what you'd expect from those patterns. That's one of the few times I'll play with powertune, and it does work.

That's kinda a rough explanation on how I start with a new card. If you want to try -g 2 just keep -I 13. You'll likely only need to try two TC values, 4x shaders and 5x shaders. 4 is usually the most for 7900 cards. After you've found the best TC, just tune the core and mem clock to each other like before.





Please DO NOT send me private messages asking for help setting up GPU miners. I will not respond!!!
NickPortland
Member
**
Offline Offline

Activity: 98
Merit: 10


View Profile
January 07, 2014, 01:59:21 AM
 #15

Ok, I did what you said, I found shadersx5 to be stabler even though less fast than shadersx4.
Then started trying out OC values.

"intensity" : "13",
"vectors" : "1",
"worksize" : "256",
"kernel" : "scrypt",
"lookup-gap" : "2",
"thread-concurrency" : "8961",
"gpu-engine" : "1160",
"gpu-fan" : "65-95",
"gpu-memclock" : "1450",
"gpu-powertune" : "20",
"temp-cutoff" : "95",
"temp-overheat" : "85",
"temp-target" : "75",
"api-port" : "4028",
"expiry" : "120",
"gpu-dyninterval" : "7",
"gpu-platform" : "0",
"gpu-threads" : "2",
"hotplug" : "5",
"log" : "5",
"queue" : "1",
"scan-time" : "30",
"scrypt" : true,
"temp-hysteresis" : "3",
"shares" : "0",

I'm getting about 605 kH/s with this config, do much better with 7168/9 but I get tons of HW errors.. weird.

Official Ambassador for UTC-PND relations
*donations here*
 UTC: Ujff1xrc8brmHkRaFG3BcG5nVScXdh5Wu1 BTC: 159uuxJCfUsG44N52NUsydi2bCNeFSYyTi
thehun
Legendary
*
Offline Offline

Activity: 1176
Merit: 1037



View Profile
January 07, 2014, 03:20:40 AM
 #16

Very interesting thread, as I am also in the process of fine-tuning my Sapphire 7950s (currently only 2 are active as the other 2 are for some reason not being detected).

I have found that setting a low TC (suck as 8961) gives me a very high number of HW errors, reducing my WU to around 150/m. Setting TC to maximum of 24000 virtually eliminates HW errors and WU stays stable at around 1080/m.

Setting I=20, P=18, mem=1350,  engine=1000 at launch I got between 575 to 585 KH stable

until now the best results have been achieved with M=1500 and E=1110, achieving around 610 KH/s.

I still don't understand how some people can get hashrates of 700 KH/s with the 7950s  Huh

Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!