Bitcoin Forum
February 27, 2017, 12:11:58 AM *
News: Latest stable version of Bitcoin Core: 0.13.2  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Warning: overflow encountered in uint_scalars  (Read 2322 times)
JesusTheCaffeine
Jr. Member
*
Offline Offline

Activity: 35


View Profile
March 05, 2011, 04:25:04 PM
 #1

I get this like 5 times every time I hit a share
319650 khash/sWarning: overflow encountered in uint_scalars
Warning: overflow encountered in uint_scalars
Warning: overflow encountered in uint_scalars
Warning: overflow encountered in uint_scalars
Warning: overflow encountered in uint_scalars
Warning: overflow encountered in uint_scalars
05/03/2011 10:17:31, 7e44781c, accepted 

This only happens in linux, in windows this does not happen. The payouts and shares/m are about the same. (I think linux has a bit more.)

System:
AMD X4 CPU
AMD 6950 with 6970 bios (This happened before I flashed the bios.) Furmark shows no artefacts at stock clocks.
Gentoo GNU/linux
ATI Stream 2.2
Momchil's gpu miner

Anybody else getting this.
It doesn't seem to affect mining but is kinda strange.
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
teknohog
Sr. Member
****
Offline Offline

Activity: 414


minor developer


View Profile WWW
March 11, 2011, 03:57:51 PM
 #2

Also happens to me in Linux, driver 10.12 and SDK 2.2. On all of my Radeons, 5570, 5770 and 5870.

I noticed this started when poclbm switched to the ArtForz kernel. In fact, on 5570 an older version is faster, and on 5770 there is no noticeable difference, so I keep using the older version for them.

JesusTheCaffeine
Jr. Member
*
Offline Offline

Activity: 35


View Profile
March 11, 2011, 07:39:14 PM
 #3

Well, I think it's because I'm still using python 2.6.

With 3.1 this doesn't happen but I don't notice any performance difference.
m0mchil
Full Member
***
Offline Offline

Activity: 171


View Profile
March 17, 2011, 09:42:07 AM
 #4

This warning appears here with PyOpenCL built with NumPy 1.5.1.

No warnings if using NumPy 1.4.1. I'll try to fix this in poclbm.

Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!