Bitcoin Forum
December 16, 2017, 09:28:37 AM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Help - can not raise thread concurrency *Reward*  (Read 841 times)
Smellbad
Newbie
*
Offline Offline

Activity: 18


View Profile
January 29, 2014, 03:19:42 AM
 #1

Driving me crazy. Setting up my 5th rig with MSI R9 290's.  Can not raise the thread concurrency higher than 8192 on -g 1 or -g 2.  I even tried with a different set of cards on the rig, Sapphire R9 280x toxic's.  Also tried memory from another rig.

Maxium buffer memory device 0 supports says 536870912
Your scrypt settings come to 536936448
Error -61: clCreateBuffer (padbuffer8), decrease TC or increase LG

Also if I run -g 1 - I 14 it causes a ton of hw.

System is a new build, Windows 7 64 bit, 12gb memory, MSI-970A-G46 main board, powered risers, 2 Corsair RM1000 psu's.

In every bat and it was also ran from cmd.
setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_USE_SYNC_OBJECTS 1

Catalyst Version   13.12

If anyone can solve this, I'll hook you up with some doggies, lottos, ect

Was I helpful?
BTC - 12apsaoXgdp29CCwvueT19WAgFgjGSbbfB
1513416517
Hero Member
*
Offline Offline

Posts: 1513416517

View Profile Personal Message (Offline)

Ignore
1513416517
Reply with quote  #2

1513416517
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1513416517
Hero Member
*
Offline Offline

Posts: 1513416517

View Profile Personal Message (Offline)

Ignore
1513416517
Reply with quote  #2

1513416517
Report to moderator
1513416517
Hero Member
*
Offline Offline

Posts: 1513416517

View Profile Personal Message (Offline)

Ignore
1513416517
Reply with quote  #2

1513416517
Report to moderator
1513416517
Hero Member
*
Offline Offline

Posts: 1513416517

View Profile Personal Message (Offline)

Ignore
1513416517
Reply with quote  #2

1513416517
Report to moderator
actuality
Jr. Member
*
Offline Offline

Activity: 32


View Profile
January 29, 2014, 03:58:05 AM
 #2

Gotta be drivers surely? Try uninstalling drivers, driver sweeping, re-installing drivers (maybe beta is its R9 cards you're struggling with) and also the APP SDK. Don't run any overclocking utilities either - feel like this is a software problem...
Smellbad
Newbie
*
Offline Offline

Activity: 18


View Profile
January 29, 2014, 06:02:07 AM
 #3

Driver swepted, installed beta, same issue.

If I remove --scrypt the R9's run at 800kh/s but get no accepts (due to the missing --scrypt).  I downloaded GUIminer and cards hashed at 770 each with accepts.  So what is going on with the sgminer and cgminer on this rig?

Was I helpful?
BTC - 12apsaoXgdp29CCwvueT19WAgFgjGSbbfB
crazyates
Legendary
*
Offline Offline

Activity: 952



View Profile
January 29, 2014, 06:06:09 AM
 #4

Can you post your whole config file, minus your pool info? Did you do something silly like not put a lookup-gap to 2?

Tips? 1crazy8pMqgwJ7tX7ZPZmyPwFbc6xZKM9
Previous Trade History - Sale Thread
maccd1
Jr. Member
*
Offline Offline

Activity: 42


View Profile
January 29, 2014, 08:48:58 AM
 #5


http://www.tomshardware.co.uk/forum/296408-31-psus-compute

MHW4jroUwUdwKgyqqXgaCtkLqxZrSogoT2
maccd1
Jr. Member
*
Offline Offline

Activity: 42


View Profile
January 29, 2014, 08:59:03 AM
 #6

https://bitcointalk.org/index.php?topic=433426.msg4756275#msg4756275

MHW4jroUwUdwKgyqqXgaCtkLqxZrSogoT2
maccd1
Jr. Member
*
Offline Offline

Activity: 42


View Profile
January 29, 2014, 09:10:53 AM
 #7

leaving the core clock at stock and raising your memory  clock to 1500 will give you tthe best results.  Raise powertune and Intensity to 20.

MHW4jroUwUdwKgyqqXgaCtkLqxZrSogoT2
breakbeater
Sr. Member
****
Offline Offline

Activity: 444


Life is a bitch, get used to it...


View Profile
January 29, 2014, 09:42:39 AM
 #8

what is your lookup-gap setting??
Smellbad
Newbie
*
Offline Offline

Activity: 18


View Profile
January 29, 2014, 10:20:38 PM
 #9

I wish that was true but negative.  7 hours last night, the rig beat me.

--This one gets the too high tc error 61, if I change tc to 8192 it will hash at around 450.
setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_USE_SYNC_OBJECTS 1
cgminer.exe --scrypt -o stratum+tcp://east1.us.stratum.dedicatedpool.com:3346 -u xxxxx -p xxxxxx --lookup-gap 2 --thread-concurrency 8193 -g 1 -I 13 -w 256 --auto-fan --gpu-fan 30-90 --temp-cutoff 98 --temp-overheat 90 --temp-target 82 --gpu-powertune 20 --gpu-memclock 1250 --gpu-engine 947 --expiry 1 --scan-time 1 --queue 0 --no-submit-stale

-- This one HW's like crazy (8192, -i 14)
setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_USE_SYNC_OBJECTS 1
cgminer.exe --scrypt -o stratum+tcp://east1.us.stratum.dedicatedpool.com:3346 -u xxxxx -p xxxxxx --lookup-gap 2 --thread-concurrency 8192 -g 1 -I 14 -w 256 --auto-fan --gpu-fan 30-90 --temp-cutoff 98 --temp-overheat 90 --temp-target 82 --gpu-powertune 20 --gpu-memclock 1250 --gpu-engine 947 --expiry 1 --scan-time 1 --queue 0 --no-submit-stale

Was I helpful?
BTC - 12apsaoXgdp29CCwvueT19WAgFgjGSbbfB
RB25
Hero Member
*****
Offline Offline

Activity: 656



View Profile
January 29, 2014, 10:41:57 PM
 #10

Which version of CGminer are you using?
Did you reinstall APP SDK?

USDE Development Team
Smellbad
Newbie
*
Offline Offline

Activity: 18


View Profile
January 29, 2014, 10:48:42 PM
 #11

Which version of CGminer are you using?
Did you reinstall APP SDK?

Cgminer 3.7.2 and Sgminer 4.0.0

Will do a uninstall and re-install of app sdk as soon as I get home from work.

Was I helpful?
BTC - 12apsaoXgdp29CCwvueT19WAgFgjGSbbfB
RB25
Hero Member
*****
Offline Offline

Activity: 656



View Profile
January 29, 2014, 10:53:43 PM
 #12

Which version of CGminer are you using?
Did you reinstall APP SDK?

Cgminer 3.7.2 and Sgminer 4.0.0

Will do a uninstall and re-install of app sdk as soon as I get home from work.

Also, try Intensity at 12 and see if you can raise the TC.

USDE Development Team
akaCash
Member
**
Offline Offline

Activity: 72

I learn fast :)


View Profile
January 29, 2014, 11:05:58 PM
 #13

Ok, so the top one, with the 2 lines above your cgminer.exe....... cmd call is what you want to use. The reason you're hashing so low is because of your low TC. Raise your TC to 24,000 to start, and then go up from there until you find the right settings. You needed those 2 lines you now have to increase your TC above the default spec limit. I had the same issue on a set of my cards. Increase your TC to 24000 and your intensity to 17 to start, and then just tweak from there. Also don't be afraid to strip a lot of those settings your using there as you can control or keep an eye on some of it yourself. I've found most aren't needed personally. https://litecoin.info/Mining_hardware_comparison is an excellent source of information as people have their config calls listed there. You'll see most aren't that long at all. I started there though and tweaked a few my TC and Intensity until I found the best combo for me, you shouldn't have any prob doing the same now.

Edit: Ok, so I just saw you can't get past the TC limit, which is odd with you using the proper:

setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_USE_SYNC_OBJECTS 1

The only thing I can think of is to run the actual batch file itself and insert those 2 lines above it, or and you can try this either way, but maybe right click and run as admin. Maybe since it's a fresh build you need to set the environment variable and you have to "Run as Administrator" to do so. Just seems odd that you'd still be getting the TC error with those 2 lines in your batch file. I had the same problem on the one I just built, but as soon as I added those to the batch file I was good. I can't say for sure I didn't right click and do that once or twice though. I was getting pretty frustrated as I'm sure you are, and I was trying tons of stuff. Good luck though and hope it works out for ya.

Any donations greatly appeciated!
BTC = 12aSS1d7Sy6MQDmxSZ59kK5uhVL8UjuKdR
LTC = LLoxWcXWwnnJ5Mo6xQpFuZcodLyyBxoorf
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!