Bitcoin Forum
December 03, 2016, 01:52:47 PM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: ATI catalyst driver 11.4 & APP SDK 2.4 BETA  (Read 12953 times)
dishwara
Legendary
*
Offline Offline

Activity: 1372


Truth may get delay, but NEVER fails


View Profile
March 15, 2011, 08:15:25 PM
 #1

Hi,

I yesterday came across preview (beta) of next ati catalyst driver.
They call it 11.4 instead of 11.3(don't know why) & stream SDK, which was renamed to APP SDK 2.4 is also in that package.
I downloaded & tested & mining & found it reducing poclbm 25 or 50% usage to 0 even with/without -f1 & also it reduces gpu use from straight 99 to variable 92 - 99%
I have HD6870 & at 1038 core & 370 mem with 100% fan & 66C temp, i am getting 274-277 Mhash/s in windows 7 32 bit with aero.

I see some odd thing, many or i say all suggest to use -w128 while the max atleast 6870 supports is 256, so putting -w256 actually increases 2-6 Mhash/s.

U can find BETA of 11.4 & sdk 2.4 here.
http://support.amd.com/us/kbarticles/Pages/Catalyst114earlypreview.aspx

Just update without uninstall & select custom instead of express to not install useless things like hydra, eyinfinity...for mining.
I installed only these 3, Ati display driver, Ati catalyst install manager & APP SDK 2.4 & VC++ 2010.

Any ideas , feedback are welcome & also some 1 or 2 bitcoins.
I can't able to get more than 3-4 with my card daily.
Thanks.

1480773167
Hero Member
*
Offline Offline

Posts: 1480773167

View Profile Personal Message (Offline)

Ignore
1480773167
Reply with quote  #2

1480773167
Report to moderator
1480773167
Hero Member
*
Offline Offline

Posts: 1480773167

View Profile Personal Message (Offline)

Ignore
1480773167
Reply with quote  #2

1480773167
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1480773167
Hero Member
*
Offline Offline

Posts: 1480773167

View Profile Personal Message (Offline)

Ignore
1480773167
Reply with quote  #2

1480773167
Report to moderator
1480773167
Hero Member
*
Offline Offline

Posts: 1480773167

View Profile Personal Message (Offline)

Ignore
1480773167
Reply with quote  #2

1480773167
Report to moderator
demonofelru
Full Member
***
Offline Offline

Activity: 238



View Profile
March 15, 2011, 08:39:48 PM
 #2

Hello did you normally get less or more?

Names do not matter; however, if you insist...id...
grue
Global Moderator
Legendary
*
Offline Offline

Activity: 1932



View Profile
March 15, 2011, 08:43:30 PM
 #3

is it:
faster than 2.3?
faster than 2.2?
faster than 2.1?

It is pitch black. You are likely to be eaten by a grue.

Tired of annoying signature ads? Ad block for signatures
Garrett Burgwardt
Sr. Member
****
Offline Offline

Activity: 350



View Profile
March 15, 2011, 09:03:07 PM
 #4

Doesn't seem to lower CPU usage at all for my 5970. Oh well, sent .2 btc for pointing out the beta. Cheesy thanks!
Beremat
Member
**
Offline Offline

Activity: 118


View Profile
March 15, 2011, 09:44:55 PM
 #5

Doesn't seem to lower CPU usage at all for my 5970. Oh well, sent .2 btc for pointing out the beta. Cheesy thanks!
Same, running a 5870 + 4850 here in W7 64-bit, no changes, BUT I *think* my hashrate has gone up slightly on my 5870. I'm not sure though, I wasn't monitoring it too closely anyways.
dishwara
Legendary
*
Offline Offline

Activity: 1372


Truth may get delay, but NEVER fails


View Profile
March 15, 2011, 11:12:16 PM
 #6

Hello did you normally get less or more?

I got less before & now i feel getting a little bit more.
& more over, i see the gpu usage is ranging from 85 -99% instead of straight 99% as before.
Also while my CPU TIME in task manager, for system idle process says 109:18:09, i think i am running system for 3-4 days without reboot.
But for the poclbm.exe it says cpu time 0.00.06 with 44,520K memory & guiminer.exe says cpu time 0.03.36 with memory 28,772K.
I am sure guiminer & poclbm is running for past one day without exit.
since, it says 600+176+4470 shares, so around 5000 shares. I run my card in many pools & keep on changing for testing & to get some more coins..
With my HD6870 i think at most i can get 250-300 shares per hour. 260-278 Mhash/s i got. & also some times to stop miners for installing & uninstalling sdk's.


is it:
faster than 2.3?
faster than 2.2?
faster than 2.1?

I am not sure about 2.1 & 2.2. But i am sure it is slightly faster than 2.3 & more over it takes 0 cpu for pocblm & also less gpu usage.
So, something is there, & please test it to make sure.
I am new to mining & graphics stuff, programming.....only thing i know is 5970 has 3200 shaders & was fastest in mining.
But seems due to 11.4 & 2.4 may be 6990 with 3072 core (instead of 3200 in 5970) can beat 5970 in mining.


Doesn't seem to lower CPU usage at all for my 5970. Oh well, sent .2 btc for pointing out the beta. Cheesy thanks!

Thanks for the tip.
geebus
Sr. Member
****
Offline Offline

Activity: 258



View Profile WWW
March 15, 2011, 11:43:54 PM
 #7

I'm using it right now on:

Windows 7 x64
Radeon HD6970
Radeon HD5770

Both cards saw a 1-2 Mhash/s increase, but nothing substantial.

As far as the SDK version go, here:

HD6970 -
2.2 > 2.1
2.3 > 2.2
2.4==2.3

HD5770 -
2.2 < 2.1
2.3 > 2.2
2.4==2.3

Feel like donating to me? BTC Address: 14eUVSgBSzLpHXGAfbN9BojXTWvTb91SHJ
grue
Global Moderator
Legendary
*
Offline Offline

Activity: 1932



View Profile
March 15, 2011, 11:57:49 PM
 #8

HD6970 -
2.2 > 2.1
2.3 > 2.2
2.4==2.3

HD5770 -
2.2 < 2.1
2.3 > 2.2
2.4==2.3
wait, isn't 2.3 slower than 2.2?

It is pitch black. You are likely to be eaten by a grue.

Tired of annoying signature ads? Ad block for signatures
Littleshop
Legendary
*
Offline Offline

Activity: 1316



View Profile WWW
March 16, 2011, 01:59:54 AM
 #9

I saw almost no difference between 2.3 and 2.4.  Maybe 2.4 is 1% faster but I am not sure because the numbers keep changing.  At some point maybe I should reformat and load 2.1.   


JWU42
Legendary
*
Offline Offline

Activity: 1484


View Profile
March 16, 2011, 11:25:10 AM
 #10

I'm using it right now on:

Windows 7 x64
Radeon HD6970
Radeon HD5770

Both cards saw a 1-2 Mhash/s increase, but nothing substantial.

As far as the SDK version go, here:

HD6970 -
2.2 > 2.1
2.3 > 2.2
2.4==2.3

I didn't think you could run anything less than 2.3 with a 69xx series?

I went from just a 5770 (2.1 w/ 10.11) and no CPU usage to 11.2 and 2.3 and 25% cpu usage (12.5% per poclbm thread).  WOuld love to see that CPU usage get back towards zero...

EDIT:  Just installed and less than a 1% increase - picked up maybe 3Mhash/s between the 5770 and 6950 combined.

GPG PubKey | THREEMA | OTC | HeatWare | 1JWU42QLGFESoQCC4iPzUDTRiC9nx5bi95
dishwara
Legendary
*
Offline Offline

Activity: 1372


Truth may get delay, but NEVER fails


View Profile
March 16, 2011, 06:12:19 PM
 #11

You all installed just sdk 2.4 or both 11.4 & sdk 2.4?

Coz, i Installed 11.4 ati display driver & sdk or app 2.4 & still seeing ZERO %



I tried with 2.2 & 2.1, but with 11.4 they cant recognize by windows or cards.
Seems its due to change in installation path or something.
coz 2.3 installs at C:\Program Files\AMD APP\bin\x86, while 2.2 & 2.1 installs at C:\Program Files\ATI Stream\bin\x86 .

I have to uninstall 11.4 & then try 10.12 or less to check 2.2 or 2.1
Coz, just uninstalling 2.4 from 11.4 & installing just sdk 2.1 & 2.2 & 2.3(not sure abt 2.3 coz forgot) from "http://download2-developer.amd.com/amd/Stream20GA/ati-stream-sdk-v2.1-vista-win7-32.exe" seems useless.

I do later & tell.
Besides you guys try with 11.4 if tried only 2.4
JWU42
Legendary
*
Offline Offline

Activity: 1484


View Profile
March 16, 2011, 06:59:26 PM
 #12

I ran the uninstall all ATI, reboot, ran the 11.4 beta preview which installed the 11.4 and OpenCL 2.4 (according to GPU Caps) rebooted again.

As mentioned, each thread of poclbm is using 12.5% (I have an i7-920 @ stock with HT enabled).  I am running it on a 6950 and 5770 (so two threads = 25% CPU usage).

One thought - what flags are you passing to poclbm?

I am using...
Code:
-v -w128 -f2

GPG PubKey | THREEMA | OTC | HeatWare | 1JWU42QLGFESoQCC4iPzUDTRiC9nx5bi95
dishwara
Legendary
*
Offline Offline

Activity: 1372


Truth may get delay, but NEVER fails


View Profile
March 16, 2011, 07:35:13 PM
 #13

mostly i use -v -w128 -f1.
I have quad coreQ8400 @ 2.66Ghz, windows 7 32 with aero enabled.
Before with 11.2 & 2.3 , if i run -f1 then even minimize & maximize was slower, now no lag.
HD6870 OC to 1047 core clk, 370 mem clk, fan 100% , temp is 65C-66C & getting 270 Mhash/s
I use GUI pocblm.
Its really strange why some gets 25% or less cpu usage & i get zero.

7 hours later,

Grinder
Legendary
*
Offline Offline

Activity: 1269


View Profile
March 16, 2011, 07:48:35 PM
 #14

Do you have one or more GPUs? The problem with 100% CPU is only there if you have more than one.
m4rkiz
Full Member
***
Offline Offline

Activity: 170


View Profile
March 16, 2011, 08:20:39 PM
 #15

still have ~50% cpu usage with those beta drivers when using 5970, after installation (and before reboot) i had ~2% BUT only one gpu core was visible (also - almost no cpu usage with 5870)

so i guess that it is multi cpu specific indeed
dishwara
Legendary
*
Offline Offline

Activity: 1372


Truth may get delay, but NEVER fails


View Profile
March 16, 2011, 08:52:58 PM
 #16

I have only one GPU, i mean only one card, HD6870 in my pc
JWU42
Legendary
*
Offline Offline

Activity: 1484


View Profile
March 16, 2011, 09:53:58 PM
 #17

Grinder,

That might be it for me - 2 GPU's (5770 and 6950).

GPG PubKey | THREEMA | OTC | HeatWare | 1JWU42QLGFESoQCC4iPzUDTRiC9nx5bi95
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!