Bitcoin Forum
July 21, 2024, 08:38:24 PM *
News: Latest Bitcoin Core release: 27.0 [Torrent]
 
   Home   Help Search Login Register More  
Pages: [1]
  Print  
Author Topic: Optimal .conf file for HD5850 (CGminer/SGminer)  (Read 6819 times)
ToScA- (OP)
Sr. Member
****
Offline Offline

Activity: 335
Merit: 250


View Profile
February 05, 2014, 04:45:23 PM
 #1

Hi!

I'm about to use a dual-GPU mining rig (a Sapphire R9 290 Tri-X OC and an Asus Radeon 5850).

I'm wondering what .conf parameters others are using for their 5850s in CGminer or SGminer?

Not a .bat-file by the way, but a .conf-file. I'm not very good at converting my .bat-settings to .conf as it never works out well; always some parameter missing Tongue

Any help is MUCH appreciated!

Thanks!!
ToScA- (OP)
Sr. Member
****
Offline Offline

Activity: 335
Merit: 250


View Profile
February 05, 2014, 07:19:27 PM
 #2

Slight bump.

I tried these settings for the 5850. It worked well initially, but after a few minutes, SGMiner showed status "SICK", followed a few minutes later på "DEAD"

What am I doing wrong? Sad


{
"pools" : [
{
"name" : "netcodepool.org",
"url" : "stratum+tcp://netcodepool.org:3333",
"user" : "username.worker",
"pass" : "x"
}
],
"scrypt" : true,
"auto-fan" : true,
"gpu-threads" : "1",
"gpu-engine" : "0-850",
"gpu-fan" : "0-100",
"gpu-memclock" : "0-1025",
"gpu-memdiff" : "0",
"gpu-powertune" : "0",
"gpu-vddc" : "0.000",
"intensity" : "19",
"temp-target" : "70",
"temp-overheat" : "85",
"temp-cutoff" : "95",
"vectors" : "1",
"worksize" : "256",
"lookup-gap" : "0",
"shaders" : "0",
"thread-concurrency" : "5824"
}
mindsplit
Newbie
*
Offline Offline

Activity: 22
Merit: 0


View Profile
February 05, 2014, 08:27:35 PM
 #3

Did you check the temperature? Try a lower intensity setting.
Also I think you can remove these lines if you use sgminer:
"gpu-memdiff" : "0",
"gpu-powertune" : "0",
"gpu-vddc" : "0.000",
"vectors" : "1",
"shaders" : "0",
"scrypt" : true,
ToScA- (OP)
Sr. Member
****
Offline Offline

Activity: 335
Merit: 250


View Profile
February 05, 2014, 09:25:42 PM
 #4

Did you check the temperature? Try a lower intensity setting.
Also I think you can remove these lines if you use sgminer:
"gpu-memdiff" : "0",
"gpu-powertune" : "0",
"gpu-vddc" : "0.000",
"vectors" : "1",
"shaders" : "0",
"scrypt" : true,

Thanks for your advice!

I haven't made much progress, I always get some kind of display driver error now on the 5850. The R9 290 runs fine though. Current config for both GPUs: (first being the 5850, second is the R9 290)

"api-allow" : "W:127.0.0.1",
"api-listen" : true,
"api-port" : "4028",
"expiry" : "120",
"failover-only" : true,
"kernel-path" : "/usr/local/bin",
"log" : "5",
"queue" : "1",
"scan-time" : "60",
"auto-fan" : true,
"gpu-threads" : "1",
"gpu-engine" : "725,1000",
"gpu-fan" : "0-100,50-90",
"gpu-memclock" : "1000,1350",
"gpu-reorder" : true,
"intensity" : "13,20",
"temp-target" : "70",
"temp-overheat" : "95",
"temp-cutoff" : "99",
"temp-hysteresis" : "3",
"worksize" : "256",
"lookup-gap" : "0,2",
"thread-concurrency" : "5824,32765"

}

These were my .bat-file srttings for 5850 before I bought the R9 290:

-I 13 -g 1 -w 256 --thread-concurrency 5824

I don't get what I'm doing wrong. Sad There's obviously more parameters in the .conf-file, but I don't know what to change.
drdanger_pi
Newbie
*
Offline Offline

Activity: 1
Merit: 0


View Profile
February 09, 2014, 04:51:28 PM
 #5

I'm getting 340 Kh/s  Grin with sgminer using the following script:

"intensity" : "21",
"worksize" : "256",
"kernel" : "ckolivas",
"lookup-gap" : "2",
"thread-concurrency" : "5864",
"gpu-engine" : "0-800",
"gpu-fan" : "0-85",
"gpu-memclock" : "1150",
"gpu-memdiff" : "0",
"gpu-powertune" : "0",
"gpu-vddc" : "0.000",
"gpu-dyninterval" : "7",
"gpu-platform" : "0",

I would like to try the new kernels that comes with sgminer, but it looks like you need to retune the thread-concurrency
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!