Bitcoin Forum
December 11, 2016, 06:28:28 AM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Flash & media players lower core MHZ and hash speed! (List of programs within.)  (Read 4411 times)
Cablesaurus
Sr. Member
****
Offline Offline

Activity: 302



View Profile WWW
March 16, 2011, 09:58:03 PM
 #1

If you use a miner on a machine that also serves video from Flash and other programs, you may run into an issue where your core is downclocked on certain cards, thus drastically lowering your hashrate. This occurs on the 5970, and perhaps other cards as well.

It seems this can be negated in Flash Player by doing the following:
1) Right-click a running Flash video window
2) Select "Settings"
3) Uncheck "Enable Hardware Acceleration." [If "Settings" is Greyed Out, re-attempt from a non Youtube video and it should be clickable. The change should carry back to all other FLV's.]



Update: Many media programs are starting to include Hardware Acceleration built into their new versions! Post if you know of a program that's caused hashrate issues related to such downclocking!

Flash Player 10.x
VLC Media Player 1.1

PCIe Extender Cables; Dummy Plugs, Fans; PSU Cables; Cases & More
Visit www.Cablesaurus.com and our forum thread at http://bitcointalk.org/index.php?topic=6128.0
1481437708
Hero Member
*
Offline Offline

Posts: 1481437708

View Profile Personal Message (Offline)

Ignore
1481437708
Reply with quote  #2

1481437708
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481437708
Hero Member
*
Offline Offline

Posts: 1481437708

View Profile Personal Message (Offline)

Ignore
1481437708
Reply with quote  #2

1481437708
Report to moderator
grue
Global Moderator
Legendary
*
Offline Offline

Activity: 1932



View Profile
March 16, 2011, 11:55:30 PM
 #2

disable hardware acceleration?

It is pitch black. You are likely to be eaten by a grue.

Tired of annoying signature ads? Ad block for signatures
TenthReality
Member
**
Offline Offline

Activity: 76


View Profile
March 16, 2011, 11:56:55 PM
 #3

IE under 7 with the same card has the issue you mention however if I swap to something non-IE it is a non-issue.  Could this be a side effect of the recent GPU/DirectX enhancements to IE FireFox and other browsers don't have an issue with?

Just use FireFox, appears to be a non issue.
Ownski
Full Member
***
Offline Offline

Activity: 180



View Profile
March 17, 2011, 01:06:17 AM
 #4

Flash 10 now uses gpu accelration so you can't watch youtube while mining because it will interfere with your miner and lower your mhash/s

Money is the oldest magic trick in the book.
ArtForz
Sr. Member
****
Offline Offline

Activity: 406


View Profile
March 17, 2011, 02:01:26 AM
 #5

The problem iirc is, if anything uses gpu video acceleration, ATI driver switches to "media playback" clock, which is 400 core/max mem.
Possible solutions:
a) enable overdrive, manually edit the overdrive config .xml to change state 2 core clock to state 0 core clock
b) use RBE to hack the cards BIOS and change the clocks/voltages for the 400 mhz core/max mem clock state there to have same high core clk as normal 3d mode state.

bitcoin: 1Fb77Xq5ePFER8GtKRn2KDbDTVpJKfKmpz
i0coin: jNdvyvd6v6gV3kVJLD7HsB5ZwHyHwAkfdw
Cablesaurus
Sr. Member
****
Offline Offline

Activity: 302



View Profile WWW
March 17, 2011, 02:21:56 AM
 #6

It seems this can be negated in Flash Player by doing the following:
1) Right-click a running Flash video window
2) Select "Settings"
3) Uncheck "Enable Hardware Acceleration." [If "Settings" is Greyed Out, re-attempt from a non Youtube video and it should be clickable. The change should carry back to all other FLV's.]



If this fix helps you donations of course much appreciated!

PCIe Extender Cables; Dummy Plugs, Fans; PSU Cables; Cases & More
Visit www.Cablesaurus.com and our forum thread at http://bitcointalk.org/index.php?topic=6128.0
ArtForz
Sr. Member
****
Offline Offline

Activity: 406


View Profile
March 17, 2011, 02:31:52 AM
 #7

yeah, that disables hardware video accel for flash, use any other media played that uses it and it's back to 400Mhz clock though.

bitcoin: 1Fb77Xq5ePFER8GtKRn2KDbDTVpJKfKmpz
i0coin: jNdvyvd6v6gV3kVJLD7HsB5ZwHyHwAkfdw
Cablesaurus
Sr. Member
****
Offline Offline

Activity: 302



View Profile WWW
March 17, 2011, 02:47:56 AM
 #8

Guess I won't be updating my VLC anytime soon then.

However if anyone knows of other programs that DO use such hardware acceleration please post them here and I'll update the list in the main post.

PCIe Extender Cables; Dummy Plugs, Fans; PSU Cables; Cases & More
Visit www.Cablesaurus.com and our forum thread at http://bitcointalk.org/index.php?topic=6128.0
dishwara
Legendary
*
Offline Offline

Activity: 1386

Truth may get delay, but NEVER fails


View Profile
March 17, 2011, 07:47:31 PM
 #9

I really don't understand what this post saying.
I have HD6870 & mining mostly with -v-w128 -f 1-15(anything depends other pgms)



You saying the red circle in the picture.
I always see other programs respond slow when i am mining at -f1,
Watching videos avi, mkv,youtube....gets slower, so i change -f1 to f15 or more.
After i change that, i see my hash rates goes down by some 20-30 depending on the video i see & when i listen music, i dont have to change -f1, winamp plays well.
VlC version is 1.1.7.

But i never saw CORE Mhz dropping. How should it drop?
Once i start system, my core & mem clk goes to default (900 & 1050) & i open MSI afterburner which increases core to what i set, but mem clocks dont get lower auto, so i reduce to max low, close afterburner & open again & now mem clk shows last set max low in middle & i further low it to 370. thats it. whether i mine or not, watching videos or not, until another reboot, i don't see any core or mem clk change.

Ah, now i got it, its due to catalyst control center which is installed by default. which has overdrive which changes it.
Please uninstall catalyst control center, if u dont feel needed.
I only installed ATI display driver, APP 2.3 or 2.4, vc++ & ATI catalyst install manager.
removed catalyst control center, WMV9/VC-1, AVIVO, Hydra, amd drag & drop, application profile.

I see no difference in running my system with the above only installed.
Hope this helps & can tip me also, if u feel
TenthReality
Member
**
Offline Offline

Activity: 76


View Profile
March 17, 2011, 08:31:44 PM
 #10

Add WinRar and 7zip to the list.  With WinRAR you seem to get about a 10-15% reduction in hashing, but it also seems to depend on how large the rarset is.  Smaller sets/files seem to be kept at the CPU, but if its a larger (100meg+) set, the GPU gets into the mix.

7zip seems to make use of the GPU no matter what, but reduction was less, 5%-10%.
urizane
Jr. Member
*
Offline Offline

Activity: 56



View Profile
March 18, 2011, 03:05:04 AM
 #11

It's not that WinRAR or 7zip use your GPU at all, it's the fact that once you make your CPU busy beyond a certain point, it can't keep the thread that feeds your GPU data to crunch running fast enough.  Try running Prime95 at the same time as a GPU miner.  If you have HyperThreading, this effect is more pronounced.
TenthReality
Member
**
Offline Offline

Activity: 76


View Profile
March 18, 2011, 01:26:40 PM
 #12

It's not that WinRAR or 7zip use your GPU at all, it's the fact that once you make your CPU busy beyond a certain point, it can't keep the thread that feeds your GPU data to crunch running fast enough.  Try running Prime95 at the same time as a GPU miner.  If you have HyperThreading, this effect is more pronounced.

With WinRAR that seems to be true, good catch, with 7zip, my CPU never went over 40%, so pleanty leftover.   If I get some time tonight I'll actually watch the GPU with debuggers to see whats shaking there. 
Grinder
Legendary
*
Offline Offline

Activity: 1269


View Profile
March 18, 2011, 02:25:09 PM
 #13

Just give the CPU intensive processes lower priority than the miner and you should be fine. Hyperthreading might mess it up, though.
dishwara
Legendary
*
Offline Offline

Activity: 1386

Truth may get delay, but NEVER fails


View Profile
March 18, 2011, 07:00:25 PM
 #14

It seems this can be negated in Flash Player by doing the following:
1) Right-click a running Flash video window
2) Select "Settings"
3) Uncheck "Enable Hardware Acceleration." [If "Settings" is Greyed Out, re-attempt from a non Youtube video and it should be clickable. The change should carry back to all other FLV's.]



If this fix helps you donations of course much appreciated!


Can u please explain me from my above post?
Did you saying to disable what i marked in red?
Thanks.
Cablesaurus
Sr. Member
****
Offline Offline

Activity: 302



View Profile WWW
March 18, 2011, 07:45:44 PM
 #15

It seems this can be negated in Flash Player by doing the following:
1) Right-click a running Flash video window
2) Select "Settings"
3) Uncheck "Enable Hardware Acceleration." [If "Settings" is Greyed Out, re-attempt from a non Youtube video and it should be clickable. The change should carry back to all other FLV's.]



If this fix helps you donations of course much appreciated!


Can u please explain me from my above post?
Did you saying to disable what i marked in red?
Thanks.

Sure thing, from my understanding you would uncheck that in VLC. However I have not used that new version of VLC and have an older one without that feature, installed. It should take care of the issue though, if VLC is causing hashrate decreases on your machine.

PCIe Extender Cables; Dummy Plugs, Fans; PSU Cables; Cases & More
Visit www.Cablesaurus.com and our forum thread at http://bitcointalk.org/index.php?topic=6128.0
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!