Bitcoin Forum
December 17, 2017, 06:07:35 PM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: [SOLVED]Probleem compilen cgminer 3.7.2 Xubuntu 12.04[SOLVED]  (Read 581 times)
Xubu
Full Member
***
Offline Offline

Activity: 238


View Profile
February 08, 2014, 04:33:26 AM
 #1

Hoi iedereen.

Xubuntu probleempje.
De installer van cgminer-3.7.2-x86_64-built.tar.bz die ik eerder al gebruikte, is niet meer te vinden op http://ck.kolivas.org/apps/cgminer/3.7/.

Het pakket dat wel te downloaden is  cgminer-3.7.2.tar.bz2 krijg ik helaas niet aan de praat. Het probleem dat ik ondervind is dat het geen built package is. Naar mijn mening dient dit pakket nog manueel "gebuilt" te worden. Ik bezit echter niet de technische kennis om dit werkende te krijgen.


Informatie over men nieuwe Hardware waarop de configuratie dient gedaan te worden :

GPU : 2 X Sapphire R9 280X Toxic
AMD drivers : AMD Catalyst™ 13.12 Proprietary Linux x86 Display Driver


De GPU s worden perfect herkend in het systeem met het commando : sudo aticonfig --adapter=all --odgt, dus na de correcte installatie van cgminer zou alles probleemloos moeten werken.


1513534055
Hero Member
*
Offline Offline

Posts: 1513534055

View Profile Personal Message (Offline)

Ignore
1513534055
Reply with quote  #2

1513534055
Report to moderator
1513534055
Hero Member
*
Offline Offline

Posts: 1513534055

View Profile Personal Message (Offline)

Ignore
1513534055
Reply with quote  #2

1513534055
Report to moderator
1513534055
Hero Member
*
Offline Offline

Posts: 1513534055

View Profile Personal Message (Offline)

Ignore
1513534055
Reply with quote  #2

1513534055
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1513534055
Hero Member
*
Offline Offline

Posts: 1513534055

View Profile Personal Message (Offline)

Ignore
1513534055
Reply with quote  #2

1513534055
Report to moderator
1513534055
Hero Member
*
Offline Offline

Posts: 1513534055

View Profile Personal Message (Offline)

Ignore
1513534055
Reply with quote  #2

1513534055
Report to moderator
SanchoBunce
Jr. Member
*
Offline Offline

Activity: 42


View Profile
February 08, 2014, 09:43:03 AM
 #2

Ik ken er nog mindervan maar had er ook problemen mee .
Heb dan maar smos linux gedownload. Zie de thread op het engelstalig gedeelte.
Downloaden op usb schrijven met windisk inpluggen en opstarten .
Moet je enkel nog in je browser de ip van je rig inlopen met :8080 achter en dan kan je jouw pool en settings aanpassen
bhai
Member
**
Offline Offline

Activity: 93


View Profile
February 08, 2014, 10:08:34 AM
 #3

xebu

PM even je details dan gaan we er uit komen Smiley

root access is in ieder geval nodig.

Of wat je kan doen wat SanchoBunce zegt Smiley

Heb je gelijk wat statistieken e.d.

rgdz,
bhai
koelen3
Legendary
*
Offline Offline

Activity: 980


Sooner or later, a man who wears two faces forgets


View Profile
February 08, 2014, 11:47:05 AM
 #4

Geef mij een secondje, ik schrijf hier dadelijk de commands neer die je moet uitvoeren.
koelen3
Legendary
*
Offline Offline

Activity: 980


Sooner or later, a man who wears two faces forgets


View Profile
February 08, 2014, 11:58:20 AM
 #5

Code:
wget http://ck.kolivas.org/apps/cgminer/3.7/cgminer-3.7.2.tar.bz2
tar jvxf cgminer-3.7.2-x86_64-built

Dit download en installeert je cgminer.
Eventueel kan je het bz2 pakket dat je hebt gedownloaded verwijderen na de installatie.
Dit doe je door de volgende command:

Code:
rm *.bz2

Je kan het mapje van cgminer rechtsonder vinden in die blauwe map.
Of je typt manueel in je terminal de volgende command:

Code:
cd cgminer-3.7.2-x86_64-built

Je moet wel altijd voor je je cgminer het volgende ingeven:

Code:
export DISPLAY=:0
export GPU_USE_SYNC_OBJECTS=1

En je spreekt je cgminer dan aan net de volgende command:

Code:
./cgminer --scrypt -o pool -u user -p password

Waar je je pooladres ingeeft, je user en je password.
Daarna volgen alle andere elementen, zoals -w --thread-concurrency en dergelijke.

Als je verdere vragen hebt, stel ze gerust Wink
Xubu
Full Member
***
Offline Offline

Activity: 238


View Profile
February 08, 2014, 12:57:48 PM
 #6

Hoi,

Bedankt voor je reactie.

Het was me vanmorgen uiteindelijk toch gelukt om de installatie te voltooien. Ondertussen kan ik cgminer starten, maar ik loop hier tegen een ander probleem aan Smiley.

Hier volgt wat ik tot nu toe geconfigureerd heb :

Update and Upgrade


sudo apt-get update
sudo apt-get upgrade

Install dependencies
sudo apt-get install cdbs dh-make dkms execstack dh-modaliases linux-headers-generic libqtgui4
sudo apt-get install lib32gcc1
sudo ln -s /lib/x86_64-linux-gnu/libudev.so.0 /lib/x86_64-linux-gnu/libudev.so.1

Install Catalyst driver
mkdir catalyst13.12 && cd catalyst13.12
wget --referer='http://support.amd.com/en-us/download/desktop?os=Linux+x86' http://www2.ati.com/drivers/linux/amd-catalyst-13.12-linux-x86.x86_64.zip
unzip amd-catalyst-13.12-linux-x86.x86_64.zip
chmod +x amd-catalyst-13.12-linux-x86.x86_64.run

sudo ./amd-catalyst-13.12-linux-x86.x86_64.run --buildpkg
sudo dpkg -i fglrx*.deb

sudo aticonfig --lsa
sudo aticonfig --adapter=all --initial
sudo reboot

ik start cgminer met een shell:

#!/bin/sh
export DISPLAY=:0
export GPU_MAX_ALLOC_PERCENT=100
export GPU_USE_SYNC_OBJECTS=1
cd /home/user/cgminer-3.7.2-x86_64-built
./cgminer -g2

Deze config file gebruik ik :

"pools" : [
        {
                "url" : "stratum+tcp://mine1.coinmine.pl:6300",
                "user" : "xxx",
                "pass" : "x"
        }
]
,
"intensity" : "13,13",
"vectors" : "1,1",
"worksize" : "256,256",
"lookup-gap" : "2,2",
"thread-concurrency" : "8192,8192",
"shaders" : "0,0",
"gpu-engine" : "1080,1080",
"gpu-fan" : "30-75",
"gpu-memclock" : "1500,1500",
"gpu-memdiff" : "0,0",
"gpu-powertune" : "20,20",
"gpu-vddc" : "0.000,0.000",
"temp-cutoff" : "95,95",
"temp-overheat" : "85,85",
"temp-target" : "75,75",
"api-mcast-port" : "4028",
"api-port" : "4028",
"expiry" : "1",
"gpu-dyninterval" : "7",
"gpu-platform" : "0",
"gpu-threads" : "1",
"hotplug" : "5",
"log" : "5",
"no-pool-disable" : true,
"queue" : "1",
"scan-time" : "60",
"temp-hysteresis" : "3",

Ben ik iets vergeten ofzo, Bedankt voor de hulp alvast.
koelen3
Legendary
*
Offline Offline

Activity: 980


Sooner or later, a man who wears two faces forgets


View Profile
February 08, 2014, 02:23:53 PM
 #7

Uiteraard ben je iets vergeten, je loopt niet op het scrypt protocol Smiley
Gebruik in je shell na /cgminer het --scrypt line.

Je kan dit ook in je config laten lopen door volgende command:

Code:
"scrypt" : true,

Als je dit niet doet in je command file, gebruik die dan op je shell:

Code:
#!/bin/sh
export DISPLAY=:0
export GPU_MAX_ALLOC_PERCENT=100
export GPU_USE_SYNC_OBJECTS=1
cd /home/user/cgminer-3.7.2-x86_64-built
/cgminer --scrypt -g2

Echter denk ik wel dat er een . Voor je /cgminer moet in de laatste lijn.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!