Bitcoin Forum
December 11, 2017, 04:49:59 AM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: [SOLVED]CGMiner Problem on Xubuntu 12.04. **Reward for problemsolver**[SOLVED]  (Read 541 times)
Xubu
Full Member
***
Offline Offline

Activity: 238


View Profile
February 08, 2014, 07:43:34 AM
 #1

First of all: I am familiar with mining. I am running a 3 X 7950 rig alredy on Xubuntu 12.10. Without any problems. I bought some new hardware for a new rig.

I have a strange problem when i start cgminer on my new rig. I installed Xubuntu 12.04, cgminer 3.7.2 and the AMD catalyst 13.12 driver.
I can start mining, but for some reason i can't accept any shares, and cgminer is showing some strange hashrate in GH instead of MH?? See the following link for more information : http://imgur.com/Ht9duZH

I Tried different pools and different versions of cgminer.  They all give the same result.

I think there is a problem with my drivers. I cant figure out.

My setup:

2 X R9 - 280X sapphire toxic.
cgminer 3.7.2
AMD Catalyst™ 13.12 Proprietary Linux x86 Display Driver


Here is what i did so far.

Update and Upgrade

sudo apt-get update
sudo apt-get upgrade

Install dependencies
sudo apt-get install cdbs dh-make dkms execstack dh-modaliases linux-headers-generic libqtgui4
sudo apt-get install lib32gcc1
sudo ln -s /lib/x86_64-linux-gnu/libudev.so.0 /lib/x86_64-linux-gnu/libudev.so.1

Install Catalyst driver

mkdir catalyst13.12 && cd catalyst13.12
wget --referer='http://support.amd.com/en-us/download/desktop?os=Linux+x86' http://www2.ati.com/drivers/linux/amd-catalyst-13.12-linux-x86.x86_64.zip
unzip amd-catalyst-13.12-linux-x86.x86_64.zip
chmod +x amd-catalyst-13.12-linux-x86.x86_64.run

sudo ./amd-catalyst-13.12-linux-x86.x86_64.run --buildpkg
sudo dpkg -i fglrx*.deb

sudo aticonfig --lsa
sudo aticonfig --adapter=all --initial
sudo reboot

I startup cgminer with a shell:


#!/bin/sh
export DISPLAY=:0
export GPU_MAX_ALLOC_PERCENT=100
export GPU_USE_SYNC_OBJECTS=1
cd /home/user/cgminer-3.7.2-x86_64-built
/cgminer -g2

My config file that gminer uses :

"pools" : [
        {
                "url" : "stratum+tcp://mine1.coinmine.pl:6300",
                "user" : "xxx",
                "pass" : "x"
        }
]
,
"intensity" : "13,13",
"vectors" : "1,1",
"worksize" : "256,256",
"lookup-gap" : "2,2",
"thread-concurrency" : "8192,8192",
"shaders" : "0,0",
"gpu-engine" : "1080,1080",
"gpu-fan" : "30-75",
"gpu-memclock" : "1500,1500",
"gpu-memdiff" : "0,0",
"gpu-powertune" : "20,20",
"gpu-vddc" : "0.000,0.000",
"temp-cutoff" : "95,95",
"temp-overheat" : "85,85",
"temp-target" : "75,75",
"api-mcast-port" : "4028",
"api-port" : "4028",
"expiry" : "1",
"gpu-dyninterval" : "7",
"gpu-platform" : "0",
"gpu-threads" : "1",
"hotplug" : "5",
"log" : "5",
"no-pool-disable" : true,
"queue" : "1",
"scan-time" : "60",
"temp-hysteresis" : "3",

Am i missing something in my setup?

Any help would really be appreciated. Teamviewer available here on my Windows Laptop with putty for the ssh login to the rig. I give a reward of 0.025 BTC for the person who can solve this problem via teamviewer.
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
squiggie
Full Member
***
Offline Offline

Activity: 147


View Profile WWW
February 08, 2014, 04:09:14 PM
 #2

Not sure but in your launch script yo u are specifying g 2 and in your conf file it has gpu threads as 1. Is there a reason you need to specify g 2?

niceman
Sr. Member
****
Offline Offline

Activity: 336

CoinMine.pw


View Profile WWW
February 08, 2014, 04:15:03 PM
 #3

add

scrypt: true,

to config

Also your config file is wrong. It can't finish with ','


niceman
Sr. Member
****
Offline Offline

Activity: 336

CoinMine.pw


View Profile WWW
February 08, 2014, 04:19:25 PM
 #4

It must start with '{' and finish with '}' without ',' at last parameter. Because it's JSON decoded object.

Example

Code:
{
"pools" : [
{
"url" : "stratum+tcp://eu.coinmine.pw:1111",
"user" : "nice",
"pass" : "x"
}
]
,
"intensity" : "20",
"vectors" : "1",
"worksize" : "256",
"kernel" : "scrypt",
"lookup-gap" : "2",
"thread-concurrency" : "24600",
"gpu-engine" : "965",
"gpu-fan" : "65",
"gpu-memclock" : "1250",
"gpu-memdiff" : "0",
"gpu-powertune" : "20",
"temp-cutoff" : "95",
"temp-overheat" : "85",
"expiry" : "20",
"gpu-threads" : "1",
"hotplug" : "5",
"log" : "5",
"no-pool-disable" : true,
"no-submit-stale" : true,
"queue" : "1",
"scan-time" : "10",
"scrypt" : true,
"temp-hysteresis" : "3",
"worktime" : true,
"shares" : "0"
}


niceman
Sr. Member
****
Offline Offline

Activity: 336

CoinMine.pw


View Profile WWW
February 08, 2014, 04:20:52 PM
 #5

Also, you can use sgminer, it's optimized cgminer for Scrypt coins

http://www.reddit.com/r/litecoinmining/comments/1va8g2/ann_sgminer_400_release/

Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!