Bitcoin Forum
October 19, 2021, 08:02:22 AM *
News: Latest Bitcoin Core release: 22.0 [Torrent]
 
   Home   Help Search Login Register More  
Pages: [1]
  Print  
Author Topic: Clean install of Armory 0.90 on win7 is non-responsive  (Read 745 times)
rocks
Legendary
*
Offline Offline

Activity: 1153
Merit: 1000


View Profile
February 11, 2014, 06:14:17 AM
 #1

After using bitcoin-qt successfully for the past couple of years, I've tried unsuccessfully to use Armory for the past week.

Unfortunately I cannot get the program to sync correctly. I've set Armory to let me manage the bitcoin-qt myself, and bitcoin-qt runs perfectly fine in the background while Armory has issues at the same time. I've tried clearing out the Armory directory and re-installing several times and keep receiving the same errors as below. I've also tried clearling the bitcoin-qt directories and re-downloading the whole chain, but that does not help.

This is a clean install of Armory 0.90 on a Win 7 64-bit machine (clean install) with bitcoind 0.8.6

After Armory syncs with bitcoin-qt, the gui become unresponsive. The armorylog.txt file show the following, the set of error messages repeats indefinitely while Armory consumes 100% of a CPU core.

Any thoughts on what this could be. Again my setup is as basic and standard as you can get.

Code:
2014-02-10 23:52 (INFO) -- armoryengine.pyc:12479 - Reading blockchain, pct complete: 99.0
2014-02-10 23:52 (INFO) -- armoryengine.pyc:12479 - Reading blockchain, pct complete: 99.3
2014-02-10 23:52 (INFO) -- armoryengine.pyc:12479 - Reading blockchain, pct complete: 99.5
2014-02-10 23:53 (INFO) -- armoryengine.pyc:12479 - Reading blockchain, pct complete: 0.0
2014-02-10 23:53 (INFO) -- armoryengine.pyc:12479 - Reading blockchain, pct complete: 0.0
----- Repeats for about 50 lines -----------------
2014-02-10 23:53 (INFO) -- armoryengine.pyc:12479 - Reading blockchain, pct complete: 0.0
2014-02-10 23:53 (INFO) -- armoryengine.pyc:12479 - Reading blockchain, pct complete: 0.0
2014-02-10 23:53 (INFO) -- ArmoryQt.py:4465 - Dashboard switched to fully-online mode
2014-02-10 23:53 (INFO) -- ArmoryQt.py:3838 - Switching Armory state text to Mgmt:User, State:OnlineFull1
2014-02-10 23:53 (INFO) -- ArmoryQt.py:3780 - Switching Armory functional mode to "Online"
2014-02-10 23:53 (INFO) -- ArmoryQt.py:3838 - Switching Armory state text to Mgmt:User, State:OnlineFull2
2014-02-10 23:54 (ERROR) -- armoryengine.pyc:12346 - BDM was not ready for your request!  Waited 20 sec.
2014-02-10 23:54 (ERROR) -- armoryengine.pyc:12347 -   getattr   name: enableZeroConf
2014-02-10 23:54 (ERROR) -- armoryengine.pyc:12348 - BDM currently doing: Passthrough (32941810)
2014-02-10 23:54 (ERROR) -- armoryengine.pyc:12349 - Waiting for completion: ID= 32941810
2014-02-10 23:54 (ERROR) -- armoryengine.pyc:12350 - Direct traceback
2014-02-10 23:54 (ERROR) -- armoryengine.pyc:12353 - Traceback:
Traceback (most recent call last):
  File "armoryengine.pyc", line 12343, in passthruFunc
  File "Queue.pyc", line 176, in get
Empty
2014-02-10 23:54 (INFO) -- ArmoryQt.py:1913 - Syncing wallet: sT1cYPFu
2014-02-10 23:55 (ERROR) -- armoryengine.pyc:12346 - BDM was not ready for your request!  Waited 20 sec.
2014-02-10 23:55 (ERROR) -- armoryengine.pyc:12347 -   getattr   name: scanRegisteredTxForWallet
2014-02-10 23:55 (ERROR) -- armoryengine.pyc:12348 - BDM currently doing: Passthrough (32941810)
2014-02-10 23:55 (ERROR) -- armoryengine.pyc:12349 - Waiting for completion: ID= 22735314
2014-02-10 23:55 (ERROR) -- armoryengine.pyc:12350 - Direct traceback
2014-02-10 23:55 (ERROR) -- armoryengine.pyc:12353 - Traceback:
Traceback (most recent call last):
  File "armoryengine.pyc", line 12343, in passthruFunc
  File "Queue.pyc", line 176, in get
Empty
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1634630542
Hero Member
*
Offline Offline

Posts: 1634630542

View Profile Personal Message (Offline)

Ignore
1634630542
Reply with quote  #2

1634630542
Report to moderator
rocks
Legendary
*
Offline Offline

Activity: 1153
Merit: 1000


View Profile
February 21, 2014, 06:09:22 PM
 #2

Really? A clean install of Armory on a clean install of Windows 7 combined with a fresh download of the blockchain by bitcoin-qt, and Armory flat out does not function, and no one has any suggestions? Or is this considered normal? I provided the error log so it should be possible for the developers to at least identify where the hangup is happening.
goatpig
Moderator
Legendary
*
Offline Offline

Activity: 3024
Merit: 1233

Armory Developer


View Profile
February 21, 2014, 06:22:40 PM
 #3

The part of the log you are showing carries no information pertaining to this bug. This is a known bug with Armory and we're bundling the fixes for the upcoming release. Test builds have been posted recently so try your luck with those.

rocks
Legendary
*
Offline Offline

Activity: 1153
Merit: 1000


View Profile
February 25, 2014, 07:25:12 PM
 #4

The part of the log you are showing carries no information pertaining to this bug. This is a known bug with Armory and we're bundling the fixes for the upcoming release. Test builds have been posted recently so try your luck with those.

Thanks for the reply.

So what error logs do you need to have the right information then? I can submit that if needed.

Also, which bug does this reference that was fixed, is it documented somewhere?
goatpig
Moderator
Legendary
*
Offline Offline

Activity: 3024
Merit: 1233

Armory Developer


View Profile
February 25, 2014, 07:42:34 PM
 #5

https://bitcointalk.org/index.php?topic=56424.msg5285727#msg5285727

Try again with these builds. Make sure you have a wallet loaded and rebuild your DB as some of its internal has changed.

Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!