Bitcoin Forum
December 18, 2017, 09:12:03 PM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Sapphire r9 290 tri-x: low hashrate/scrypt changes do not reflect hashrate  (Read 1082 times)
antonsgeorgiev
Newbie
*
Offline Offline

Activity: 5


View Profile
February 19, 2014, 10:41:13 PM
 #1

Hello everyone,

A friend of mine and I (both new to mining) bought the same GPUs - Sapphire r9 290 tri-x OC. He has a decent hashrate (around 850), but I have a problem - whatever tweaks I make in the scrypt, there seems to be no change or whatsoever in the hashrate.
Using cgminer 3.7.2, windows 7 x64, latest official amd drivers. (did a full uninstall and reinstalled them again)

Here are my specs:

i7-4770k
sapphire r9 290 tri-x OC
asrock z87 killer fatal1ty
16 gb of ddr3 ram @1600mhz running in dual channel
Seasonic m12ii Evo edition 750w


Here are my settings:

Code:
setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_OBJECTS_SYNC 1

cgminer --scrypt -o stratum+tcp://stratum2.flappycoinpool.com:3353 -u antonsgeorgiev.anton -p 01020102hs -g 1 -w 512 --lookup-gap 2 --thread-concurrency 24500 -I 20 --gpu-fan 90 --gpu-engine 947 --gpu-memclock 1500 --gpu-powertune 20 --auto-fan --temp-target 80 --temp-overheat 90 --temp-cutoff 95
I have tried numerous changes in all parameters - changing W, TC, I, Memclock, Engine, Powertune and regardless of the changes made my hashrate tops at 540 every time with any settings applied.

Am I doing something wrong, or the exact question is "What am I doing wrong?", cause there surely is something going on, which is messing up my hashrate.
Please note that my friend gets around 850 hashrate with the same settings above.

Regards,
Anton
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1513631523
Hero Member
*
Offline Offline

Posts: 1513631523

View Profile Personal Message (Offline)

Ignore
1513631523
Reply with quote  #2

1513631523
Report to moderator
antonsgeorgiev
Newbie
*
Offline Offline

Activity: 5


View Profile
February 20, 2014, 02:21:53 PM
 #2

Anyone? Help will be much appreciated.

Thank you!
Starscream
Sr. Member
****
Offline Offline

Activity: 280

All hail Lord Megatron!


View Profile
February 20, 2014, 03:29:54 PM
 #3

Try SGminer 4.0 or above.

When I tried cgminer I had the same issue, hashrate would wobble around 550KH/s.

SGminer uses the same parameters with the exception of --scrypt (and if you download sgminer 4.1 you can use xintensity for better control)


 
 
           ▄████▄
         ▄████████▄
       ▄████████████▄
     ▄████████████████▄
    ████████████████████      ▄█▄                 ▄███▄                 ▄███▄                 ▄████████████████▀   ▄██████████

  ▄▄▄▀█████▀▄▄▄▄▀█████▀▄▄▄     ▀██▄             ▄██▀ ▀██▄             ▄██▀ ▀██▄             ▄██▀                   ██
▄█████▄▀▀▀▄██████▄▀▀▀▄█████▄     ▀██▄         ▄██▀     ▀██▄         ▄██▀     ▀██▄         ▄██▀        ▄█▄          ▀██████████████▄
████████████████████████████       ▀██▄     ▄██▀         ▀██▄     ▄██▀         ▀██▄     ▄██▀          ▀█▀                        ██
 ▀████████████████████████▀          ▀██▄ ▄██▀             ▀██▄ ▄██▀     ▄█▄     ▀██▄ ▄██▀                                       ██
   ▀████████████████████▀              ▀███▀                 ▀███▀       ▀█▀       ▀███▀      ▄███████████████████████████████████▀
     ▀████████████████▀
       ▀████████████▀
         ▀████████▀
           ▀████▀
║║


║║
.
.

║║
██
║║
.
.

║║
██
║║
.
║║


║║
antonsgeorgiev
Newbie
*
Offline Offline

Activity: 5


View Profile
February 20, 2014, 09:12:25 PM
 #4

Thanks a lot Starscream, I have installed sgminer 4.1.0 and now have a stable 880 kh/s with the following settings:


"gpu-threads" : "1",
"xintensity" : "1100",
"thread-concurrency" : "25601",
"worksize" : "512",
"lookup-gap" : "2",

"gpu-powertune" : "20",
"gpu-memclock" : "1250",
"gpu-engine" : "1000",
"gpu-fan" : "80"
}

Once again thanks, and regards. Smiley
Starscream
Sr. Member
****
Offline Offline

Activity: 280

All hail Lord Megatron!


View Profile
February 20, 2014, 09:38:02 PM
 #5

Thanks a lot Starscream, I have installed sgminer 4.1.0 and now have a stable 880 kh/s with the following settings:


"gpu-threads" : "1",
"xintensity" : "1100",
"thread-concurrency" : "25601",
"worksize" : "512",
"lookup-gap" : "2",

"gpu-powertune" : "20",
"gpu-memclock" : "1250",
"gpu-engine" : "1000",
"gpu-fan" : "80"
}

Once again thanks, and regards. Smiley
Read some about how to configure properly here: http://www.overclock.net/t/1461916/tutorial-ultimate-guide-to-tweaking-amd-cgminer-3-7-2-kalroth-edition-sgminer-instructions-included-aswell-get-the-most-hash-out-of-your-gpu

1100 xintensity is over the top value. I'm using 111 right now and so far I really am happy with that.


 
 
           ▄████▄
         ▄████████▄
       ▄████████████▄
     ▄████████████████▄
    ████████████████████      ▄█▄                 ▄███▄                 ▄███▄                 ▄████████████████▀   ▄██████████

  ▄▄▄▀█████▀▄▄▄▄▀█████▀▄▄▄     ▀██▄             ▄██▀ ▀██▄             ▄██▀ ▀██▄             ▄██▀                   ██
▄█████▄▀▀▀▄██████▄▀▀▀▄█████▄     ▀██▄         ▄██▀     ▀██▄         ▄██▀     ▀██▄         ▄██▀        ▄█▄          ▀██████████████▄
████████████████████████████       ▀██▄     ▄██▀         ▀██▄     ▄██▀         ▀██▄     ▄██▀          ▀█▀                        ██
 ▀████████████████████████▀          ▀██▄ ▄██▀             ▀██▄ ▄██▀     ▄█▄     ▀██▄ ▄██▀                                       ██
   ▀████████████████████▀              ▀███▀                 ▀███▀       ▀█▀       ▀███▀      ▄███████████████████████████████████▀
     ▀████████████████▀
       ▀████████████▀
         ▀████████▀
           ▀████▀
║║


║║
.
.

║║
██
║║
.
.

║║
██
║║
.
║║


║║
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!