Bitcoin Forum
September 28, 2016, 06:51:45 AM *
News: Latest stable version of Bitcoin Core: 0.13.0 (New!) [Torrent]. Make sure you verify it.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Help running bitcoin in a Debian Lenny headless machine  (Read 3980 times)
Kapisketo
Newbie
*
Offline Offline

Activity: 1


View Profile
July 19, 2010, 05:44:33 PM
 #1

Hello. I want to run bitcoin software in a Debian Lenny headless machine. But I don't know how to do it.
Of course the name of the user and the machine are not real  Wink
First Try
Code:
user@machine:~/bitcoin/bin/32$ ./bitcoind
./bitcoind: error while loading shared libraries: libgthread-2.0.so.0: cannot open shared object file: No such file or directory

Second Try
I installed libglib2.0-dev
Code:
user@machine:~/bitcoin/bin/32$ ./bitcoind
./bitcoind: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by ./bitcoind)
1475045505
Hero Member
*
Offline Offline

Posts: 1475045505

View Profile Personal Message (Offline)

Ignore
1475045505
Reply with quote  #2

1475045505
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1475045505
Hero Member
*
Offline Offline

Posts: 1475045505

View Profile Personal Message (Offline)

Ignore
1475045505
Reply with quote  #2

1475045505
Report to moderator
Some Mouse
Newbie
*
Offline Offline

Activity: 14


View Profile
July 20, 2010, 12:15:32 AM
 #2

You need the libglib2.0-0 package. You don't need the dev.
Ground Loop
Member
**
Offline Offline

Activity: 112


View Profile
July 20, 2010, 07:30:04 AM
 #3

I've got libglib2.0-0 installed.    I believe Debian's libstdc++.so is older than the one bitcoind was compiled with.  Same error here.

Bitcoin accepted here: 1HrAmQk9EuH3Ak6ugsw3qi3g23DG6YUNPq
Some Mouse
Newbie
*
Offline Offline

Activity: 14


View Profile
July 20, 2010, 05:36:25 PM
 #4

I've got libglib2.0-0 installed.    I believe Debian's libstdc++.so is older than the one bitcoind was compiled with.  Same error here.


hrm. I'm using Squeeze for all of my generation, it seems. You can try upgrading to the testing version of that package.
altoid
Jr. Member
*
Offline Offline

Activity: 48


View Profile
March 19, 2011, 06:22:50 PM
 #5

has anyone successfully done this?  I have been trying for days with no success. 
payb.tc
Hero Member
*****
Offline Offline

Activity: 812



View Profile
July 30, 2011, 12:08:46 PM
 #6

has anyone successfully done this?  I have been trying for days with no success. 

bumping an old thread... still can't get 0.3.24 working on debian lenny.
drawoc
Full Member
***
Offline Offline

Activity: 168

Firstbits: 175wn


View Profile
July 30, 2011, 08:45:25 PM
 #7

The precompiled binaries need squeeze (current stable) or later.

You can either upgrade to squeeze, or compile bitcoind yourself. Also note that on occasion someone will post a precompiled version on the forum that was compiled for older libraries (and works with lenny).

Donate: 175WNXmJ1WVhFgVGKUqEhYtAQGRYAvqPA
payb.tc
Hero Member
*****
Offline Offline

Activity: 812



View Profile
July 30, 2011, 11:24:27 PM
 #8

The precompiled binaries need squeeze (current stable) or later.

You can either upgrade to squeeze, or compile bitcoind yourself. Also note that on occasion someone will post a precompiled version on the forum that was compiled for older libraries (and works with lenny).

thanks for your help.

My host tells me that your reference to squeeze is for debian 6.x and apparently I'm running debian 5.x, so it's a no go.

is this just an anomaly with this particular version of bitcoin? i.e. would waiting for 0.3.25 solve this problem or would the problem be ongoing until my OS is upgraded?

drawoc
Full Member
***
Offline Offline

Activity: 168

Firstbits: 175wn


View Profile
July 31, 2011, 12:07:01 AM
 #9

thanks for your help.

My host tells me that your reference to squeeze is for debian 6.x and apparently I'm running debian 5.x, so it's a no go.

is this just an anomaly with this particular version of bitcoin? i.e. would waiting for 0.3.25 solve this problem or would the problem be ongoing until my OS is upgraded?

Yep, squeeze is the latest stable debian version (just released in February).

The problem is with how the precompiled binaries were compiled. I doubt that whoever builds the precompiled binaries will change this in the future, so waiting for 0.3.25 wouldn't fix it.

Unless you want to compile bitcoin yourself, it looks like you're going to have to wait for an upgrade to squeeze.

Donate: 175WNXmJ1WVhFgVGKUqEhYtAQGRYAvqPA
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!