Bitcoin Forum
February 24, 2019, 06:24:06 AM *
News: Latest Bitcoin Core release: 0.17.1 [Torrent]
 
   Home   Help Search Login Register More  
Pages: [1]
  Print  
Author Topic: [ANN] QT Wallet Compiler for Linux  (Read 8411 times)
pastet89
Sr. Member
****
Offline Offline

Activity: 322
Merit: 250


View Profile WWW
March 03, 2014, 08:14:29 PM
Last edit: May 02, 2014, 07:22:12 PM by pastet89
 #1

I am representing you a simple python scrypt, which will do the compiling of your qt-wallets under linux, just by submiting the git URL to it.
I myself have compiled a lot of wallets and I know it may be very boring and annoying to wait for the steps during compilation to finalize, in order to continue with the next one and do all this manually. Furthermore, sometimes errors occur during installation, so in this scrypt I have addressed the 3 most common mistakes during compilation, and all should go smooth with it.

What does the scrypt do:

1. Compiles the qt wallet just by being provided with git URL.

Note! The compiler uses just the basic complation commands:


Code:
cd src && make
cd ../
qmake-qt4
make
Some coins may require special options during compilation, so you still need to check this and proceed at your own risk!

2. Fixes the error when the "obj" folder is not created within the "src" one, by auto-creating it, if needed.
3. Fixes the compilation error that occurs on some coins as a result of boost 1.53 libraries for windows lines being present in the .pro file, by removing these lines.
4. Fixes the compilation error that occurs as a result of missing permissions of the "leveldb/build_detect_platform" folder by auto-applying those.

Requirements
You still need to install all required libraries for the coin wallet, which in most cases are the same so once you have them installed after installing your first wallet most likely you will not need anything else.
You also need to confirm that you have installed git and qmake-qt4 prior usage of the script. Of course, you will need python 2.7.x as well, however every linux has installed that by default so I doubt you will need to install it.

These are the main commands to execute before starting the script, but depending on your system it might request something additionaly as well:

Code:
sudo apt-get install   libdb4.8-dev libdb4.8++-dev libboost-all-dev libqrencode-devqt4-qmake libqt4-dev build-essential libboost-dev libboost-system-dev    libboost-filesystem-dev libboost-program-options-dev libboost-thread-dev    libssl-dev automake




Usage
1. Download the script from this location: http://www.solidfiles.com/d/09c5c54693/build.py
2. Open terminal, cd to the directory where the scipt is, and type:[/size]

Code:
python build.py


After that you will be asked to type in the console the URL of the git source. Paste it, press enter, and that's all.

I still can not gurantee that the compiler is going to work flawlessly with all kind of wallets, as all of them are still more or less different. I have tested it successfuly with Digibyte, Catcoin, Leafcoin and Mintcoin, all of them working OK.

Enjoy, and don't forget: use at your own risk!

Cryptostats.es
Your Bitcoin transactions
The Ultimate Bitcoin mixer
made truly anonymous.
with an advanced technology.
Mix coins
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1550989446
Hero Member
*
Offline Offline

Posts: 1550989446

View Profile Personal Message (Offline)

Ignore
1550989446
Reply with quote  #2

1550989446
Report to moderator
1550989446
Hero Member
*
Offline Offline

Posts: 1550989446

View Profile Personal Message (Offline)

Ignore
1550989446
Reply with quote  #2

1550989446
Report to moderator
RagnarDanneskjold
Full Member
***
Offline Offline

Activity: 144
Merit: 100



View Profile
April 25, 2014, 02:57:52 AM
 #2

this is nice. thanks - I think I got it working with hbonickels - almost

Code:
15 warnings and 3 errors generated.
make: *** [obj/netbase.o] Error 1
sh: qmake-qt4: command not found
make: *** No targets specified and no makefile found.  Stop.
Wallet compiled!

git  |  | ID
'Bitcoin is the progress toward a society of privacy. The savage’s whole existence is public, ruled by the laws of his tribe. Bitcoin is the process of setting man free from men'
pastet89
Sr. Member
****
Offline Offline

Activity: 322
Merit: 250


View Profile WWW
May 02, 2014, 06:04:34 PM
 #3

this is nice. thanks - I think I got it working with hbonickels - almost

Code:
15 warnings and 3 errors generated.
make: *** [obj/netbase.o] Error 1
sh: qmake-qt4: command not found
make: *** No targets specified and no makefile found.  Stop.
Wallet compiled!
Please check your qmake version.
You might need to replace the line using qmake-qt4 with simply qmake.

Cryptostats.es
pastet89
Sr. Member
****
Offline Offline

Activity: 322
Merit: 250


View Profile WWW
May 02, 2014, 06:10:30 PM
Last edit: May 02, 2014, 07:22:30 PM by pastet89
 #4

Edit: please, check updated OP.

Cryptostats.es
Thunderhead
Member
**
Offline Offline

Activity: 64
Merit: 10


View Profile
June 05, 2016, 12:06:23 AM
 #5

Where do I get these from ?

sudo apt-get install   libdb4.8-dev libdb4.8++-dev libboost-all-dev libqrencode-devqt4-qmake libqt4-dev build-essential libboost-dev libboost-system-dev    libboost-filesystem-dev libboost-program-options-dev libboost-thread-dev    libssl-dev automake

The libdb4.8++-dev libdb4.8-dev missing
jackg
Copper Member
Legendary
*
Offline Offline

Activity: 1288
Merit: 1206


bc1qdj5v2q8p398rdy6sexc0fapk4hcq0p54xz56ez


View Profile
June 05, 2016, 12:13:29 AM
 #6

Where do I get these from ?

sudo apt-get install   libdb4.8-dev libdb4.8++-dev libboost-all-dev libqrencode-devqt4-qmake libqt4-dev build-essential libboost-dev libboost-system-dev    libboost-filesystem-dev libboost-program-options-dev libboost-thread-dev    libssl-dev automake

The libdb4.8++-dev libdb4.8-dev missing

You could either search online for the corrosponding packages to download.
Maybe try first to just try each individually
Code:
sudo apt-get install libdb4.8++-dev
Code:
sudo apt-get install libdb4.8-dev

@OP - you may wish to allow for improvements to the program in order to ensure these packages are already installed, if any help is needed with this, I have strong knowledge of python2, python3, the linux command line and simple requests in the git shell.

BanzaiBTC
Legendary
*
Offline Offline

Activity: 1274
Merit: 1002


Amsterdex Founder


View Profile WWW
June 05, 2016, 12:15:31 AM
 #7

Code:
apt-get install software-properties-common python-software-properties

add-apt-repository ppa:bitcoin/bitcoin

apt-get update

apt-get install unzip nano git build-essential libtool autotools-dev autoconf automake libssl-dev libboost-all-dev libdb4.8-dev libdb4.8++-dev libminiupnpc-dev libqt4-dev libprotobuf-dev protobuf-compiler libqrencode-dev


Should get you on the way Wink

▄██▄░░░░░░░░░▄█▄░░░░░░░░░▄██▄
██████░░░░░░███████░░░░░░██████
███░░████░░████░░░████░░░███░░███
███░░░░██████░░░░░░░██████░░░░███
███░░░░░████░░░░░░░░░████░░░░░███
███░░░░░░░███░░░░░░░███░░░░░░░███
███░░░░░░░░███░░░░░███░░░░░░░░███
███░░░░░░░░░███░░░███░░░░░░░░░███
███░░░░░░░░░░██████░░░░░░░░░░███
███░░░░░░░░░░░█████░░░░░░░░░░░███
███░░░░░░░░░░░░███░░░░░░░░░░░░███
███░░░░░░░░░░░███░░░░░░░░░░░░░███
███░░░░░░░░░░███░░░░░░░░░░░░░░███
███░░░░░░░░░███░░░░░░░░░░░░░░░███
██▄.░░░░░▐███░░░░░░░░░░░░░░░███
███░░░░▄██▀░░░░░░░░░░░░░░░███
███░░▐██▀░░░░░░░░░░░░░░░███
█████▌░░░░░░░░░░░░░░░███
█████░░░░░░░░░░░░░░████
████░░░░░░░░░░░████
████▄░░░░░▄████
██████████
▀▀▀
.AMSTERDEX.




























jc12345
Legendary
*
Offline Offline

Activity: 1442
Merit: 1003


View Profile
June 05, 2016, 06:00:24 AM
 #8

Where do I get these from ?

sudo apt-get install   libdb4.8-dev libdb4.8++-dev libboost-all-dev libqrencode-devqt4-qmake libqt4-dev build-essential libboost-dev libboost-system-dev    libboost-filesystem-dev libboost-program-options-dev libboost-thread-dev    libssl-dev automake

The libdb4.8++-dev libdb4.8-dev missing

The missing libraries refer to Berkley Database 4.8. Version 4.8 has been removed from later versions of Linux and replaced with version 5.3. Many coins require bdb4.8 in order to be compatible and move your wallet.dat file around to other computers, however it is not impossible to use bdb5.3. In the later types of wallet configuration scripts you can for example configure with the incompatible bdb and it will compile. If you compile with bdb5.3 and you only plan to use it on that computer it is perfectly fine. If you use a later Linux version and you have to use the older bdb then you have to download the source for 4.8 and compile it yourself or add the special repository per the previous post. You wont fine ready-made bdb4.8 libraries in latest default repositories to install and hence your error.
booktiger
Sr. Member
****
Offline Offline

Activity: 370
Merit: 250


View Profile
June 06, 2016, 09:25:30 AM
 #9

how to compile Berkley db 4.8  from source

https://bitcointalk.org/index.php?topic=778322.msg10398331#msg10398331


Quote
# Get db4.8 source, compile and install (takes 5 minutes)
cd ~
wget http://download.oracle.com/berkeley-db/db-4.8.30.NC.tar.gz
tar zxf db-4.8.30.NC.tar.gz
cd db-4.8.30.NC/build_unix; ../dist/configure – – enable-cxx
make; sudo make install
rm -R ~/db-4.8.30.NC*   # delete the sources

# Link the libraries
sudo ln -s /usr/local/BerkeleyDB.4.8/lib/libdb-4.8.so /usr/lib/libdb-4.8.so
sudo ln -s /usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.8.so /usr/lib/libdb_cxx-4.8.so

#
# (SERVER IS PREPARED. FROM HERE ON YOU CAN INSTALL OTHER WALLETS)
#

# where to find db4.8 tell your system  (needs to be redone after reboot)
export BDB_INCLUDE_PATH=”/usr/local/BerkeleyDB.4.8/include”
export BDB_LIB_PATH=”/usr/local/BerkeleyDB.4.8/lib”

Pages: [1]
  Print  
 
Jump to:  

Bitcointalk.org is not available or authorized for sale. Do not believe any fake listings.
Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!