Bitcoin Forum
December 05, 2016, 10:49:40 AM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: libdb4.8 is not available in Ubuntu 11.10  (Read 3140 times)
cdnbcguy
Full Member
***
Online Online

Activity: 128


View Profile WWW
October 26, 2011, 10:39:26 PM
 #1

Hi - I can't install bitcoin 4 because the apt-get for libdb4.8++-dev says 'package libdb4.8++ is not available'

Also - didn't we have a warning not to use 4.8 because of compatibility issues? Also, shouldn't the apt-get be sudo?

I built the bitcoin-qt a while back and I'm glad to see the regular version switch over to QT, it's much better!

Annona ad! Please keep in mind that there is nothing wrong with Bitcoin itself. All it's scandals are caused by wonky websites and sleazy people exploiting it. The light attracts bugs.

When all this bullshit drys up and blows away, Bitcoin will be stronger than ever.
1480934980
Hero Member
*
Offline Offline

Posts: 1480934980

View Profile Personal Message (Offline)

Ignore
1480934980
Reply with quote  #2

1480934980
Report to moderator
1480934980
Hero Member
*
Offline Offline

Posts: 1480934980

View Profile Personal Message (Offline)

Ignore
1480934980
Reply with quote  #2

1480934980
Report to moderator
1480934980
Hero Member
*
Offline Offline

Posts: 1480934980

View Profile Personal Message (Offline)

Ignore
1480934980
Reply with quote  #2

1480934980
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1480934980
Hero Member
*
Offline Offline

Posts: 1480934980

View Profile Personal Message (Offline)

Ignore
1480934980
Reply with quote  #2

1480934980
Report to moderator
cdnbcguy
Full Member
***
Online Online

Activity: 128


View Profile WWW
October 31, 2011, 10:26:31 AM
 #2


The version 5 works as well so if needed and the makefile is not using the BDB 5 edit the makefile.unix to change it close to what I have below reflecting the version in your distro do a search on the libdb_cxx-?.?.a file included in the -dev package for the exact name you need to replace with. And yes the apt-get should be sudo, the warning was about using a higher version of the BDB say like version 5 then trying to use the wallet.dat on a version compiled with version 4 they are not backward compatible..

Code:
LIBS= -dead_strip \
 $(DEPSDIR)/lib/libdb_cxx-5.1.a \

Sorry about the delay. Got it. The new client sure is pretty, thanks for that, and your help.


Annona ad! Please keep in mind that there is nothing wrong with Bitcoin itself. All it's scandals are caused by wonky websites and sleazy people exploiting it. The light attracts bugs.

When all this bullshit drys up and blows away, Bitcoin will be stronger than ever.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!