Bitcoin Forum
May 29, 2017, 09:37:00 AM *
News: Latest stable version of Bitcoin Core: 0.14.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Bitcoin build/dependancy issues on ubuntu oneiric, wallet format  (Read 1254 times)
graingert
Full Member
***
Offline Offline

Activity: 227


View Profile WWW
October 30, 2011, 06:12:27 PM
 #1

Ubuntu oneiric does not have the libdb4.8++ or libdb4.8++-dev packages, meaning running or building bitcoin impossible without adding those extra packages to the bitcoin repository.

What do you think would be the best way to go about this:

  • Upgrade to libdb5.x++ and cause new wallets to be incompatible with old bitcoin versions
  • include the libdb4.8++ packages and potentially cause collisions with other software making this same decision
  • Upgrade to libdb5.x, cause new wallets to be incompatible with old bitcoin versions, but make an export option that will potentially be compatible "forever"

The export wallet command could export as a GPG compatible ascii armoured ecdsa key set, a json file, or an XML file

[EDIT] the current leaning in #bitcoin-dev is to go with "include the libdb4.8++ packages and potentially cause collisions with other software making this same decision" Then move to machine-dependant wallets once a bitcoin standard export format has been chosen


 *Image Removed*
1496050620
Hero Member
*
Offline Offline

Posts: 1496050620

View Profile Personal Message (Offline)

Ignore
1496050620
Reply with quote  #2

1496050620
Report to moderator
1496050620
Hero Member
*
Offline Offline

Posts: 1496050620

View Profile Personal Message (Offline)

Ignore
1496050620
Reply with quote  #2

1496050620
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1496050620
Hero Member
*
Offline Offline

Posts: 1496050620

View Profile Personal Message (Offline)

Ignore
1496050620
Reply with quote  #2

1496050620
Report to moderator
1496050620
Hero Member
*
Offline Offline

Posts: 1496050620

View Profile Personal Message (Offline)

Ignore
1496050620
Reply with quote  #2

1496050620
Report to moderator
1496050620
Hero Member
*
Offline Offline

Posts: 1496050620

View Profile Personal Message (Offline)

Ignore
1496050620
Reply with quote  #2

1496050620
Report to moderator
Luke-Jr
Legendary
*
expert
Offline Offline

Activity: 2184



View Profile
October 30, 2011, 06:15:02 PM
 #2

Supposedly bdb 5.x is completely compatible with 4.8, so...

Matt Corallo
Hero Member
*****
expert
Offline Offline

Activity: 754


View Profile
October 30, 2011, 06:20:55 PM
 #3

Upgrade to libdb5.x++ and cause new wallets to be incompatible with old bitcoin versions
Problem here is that we would then have to ship our own libdb5.x packages for maverick, and lucid, which really isnt any better than shipping db4.8 for oneiric.
include the libdb4.8++ packages and potentially cause collisions with other software making this same decision
My personal opinion is to go with this one.  The likelyhood of causing any collisions or issues is fairly low as we can just re-upload the lucid db4.8 source and have launchpad build it for oneiric.
Upgrade to libdb5.x, cause new wallets to be incompatible with old bitcoin versions, but make an export option that will potentially be compatible "forever"
That would be a pain...plus we would want to switch mac/win32 releases to 5.X at the same time...

Bitcoin Ubuntu PPA maintainer - donate to me personally: 1JBMattRztKDF2KRS3vhjJXA7h47NEsn2c
http://bitcoinrelaynetwork.org maintainer
PGP ID: 07DF 3E57 A548 CCFB 7530  7091 89BB B866 3E2E65CE
graingert
Full Member
***
Offline Offline

Activity: 227


View Profile WWW
October 30, 2011, 06:42:33 PM
 #4

Supposedly bdb 5.x is completely compatible with 4.8, so...

_If_ this is true then the best thing to go for is using 5.x on oneiric and 4.8 on the older versions

 *Image Removed*
Luke-Jr
Legendary
*
expert
Offline Offline

Activity: 2184



View Profile
October 30, 2011, 06:50:57 PM
 #5

Supposedly bdb 5.x is completely compatible with 4.8, so...

_If_ this is true then the best thing to go for is using 5.x on oneiric and 4.8 on the older versions
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=621425

graingert
Full Member
***
Offline Offline

Activity: 227


View Profile WWW
October 30, 2011, 07:10:51 PM
 #6

It seems bitcoinj/MultiBit are going in a direction to make an interchangeable wallet format.

It would be great if this discussion could be pulled out into the mainline client

https://github.com/jim618/multibit/wiki/Stable%20wallet%20format

 *Image Removed*
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!