Bitcoin Forum
February 17, 2020, 09:04:15 PM *
News: Latest Bitcoin Core release: 0.19.0.1 [Torrent]
 
   Home   Help Search Login Register More  
Pages: [1] 2 »  All
  Print  
Author Topic: Electrum - Why my confirmation is negative?  (Read 313 times)
artofwar
Member
**
Offline Offline

Activity: 142
Merit: 25


View Profile
January 03, 2019, 05:45:53 PM
 #1

Quote
{"status": "success", "status_code": 200, "message": "", "data": {"partial": false, "version": 1, "segwit_ser": false, "inputs": [{"prevout_hash": "9f36aa1d9e6c24b5570290766ad2ba402a31ad0e30fe62e0ad4b607b549ac63c", "prevout_n": 1, "scriptSig": "47304402200b900e57472ca6e0c081c17ffc65e96ef130346e7c8a6baaec71b2aa05a55b4402202 e2913d7cfc202896506630daf7d1fb2a6ffe54c8cde9b267290c4476747a2700121034af2b495a6 2750f5e0b7aa13badf858fe48bfa30c436debfae3dc206c062486e", "sequence": 4294967295, "type": "p2pkh", "address": "1MtCJ1uvApDcj9YkGSmnzQc2DPUBiiXjWD", "num_sig": 1, "x_pubkeys": ["034af2b495a62750f5e0b7aa13badf858fe48bfa30c436debfae3dc206c062486e"], "pubkeys": ["034af2b495a62750f5e0b7aa13badf858fe48bfa30c436debfae3dc206c062486e"], "signatures": ["304402200b900e57472ca6e0c081c17ffc65e96ef130346e7c8a6baaec71b2aa05a55b4402202e2 913d7cfc202896506630daf7d1fb2a6ffe54c8cde9b267290c4476747a27001"]}], "outputs": [{"value": 1000, "type": 0, "address": "18yYUxDEG4uEebiGcLVSPfxCFqeEa8X1Qq", "scriptPubKey": "76a914577a74426272ccf6299ebaa32965dc46171f5cec88ac", "prevout_n": 0}, {"value": 22659, "type": 0, "address": "1Luj34vrE8bRgv1ukeK5kSCJg9MrBykdqC", "scriptPubKey": "76a914da631c081cdbe466aa9a0d945d46ee82e3ea0e6f88ac", "prevout_n": 1}], "lockTime": 0, "input": "1MtCJ1uvApDcj9YkGSmnzQc2DPUBiiXjWD", "confirmations": -13}}


Hello there, Im using electrum server for my apps, im trying to notify user that their payment has been successful.

but why I get negative comfirmations everytime? can somone help me out? (was using blockchain.info as block comfirmation before, but they limit our data call)
1581973455
Hero Member
*
Offline Offline

Posts: 1581973455

View Profile Personal Message (Offline)

Ignore
1581973455
Reply with quote  #2

1581973455
Report to moderator
1581973455
Hero Member
*
Offline Offline

Posts: 1581973455

View Profile Personal Message (Offline)

Ignore
1581973455
Reply with quote  #2

1581973455
Report to moderator
1581973455
Hero Member
*
Offline Offline

Posts: 1581973455

View Profile Personal Message (Offline)

Ignore
1581973455
Reply with quote  #2

1581973455
Report to moderator
100% First Deposit Bonus Instant Withdrawals Best Odds 10+ Sports Since 2014 No KYC Asked Play Now
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1581973455
Hero Member
*
Offline Offline

Posts: 1581973455

View Profile Personal Message (Offline)

Ignore
1581973455
Reply with quote  #2

1581973455
Report to moderator
khaled0111
Hero Member
*****
Online Online

Activity: 980
Merit: 773


WOLF.BET - Provably Fair Dice Game


View Profile
January 03, 2019, 07:08:49 PM
 #2

Try to restart/resync your server.

.WOLF.BET.▄███████████▄
███████    ████████████▄
███████    ███████   ▀██
██████████████████    ██
██    ██████████████████
██    ███████    ███████
█████████████    ███████
███████    █████████████
███████    ███████    ██
██████████████████   ▄██
██        ▀███████████▀
██
██

█████
  ███
  ███
  ███
  ███
  ███
  ███
  ███
  ███
  ███
  ███
█████


artofwar
Member
**
Offline Offline

Activity: 142
Merit: 25


View Profile
January 04, 2019, 04:17:56 AM
 #3

Try to restart/resync your server.


so the problem is its not sync?

I use electrum, im not using my own nodes. why it not sync?
artofwar
Member
**
Offline Offline

Activity: 142
Merit: 25


View Profile
January 04, 2019, 05:07:22 AM
 #4

Try to restart/resync your server.


To restart/resync electrum do I need to reboot the server? Electrum daemon was running all the time. Shouldn't it sync?
Heisenberg_Hunter
Hero Member
*****
Offline Offline

Activity: 784
Merit: 807



View Profile WWW
January 04, 2019, 08:24:01 AM
 #5

Seems like the transaction has been confirmed while checking through the block explorer. Negative confirmations is a well known bug present in the electrum software. Resyncing/re-connecting to a newer server will probably solve your issue I guess.

I use electrum, im not using my own nodes. why it not sync?
Electrum is a light wallet and it doesn't download the whole blockchain. Rather your wallet syncs to a server running a full node to broadcast transactions and update your balances. Servers can go down at times.

To restart/resync electrum do I need to reboot the server? Electrum daemon was running all the time. Shouldn't it sync?
Press the green button present on the bottom right of your client interface to resync with new server. When you click that, Press the server tab and select a new server from the list.

If that doesn't solve your issue and if it still persists you better need to delete the block headers.  Sad




▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄    ▄▄▄▄                  ▄▄▄   ▄▄▄▄▄        ▄▄▄▄▄   ▄▄▄▄▄▄▄▄▄▄▄▄    ▄▄▄▄▄▄▄▄▄▄▄▄▄▄   ▄▄▄▄▄▄▄▄▄▄▄▄▄▄   ▄▄▄▄▄▄▄▄▄▄▄
 ▀████████████████▄  ████                 █████   ▀████▄    ▄████▀  ▄██████████████   ████████████▀  ▄█████████████▀  ▄█████████████▄
              ▀████  ████               ▄███▀███▄   ▀████▄▄████▀               ████   ████                ████                   ▀████
   ▄▄▄▄▄▄▄▄▄▄▄█████  ████              ████   ████    ▀██████▀      ██████████████▄   ████████████▀       ████       ▄▄▄▄▄▄▄▄▄▄▄▄████▀
   ██████████████▀   ████            ▄███▀     ▀███▄    ████        ████        ████  ████                ████       ██████████████▀
   ████              ████████████▀  ████   ██████████   ████        ████████████████  █████████████▀      ████       ████      ▀████▄
   ▀▀▀▀              ▀▀▀▀▀▀▀▀▀▀▀   ▀▀▀▀   ▀▀▀▀▀▀▀▀▀▀▀▀  ▀▀▀▀        ▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀   ▀▀▀▀▀▀▀▀▀▀▀▀        ▀▀▀▀       ▀▀▀▀        ▀▀▀▀▀

#1 CRYPTO CASINO & SPORTSBOOK
  WELCOME
BONUS
.INSTANT & FAST.
.TRANSACTION.....
.PROVABLY FAIR.
......& SECURE......
.24/7 CUSTOMER.
............SUPPORT.
BTC      |      ETH      |      LTC      |      XRP      |      XMR      |      BNB      |     more
artofwar
Member
**
Offline Offline

Activity: 142
Merit: 25


View Profile
January 04, 2019, 10:14:26 AM
 #6

Seems like the transaction has been confirmed while checking through the block explorer. Negative confirmations is a well known bug present in the electrum software. Resyncing/re-connecting to a newer server will probably solve your issue I guess.

I use electrum, im not using my own nodes. why it not sync?
Electrum is a light wallet and it doesn't download the whole blockchain. Rather your wallet syncs to a server running a full node to broadcast transactions and update your balances. Servers can go down at times.

To restart/resync electrum do I need to reboot the server? Electrum daemon was running all the time. Shouldn't it sync?
Press the green button present on the bottom right of your client interface to resync with new server. When you click that, Press the server tab and select a new server from the list.

If that doesn't solve your issue and if it still persists you better need to delete the block headers.  Sad


are you a troll?
BitMaxz
Legendary
*
Online Online

Activity: 1708
Merit: 1336


Beware on fake ledger nano, trezor and electrum.


View Profile WWW
January 04, 2019, 11:19:08 PM
 #7

Let me ask if the quoted from the OP is it in Electrum X python result? Where did you copy this logs?

Also, let me ask if you are using this electrum server from here https://github.com/spesmilo/electrum-server ? upgrade to electrum X might solve this issue.

artofwar
Member
**
Offline Offline

Activity: 142
Merit: 25


View Profile
January 05, 2019, 07:38:08 AM
Last edit: January 05, 2019, 08:17:59 AM by artofwar
 #8

Let me ask if the quoted from the OP is it in Electrum X python result? Where did you copy this logs?

Also, let me ask if you are using this electrum server from here https://github.com/spesmilo/electrum-server ? upgrade to electrum X might solve this issue.

we are using electrum software, not server, using its json rpc apis in our app. and its an electrum python library
Abdussamad
Legendary
*
Offline Offline

Activity: 2380
Merit: 1254



View Profile
January 05, 2019, 08:20:11 AM
 #9

What version of electrum are you using? If it's 3.3.2 then you should make an issue on github. Otherwise update to the latest and greatest first.
artofwar
Member
**
Offline Offline

Activity: 142
Merit: 25


View Profile
January 05, 2019, 08:23:41 AM
 #10

Let me ask if the quoted from the OP is it in Electrum X python result? Where did you copy this logs?

Also, let me ask if you are using this electrum server from here https://github.com/spesmilo/electrum-server ? upgrade to electrum X might solve this issue.

version 3.3.2
artofwar
Member
**
Offline Offline

Activity: 142
Merit: 25


View Profile
January 05, 2019, 09:08:27 AM
 #11

anyone, please help.
Heisenberg_Hunter
Hero Member
*****
Offline Offline

Activity: 784
Merit: 807



View Profile WWW
January 05, 2019, 09:28:12 AM
 #12

are you a troll?
What makes you say so? At first I thought your issue was on ElectrumX and I would have mistyped them considering it as a software. But now you are saying so, you are using software and not server. If your issue is negative confirmations and it is in electrum software/merchant wallet then what I have said is right.

So you are mentioning about this right? : http://docs.electrum.org/en/latest/merchant.html




▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄    ▄▄▄▄                  ▄▄▄   ▄▄▄▄▄        ▄▄▄▄▄   ▄▄▄▄▄▄▄▄▄▄▄▄    ▄▄▄▄▄▄▄▄▄▄▄▄▄▄   ▄▄▄▄▄▄▄▄▄▄▄▄▄▄   ▄▄▄▄▄▄▄▄▄▄▄
 ▀████████████████▄  ████                 █████   ▀████▄    ▄████▀  ▄██████████████   ████████████▀  ▄█████████████▀  ▄█████████████▄
              ▀████  ████               ▄███▀███▄   ▀████▄▄████▀               ████   ████                ████                   ▀████
   ▄▄▄▄▄▄▄▄▄▄▄█████  ████              ████   ████    ▀██████▀      ██████████████▄   ████████████▀       ████       ▄▄▄▄▄▄▄▄▄▄▄▄████▀
   ██████████████▀   ████            ▄███▀     ▀███▄    ████        ████        ████  ████                ████       ██████████████▀
   ████              ████████████▀  ████   ██████████   ████        ████████████████  █████████████▀      ████       ████      ▀████▄
   ▀▀▀▀              ▀▀▀▀▀▀▀▀▀▀▀   ▀▀▀▀   ▀▀▀▀▀▀▀▀▀▀▀▀  ▀▀▀▀        ▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀   ▀▀▀▀▀▀▀▀▀▀▀▀        ▀▀▀▀       ▀▀▀▀        ▀▀▀▀▀

#1 CRYPTO CASINO & SPORTSBOOK
  WELCOME
BONUS
.INSTANT & FAST.
.TRANSACTION.....
.PROVABLY FAIR.
......& SECURE......
.24/7 CUSTOMER.
............SUPPORT.
BTC      |      ETH      |      LTC      |      XRP      |      XMR      |      BNB      |     more
artofwar
Member
**
Offline Offline

Activity: 142
Merit: 25


View Profile
January 05, 2019, 09:31:31 AM
 #13

are you a troll?
What makes you say so? At first I thought your issue was on ElectrumX and I would have mistyped them considering it as a software. But now you are saying so, you are using software and not server. If your issue is negative confirmations and it is in electrum software/merchant wallet then what I have said is right.

So you are mentioning about this right? : http://docs.electrum.org/en/latest/merchant.html


im sorry for my rude comment earlier. but It dont have any gui. and yes we have tried changing network based on your suggestion, but it dont work.
Abdussamad
Legendary
*
Offline Offline

Activity: 2380
Merit: 1254



View Profile
January 05, 2019, 12:49:42 PM
 #14

anyone, please help.

see post #9 above.

edit: i see you posted it on github. good.
artofwar
Member
**
Offline Offline

Activity: 142
Merit: 25


View Profile
January 05, 2019, 01:15:24 PM
 #15

anyone, please help.

see post #9 above.

edit: i see you posted it on github. good.

I wonder why no one ever encounter with this. doesn't everybody use electrum to accept payment for their business? (no 3rd party option)
Heisenberg_Hunter
Hero Member
*****
Offline Offline

Activity: 784
Merit: 807



View Profile WWW
January 05, 2019, 05:00:35 PM
 #16

im sorry for my rude comment earlier. but It dont have any gui. and yes we have tried changing network based on your suggestion, but it dont work.
No issues dude. I do verify each and every time before I post anything in tech board. Most of my posts has somehow contributed to the topic or helped OP in solving his issue, helped them in understanding simple commands on smart contracts etc. Also I don't post what comes to my mind, I do verify with older posts and issues in github before posting.

Negative confirmations has been probably a common issue during server sync. Check out earlier issues raised in git and also if it doesn't solve your issue you better ought to delete the block headers. That might be one of the possible ways.  If that doesn't solve either, you better need to wait for an electrum dev to answer your issue in github.

Check this out buddy  Smiley

Deleting the block_headers in the .electrum directory to download it again does correct the unverified issue

P.S Is this issue raised by you?




▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄    ▄▄▄▄                  ▄▄▄   ▄▄▄▄▄        ▄▄▄▄▄   ▄▄▄▄▄▄▄▄▄▄▄▄    ▄▄▄▄▄▄▄▄▄▄▄▄▄▄   ▄▄▄▄▄▄▄▄▄▄▄▄▄▄   ▄▄▄▄▄▄▄▄▄▄▄
 ▀████████████████▄  ████                 █████   ▀████▄    ▄████▀  ▄██████████████   ████████████▀  ▄█████████████▀  ▄█████████████▄
              ▀████  ████               ▄███▀███▄   ▀████▄▄████▀               ████   ████                ████                   ▀████
   ▄▄▄▄▄▄▄▄▄▄▄█████  ████              ████   ████    ▀██████▀      ██████████████▄   ████████████▀       ████       ▄▄▄▄▄▄▄▄▄▄▄▄████▀
   ██████████████▀   ████            ▄███▀     ▀███▄    ████        ████        ████  ████                ████       ██████████████▀
   ████              ████████████▀  ████   ██████████   ████        ████████████████  █████████████▀      ████       ████      ▀████▄
   ▀▀▀▀              ▀▀▀▀▀▀▀▀▀▀▀   ▀▀▀▀   ▀▀▀▀▀▀▀▀▀▀▀▀  ▀▀▀▀        ▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀   ▀▀▀▀▀▀▀▀▀▀▀▀        ▀▀▀▀       ▀▀▀▀        ▀▀▀▀▀

#1 CRYPTO CASINO & SPORTSBOOK
  WELCOME
BONUS
.INSTANT & FAST.
.TRANSACTION.....
.PROVABLY FAIR.
......& SECURE......
.24/7 CUSTOMER.
............SUPPORT.
BTC      |      ETH      |      LTC      |      XRP      |      XMR      |      BNB      |     more
artofwar
Member
**
Offline Offline

Activity: 142
Merit: 25


View Profile
January 05, 2019, 05:08:34 PM
 #17

im sorry for my rude comment earlier. but It dont have any gui. and yes we have tried changing network based on your suggestion, but it dont work.
No issues dude. I do verify each and every time before I post anything in tech board. Most of my posts has somehow contributed to the topic or helped OP in solving his issue, helped them in understanding simple commands on smart contracts etc. Also I don't post what comes to my mind, I do verify with older posts and issues in github before posting.

Negative confirmations has been probably a common issue during server sync. Check out earlier issues raised in git and also if it doesn't solve your issue you better ought to delete the block headers. That might be one of the possible ways.  If that doesn't solve either, you better need to wait for an electrum dev to answer your issue in github.

Check this out buddy  Smiley

Deleting the block_headers in the .electrum directory to download it again does correct the unverified issue

P.S Is this issue raised by you?

yes correct. I have instructed my team to raise issue on github based on this thread suggestion.

anyway, how can we delete block headers?

Lucius
Legendary
*
Offline Offline

Activity: 1694
Merit: 1522


⚔ Fortis Fortuna Adiuvat ⚔


View Profile WWW
January 05, 2019, 05:39:55 PM
 #18

anyway, how can we delete block headers?

If you are on Windows the easiest way to delete blockchain_headers it to copy/paste %APPDATA%\Electrum in your windows explorer, and it will lead you to Electrum folder. There you can delete this file and then open Electrum again, depending on your internet speed it should be synchronized in minutes or even less then minute if you have fast internet (file is just 40 MB+).

In case you are on Mac or Linux :

On Mac:

- Open Finder
- Go to folder (shift+cmd+G) and type ~/.electrum

On Linux:

- Home Folder
- Go -> Location and type ~/.electrum

http://docs.electrum.org/en/latest/faq.html




artofwar
Member
**
Offline Offline

Activity: 142
Merit: 25


View Profile
January 06, 2019, 02:29:07 PM
 #19

anyway, how can we delete block headers?

If you are on Windows the easiest way to delete blockchain_headers it to copy/paste %APPDATA%\Electrum in your windows explorer, and it will lead you to Electrum folder. There you can delete this file and then open Electrum again, depending on your internet speed it should be synchronized in minutes or even less then minute if you have fast internet (file is just 40 MB+).

In case you are on Mac or Linux :

On Mac:

- Open Finder
- Go to folder (shift+cmd+G) and type ~/.electrum

On Linux:

- Home Folder
- Go -> Location and type ~/.electrum

http://docs.electrum.org/en/latest/faq.html






We deleted block headers,restarted daemon with the following commands:

electrum daemon stop
electrum daemon start
electrum load_wallet

Confirmation amount is still negative

this is the detailed issue on github https://github.com/spesmilo/electrum/issues/4990
Abdussamad
Legendary
*
Offline Offline

Activity: 2380
Merit: 1254



View Profile
January 06, 2019, 02:41:25 PM
 #20

@artofwar Please lock this thread and continue this issue on github. On github you get the devs' attention. Over here we are just volunteers.
Pages: [1] 2 »  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!