Bitcoin Forum
April 23, 2017, 05:59:45 PM *
News: If the forum does not load normally for you, please send me a traceroute.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Offline bundle 0.90 dependancy problems preventing installation of Armory  (Read 2045 times)
W2014
Member
**
Offline Offline

Activity: 96



View Profile WWW
March 17, 2014, 08:06:05 AM
 #1

Dear Armory developers:

I'd appreciate any feedback on the below problem.

1) I installed a fresh version of

Ubuntu 12.04 LTS 32-bit

on an offline computer.

2) I then attempted to install

Version 0.90-beta Offline Bundle for Ubuntu/Debian 12.04-32bit

using the steps outline on the Armory website.

3) When running in terminal, all went smoothly until I received several error messages noting dependency issues.

For example:

dpkg: error processing libqt4-designer (--configure):
dependency problems -- leaving unconfigured

python-qt4 is not configured yet

4) Note: I have previously installed Version 0.90-beta Offline Bundle for Ubuntu/Debian 12.04-32bit on the same computer a month ago without any problem. The only possible difference is Ubuntu version has been upgraded and is now 12.04.4 and was previously 12.04.3.

5) Note 2: I performed all of the above steps on a completely different offline computer and had the exact same result -- python-qt4 dependency problems.

6) This leads me to ask: Has there been some recent change to the Version 0.90-beta Offline Bundle for Ubuntu/Debian 12.04-32bit which is now causing it to lack all of the necessary dependencies to install properly? Or some recent change to Ubuntu 12.04 causing the problem?

Thank you for any feedback!!




Counterparty and Mastercoin: advanced features implemented on top of the bitcoin blockchain.
 
For the more information go to http://counterparty.co and http://www.mastercoin.org
1492970385
Hero Member
*
Offline Offline

Posts: 1492970385

View Profile Personal Message (Offline)

Ignore
1492970385
Reply with quote  #2

1492970385
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
njaard
Newbie
*
Offline Offline

Activity: 29

Armory Developer


View Profile
March 17, 2014, 05:47:44 PM
 #2

After you do the dpkg -i for Armory, apt-get -f install should install those dependencies.
furu
Newbie
*
Offline Offline

Activity: 1


View Profile
March 17, 2014, 08:49:09 PM
 #3

Same here!

Ubuntu 12.04 LTS 32-bit


libqt4-test depends on libqtcore4 (= 4:4.8.1-0ubuntu4.4); however:
Version of libqtcore4 on system is 4:4.8.1-0ubuntu4.6.
python-qt4 depends on libqt4-designer (>= 4:4.8.0.1~); however:
Package libqt4-designer is not configured yet

When i execute "apt-get -f install" it tries to remove all the installed packages, including armory.
etotheipi
Legendary
*
Offline Offline

Activity: 1428


Core Armory Developer


View Profile WWW
March 17, 2014, 11:16:37 PM
 #4

I just ran into an issue with 12.04 myself.  I think on a fresh 12.04 OS, the dependency sources are outdated.  You have to do a "sudo apt-get update" to get the new sources for the missing dependencies.   Try that, and then try reinstalling Armory again.

Founder and CEO of Armory Technologies, Inc.
Armory Bitcoin Wallet: Bringing cold storage to the average user!
Only use Armory software signed by the Armory Offline Signing Key (0x98832223)

Please donate to the Armory project by clicking here!    (or donate directly via 1QBDLYTDFHHZAABYSKGKPWKLSXZWCCJQBX -- yes, it's a real address!)
W2014
Member
**
Offline Offline

Activity: 96



View Profile WWW
March 18, 2014, 04:40:00 AM
 #5

thanks for the reply.

"sudo apt-get update" is not available on an offline computer.

Instead, I searched for and found the previous version of Ubuntu 12.04.3 LTS. It works with this version, but not the most recent updated version 12.04.04 LTS.


Counterparty and Mastercoin: advanced features implemented on top of the bitcoin blockchain.
 
For the more information go to http://counterparty.co and http://www.mastercoin.org
etotheipi
Legendary
*
Offline Offline

Activity: 1428


Core Armory Developer


View Profile WWW
March 18, 2014, 04:45:03 AM
 #6

thanks for the reply.

"sudo apt-get update" is not available on an offline computer.

Instead, I searched for and found the previous version of Ubuntu 12.04.3 LTS. It works with this version, but not the most recent updated version 12.04.04 LTS.



Oh duh.  Offline.  Whoops.

Very interesting about the 12.04.3 vs 12.04.4.  Gonna have to figure out how to adjust our offline bundle releases appropriately.

Founder and CEO of Armory Technologies, Inc.
Armory Bitcoin Wallet: Bringing cold storage to the average user!
Only use Armory software signed by the Armory Offline Signing Key (0x98832223)

Please donate to the Armory project by clicking here!    (or donate directly via 1QBDLYTDFHHZAABYSKGKPWKLSXZWCCJQBX -- yes, it's a real address!)
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!