Bitcoin Forum
December 11, 2019, 07:51:46 AM *
News: Latest Bitcoin Core release: 0.19.0.1 [Torrent]
 
   Home   Help Search Login Register More  
Pages: [1]
  Print  
Author Topic: Keeping a Connection open between 2 Nodes.  (Read 79 times)
calkob
Hero Member
*****
Offline Offline

Activity: 854
Merit: 503


View Profile
October 15, 2019, 07:13:16 AM
 #1

I have 2 node on the same network, one is 0.18.1 and the other is older 0.12.0.  I want to get 0.12 to stay connected to 0.18.1 permanently as its only connection for information whats the best way to go about that.

currently i can get them to connect simply by addnode in Conf but after a few minutes 0.18.1 is dropping the connection with 0.12.   Undecided  also how do i stop from connecting to any other node.
1576050706
Hero Member
*
Offline Offline

Posts: 1576050706

View Profile Personal Message (Offline)

Ignore
1576050706
Reply with quote  #2

1576050706
Report to moderator
1576050706
Hero Member
*
Offline Offline

Posts: 1576050706

View Profile Personal Message (Offline)

Ignore
1576050706
Reply with quote  #2

1576050706
Report to moderator
1576050706
Hero Member
*
Offline Offline

Posts: 1576050706

View Profile Personal Message (Offline)

Ignore
1576050706
Reply with quote  #2

1576050706
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
nc50lc
Hero Member
*****
Offline Offline

Activity: 798
Merit: 827


Self-proclaimed Genius ㊙️


View Profile WWW
October 15, 2019, 11:43:58 AM
Merited by Jet Cash (2), ETFbitcoin (1)
 #2

I'm not confident with networking settings in bitcoin.conf but try to use these settings.

Connect to this node exclusively (use instead of addnode):
Code:
connect=(node IP)
Maybe it's disconnecting because the old version is misbehaving, try any of these:
Code:
whitelist=(IP)
bantime=5

Also, make sure that bitcoind isn't running in the background while editing your config file.

ETFbitcoin
Legendary
*
Offline Offline

Activity: 1848
Merit: 2123

Use SegWit and enjoy lower fees.


View Profile WWW
October 15, 2019, 04:28:18 PM
Merited by Jet Cash (2)
 #3

This sounds like XY problem, do you have any particular reason to stay use Bitcoin Core 0.12.0 which is outdated? If there aren't any, i suggest you to upgrade your Bitcoin Core.

AFAIK nc50lc suggestion should fix the problem, but if it's not, then try to share your debug.log file

calkob
Hero Member
*****
Offline Offline

Activity: 854
Merit: 503


View Profile
October 16, 2019, 08:06:04 PM
 #4

I'm not confident with networking settings in bitcoin.conf but try to use these settings.

Connect to this node exclusively (use instead of addnode):
Code:
connect=(node IP)
Maybe it's disconnecting because the old version is misbehaving, try any of these:
Code:
whitelist=(IP)
bantime=5

Also, make sure that bitcoind isn't running in the background while editing your config file.

Thanks for that working a treat now.

This sounds like XY problem, do you have any particular reason to stay use Bitcoin Core 0.12.0 which is outdated? If there aren't any, i suggest you to upgrade your Bitcoin Core.

AFAIK nc50lc suggestion should fix the problem, but if it's not, then try to share your debug.log file

I think it is important that Bitcoin maintains its backward compatability and i want to see that older nodes can always stay connected to the network.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!