Bitcoin Forum
April 08, 2020, 09:34:38 PM *
News: Latest Bitcoin Core release: 0.19.1 [Torrent]
 
   Home   Help Search Login Register More  
Pages: [1]
  Print  
Author Topic: Unable to install Electrum  (Read 218 times)
protrader786
Jr. Member
*
Offline Offline

Activity: 33
Merit: 14


View Profile
January 16, 2020, 09:48:26 AM
Merited by Royse777 (2)
 #1

Hello,

I had a old cpu that i decided to use today. I downloaded Electrum wallet into it from https://electrum.org/#download and verified its GPG signature too.

The Cpu specs are :

AMD FX(tm)-6300 Six-Core processor 3.50 GHz
8 GB RAM
64-bit Operating System
2 GB Graphics Card
Windows 7 Ultimate

I think the problem is being caused due to the CPU having windows 7 Ultimate. I don't want to replace the OS Sad

I got an error "api-ms-win-crt-runtime-l1-1-0.dll missing" - This is basically Visual C++ Redistributable for Visual Studio 2015.

I didn't get it by automatic windows update since windows is up to date already.

When i downloaded it manually and tried to install, also it doesn't go through because its too high version for this OS to handle.

If i download a lower version of electrum then there is a lot of risk in everything.

Is there any fix to this ?



Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1586381678
Hero Member
*
Offline Offline

Posts: 1586381678

View Profile Personal Message (Offline)

Ignore
1586381678
Reply with quote  #2

1586381678
Report to moderator
1586381678
Hero Member
*
Offline Offline

Posts: 1586381678

View Profile Personal Message (Offline)

Ignore
1586381678
Reply with quote  #2

1586381678
Report to moderator
Royse777
Legendary
*
Offline Offline

Activity: 994
Merit: 1196


Office and WIN listed on https://bit.ly/33NdWDW


View Profile
January 16, 2020, 10:00:57 AM
Merited by pooya87 (1), mocacinno (1), iasenko (1), DdmrDdmr (1)
 #2

As OS you require Windows 7 or higher so I do not think your OS has anything to do here.

Quote
When i downloaded it manually and tried to install, also it doesn't go through because its too high version for this OS to handle.
You downloaded C++ Redistributable? If not then read here. https://www.threesl.com/blog/fixi-api-ms-win-crt-runtime-l1-1-0-dll-missing-error-install/

Quote
If i download a lower version of electrum then there is a lot of risk in everything.
Don't use an outdated version of Electrum. Always make sure you have latest update with you.

.
.
.
▄███████████████████▄
█████████████████████
████████████▀▀░░░░███
███████████▌░░░░░░███
███████████░░░░██████
███████████░░░░██████
████████░░░░░░░░░░▐██
████████░░░░░░░░░░███

███████████░░░░██████

███████████░░░░██████

███████████░░░░██████

███████████░░░░██████

▀██████████░░░░█████▀
▄███████████████████▄
█████████████████████
█████████████████████
████▀██████▀░░░▀▀▄███
████░░▀▀███░░░░░░▄███
████▀░░░░░░░░░░░▐████
████▄░░░░░░░░░░░█████
█████▀░░░░░░░░░▄█████

████▀█▄░░░░░░░▄██████

█████▄░░░░░▄▄████████

█████████████████████

█████████████████████

▀███████████████████▀
▄███████████████████▄
█████▀▀▀▀▀▀▀▀▀▀▀█████
███░░░▄▄▄▄▄▄▄▄▄░░░███
██░░▄█████████▀▀▄░░██
██░░███▀▀░░░▀▀▄▄█░░██
██░░██▀░▄███▄░▀██░░██
██░░██░░█████░░██░░██
██░░██▄░▀███▀░▄██░░██

██░░███▄▄░░░▄▄███░░██

██░░▀███████████▀░░██

███░░░▀▀▀▀▀▀▀▀▀░░░███

█████▄▄▄▄▄▄▄▄▄▄▄█████

▀███████████████████▀
▄███████████████████▄
█████████████████████
█████████████████████
██████████████▀▀▀████
██████████▀▀░░░░▐████
██████▀▀░░░▄▀░░░█████
████░░░░▄▄▀░░░░▐█████
██████▄▐█░░░░░░██████

███████▌▌░░░░░▐██████

████████▄██▄▄░███████

█████████████████████

█████████████████████

▀███████████████████▀
.
mocacinno
Legendary
*
Offline Offline

Activity: 1918
Merit: 2202


https://unblur.ninja =>lightning network testsite


View Profile WWW
January 16, 2020, 10:03:47 AM
Merited by DdmrDdmr (1)
 #3

It's an old "problem" that has been discussed/solved many times before

for example: https://bitcointalk.org/index.php?topic=2864522.0
or if that thread doesn't solve your problem, try a forum search: https://cse.google.com/cse?cx=016660200577587308545%3Aesf40ml9aag&ie=UTF-8&q=api-ms-win-crt-runtime&sa=Google+search#gsc.tab=0&gsc.q=api-ms-win-crt-runtime&gsc.page=1

Like Royse777 said: don't run old versions... There's a reason newer versions were released. Some older versions have serious critical vulnerability's that are still actively exploited. Some older versions won't even connect to recent electrum nodes at all...

protrader786
Jr. Member
*
Offline Offline

Activity: 33
Merit: 14


View Profile
January 16, 2020, 10:12:42 AM
 #4

The C++ Redistributable installation never goes through.

Always fails. Log https://pastebin.com/u7UTeQ2T
pooya87
Legendary
*
Offline Offline

Activity: 1974
Merit: 2564


Remember tonight for it's the beginning of forever


View Profile
January 16, 2020, 10:24:34 AM
Merited by figmentofmyass (1), DdmrDdmr (1)
 #5

Quote
Windows v6.1 (Build 7600: Service Pack 0)

your problem is not about your hardware or even your operating system. it is all about missing a bunch of dependencies.
try upgrading your windows to at least Service Pack 1 (SP1), these packages (such as Visual C++ Redistributable for Visual Studio 2015) usually have a lot of common requirement that depends on that upgraded service pack.

protrader786
Jr. Member
*
Offline Offline

Activity: 33
Merit: 14


View Profile
January 16, 2020, 10:30:34 AM
 #6

Quote
Windows v6.1 (Build 7600: Service Pack 0)

your problem is not about your hardware or even your operating system. it is all about missing a bunch of dependencies.
try upgrading your windows to at least Service Pack 1 (SP1), these packages (such as Visual C++ Redistributable for Visual Studio 2015) usually have a lot of common requirement that depends on that upgraded service pack.
+1. I am forcing it to update now. If nothing works, i will make a backup of the data and install Linux.
NeuroticFish
Legendary
*
Offline Offline

Activity: 2184
Merit: 1556


First 100% Liquid Stablecoin Backed by Gold


View Profile
January 16, 2020, 11:36:55 AM
 #7

+1. I am forcing it to update now. If nothing works, i will make a backup of the data and install Linux.

According to what MS page tells as system requirements when you d/l VS 2005 Redist, Win 7 SP1 is required.
So if you manage to install SP1 and Electrum still doesn't work, please try to install the Redist Package again.

Also, if you are so much used with Windows, you can simply install Win10. If you don't want to change desktop background and such look&feel settings and if the watermark doesn't bother you, you can use it for good unlicensed.

And if you go for Linux, an USB stick with Tails OS on it already has Electrum too.

50 Cent
Full Member
***
Offline Offline

Activity: 336
Merit: 189


View Profile
January 16, 2020, 11:58:45 AM
Merited by Royse777 (3)
 #8

In electrum website, https://electrum.org/#download below have notice for old windows
Quote
Old versions of Windows might need to install the KB2999226 Windows update.
mk4
Legendary
*
Offline Offline

Activity: 1274
Merit: 1269


Dank memes: 9999


View Profile WWW
January 16, 2020, 01:58:25 PM
 #9

+1. I am forcing it to update now. If nothing works, i will make a backup of the data and install Linux.

Just install Linux regardless if it works or not. If I were to use a separate device to solely use as a wallet device, I'd be far more comfortable in running a Linux OS than a Windows(especially older versions) OS. As long as you don't do anything bad like randomly executing commands you've found online, you should be a lot less likely infected by malware sometime in the future.

protrader786
Jr. Member
*
Offline Offline

Activity: 33
Merit: 14


View Profile
January 16, 2020, 06:03:05 PM
Merited by pooya87 (1)
 #10

After several tries to update to SP1, i finally gave up and installed ubuntu into it. Electrum seems to work now. I think the version of OS i had could not be auto upgraded using windows update. I always got the dialog telling windows is up to date and still could not go through the installation of C++ package.
DroomieChikito
Hero Member
*****
Offline Offline

Activity: 910
Merit: 1021


https://bit.ly/2JKSdDJ


View Profile
January 17, 2020, 12:03:10 AM
 #11

I think the version of OS i had could not be auto upgraded using windows update. I always got the dialog telling windows is up to date and still could not go through the installation of C++ package.
Windows 7 was shut down a day ago [Windows 7 support ended on January 14, 2020]. Microsoft isn't giving you receive security updates, no tech support and no software updates. this is very risky for your PC especially your Electrum wallet from malware and virus.





▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄    ▄▄▄▄                  ▄▄▄   ▄▄▄▄▄        ▄▄▄▄▄   ▄▄▄▄▄▄▄▄▄▄▄▄    ▄▄▄▄▄▄▄▄▄▄▄▄▄▄   ▄▄▄▄▄▄▄▄▄▄▄▄▄▄   ▄▄▄▄▄▄▄▄▄▄▄
 ▀████████████████▄  ████                 █████   ▀████▄    ▄████▀  ▄██████████████   ████████████▀  ▄█████████████▀  ▄█████████████▄
              ▀████  ████               ▄███▀███▄   ▀████▄▄████▀               ████   ████                ████                   ▀████
   ▄▄▄▄▄▄▄▄▄▄▄█████  ████              ████   ████    ▀██████▀      ██████████████▄   ████████████▀       ████       ▄▄▄▄▄▄▄▄▄▄▄▄████▀
   ██████████████▀   ████            ▄███▀     ▀███▄    ████        ████        ████  ████                ████       ██████████████▀
   ████              ████████████▀  ████   ██████████   ████        ████████████████  █████████████▀      ████       ████      ▀████▄
   ▀▀▀▀              ▀▀▀▀▀▀▀▀▀▀▀   ▀▀▀▀   ▀▀▀▀▀▀▀▀▀▀▀▀  ▀▀▀▀        ▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀   ▀▀▀▀▀▀▀▀▀▀▀▀        ▀▀▀▀       ▀▀▀▀        ▀▀▀▀▀

#1 CRYPTO CASINO & SPORTSBOOK
  WELCOME
BONUS
.INSTANT & FAST.
.TRANSACTION.....
.PROVABLY FAIR.
......& SECURE......
.24/7 CUSTOMER.
............SUPPORT.
BTC      |      ETH      |      LTC      |      XRP      |      XMR      |      BNB      |     more
UserU
Full Member
***
Offline Offline

Activity: 546
Merit: 113


★777Coin.com★ Fun BTC Casino!


View Profile WWW
January 17, 2020, 07:20:27 AM
 #12

After several tries to update to SP1, i finally gave up and installed ubuntu into it. Electrum seems to work now. I think the version of OS i had could not be auto upgraded using windows update. I always got the dialog telling windows is up to date and still could not go through the installation of C++ package.

Why not go for Windows 10? It's quite fluid and I've installed Electrum on it without any issues.

Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!