Bitcoin Forum
February 23, 2020, 05:45:19 AM *
News: Latest Bitcoin Core release: 0.19.0.1 [Torrent]
 
   Home   Help Search Login Register More  
Pages: « 1 [2]  All
  Print  
Author Topic: Electrum Lightning Demo  (Read 251 times)
DireWolfM14
Copper Member
Hero Member
*****
Offline Offline

Activity: 672
Merit: 1392


https://bitcoin.watfordfc.com


View Profile WWW
February 06, 2020, 10:22:12 PM
 #21

yeah... wrong wording on my behalf, I didn't mean checkout... I meant build... if I look in my "fresh clone" directory... cat electrum/version.py shows version 4.0.0.a0, but for some reason, when running the build.sh, it is only building 3.3.8 version??!? Huh

EDIT: disregard, it's just naming the output file incorrectly... it is in fact building the 4.0.0a0 version:


I transferred the "3.3.8" portable .exe file out of the Ubuntu VirtualBox and ran it on the Windows 10 host Wink

I'm getting the same issue with names, but I have not been able to confirm if I'm actually building 4.0.0a0.  Trying to run the portable version on my Win10 machine I get an error saying the file cannot be found.  I tried running it right from the desktop, so I don't know how that's possible.  Do I need to install some python run environment something or other in Windows?

  ▄▄█████▄▄███████▄▄
 ███████████
     ▀▀███▄
█████████████        ▀██▄
█████████████          ██▄
███████████            ██▄
██▀▀█████▀▀              ██
██                       ██
██                       ██
▀██                     ██▀
 ▀██                   ██▀
  ▀██▄               ▄██▀
    ▀███▄▄       ▄▄███▀
       ▀▀█████████▀▀
███████   INDUSTRY LEADING CRYPTO SPORTSBOOK   ███████
MULTI
CURRENCY
ONLINE
   CASINO  
DAILY PRICE
BOOSTS
FAST & SECURE
PAYMENTS
█████████████████████████
███████▀▀       ▀▀███████
████▀   ▄ ▀███▀ ▄   ▀████
███  ▄████▄ ▀ ▄████▄  ███
██  ▄ ▀███▀ ▄ ▀███▀ ▄  ██
█  ▄██ ▀▀ ▄███▄ ▀▀ ██▄  █
█  █▀ ▄█ ███████ █▄ ▀█  █
█   ▄███▄ █████ ▄███▄   █
██  ████▀ ▄▄▄▄▄ ▀████  ██
███  ▀ ▄ ▀█████▀ ▄ ▀  ███
████▄  ▀▀▄ ███ ▄▀▀  ▄████
███████▄▄       ▄▄███████
█████████████████████████
█████████████████████████
███████▀▀ █████ ▀▀███████
████▀    ▄█████▄    ▀████
█████▄▄█▀▀ ▄▄▄ ▀▀█▄▄█████
██▀███▀ ▄███▀███▄ ▀███▀██
█   █ ▄██▀     ▀██▄ █   █
█   █ ██         ██ █   █
█   █ ▀██▄▄█ █▄▄██▀ █   █
██▄███▄ ▀██▄▄▄██▀ ▄███▄██
█████▀▀█▄▄ ▀▀▀ ▄▄█▀▀█████
████▄    ▀█████▀    ▄████
███████▄▄ █████ ▄▄███████
█████████████████████████
.
.REGISTER NOW!.
Report To
1582436719
Hero Member
*
Offline Offline

Posts: 1582436719

View Profile Personal Message (Offline)

Ignore
1582436719
Reply with quote  #2

1582436719
Report to moderator
100% First Deposit Bonus Instant Withdrawals Best Odds 10+ Sports Since 2014 No KYC Asked Play Now
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1582436719
Hero Member
*
Offline Offline

Posts: 1582436719

View Profile Personal Message (Offline)

Ignore
1582436719
Reply with quote  #2

1582436719
Report to moderator
1582436719
Hero Member
*
Offline Offline

Posts: 1582436719

View Profile Personal Message (Offline)

Ignore
1582436719
Reply with quote  #2

1582436719
Report to moderator
HCP
Legendary
*
Offline Offline

Activity: 1246
Merit: 2264

<insert witty quote here>


View Profile
February 10, 2020, 08:19:50 AM
 #22

I'm getting the same issue with names,
Just FYI, the file name "bug" is caused because the build-wine system uses:
Code:
VERSION=`git describe --tags --dirty --always`
to fetch the version number... and the git "tags" are currently returning 3.3.8 Tongue


Quote
...but I have not been able to confirm if I'm actually building 4.0.0a0.  Trying to run the portable version on my Win10 machine I get an error saying the file cannot be found.  
If you're building from the MASTER branch, it will be building 4.0.0a0... you can have a quick look in /electrum/version.py file and see what it says there...


Which file cannot be found? Huh


Quote
I tried running it right from the desktop, so I don't know how that's possible.  Do I need to install some python run environment something or other in Windows?
So you tried to compile the .exe? or you were running from a clone of the github repository using Python? Huh

Pages: « 1 [2]  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!