Bitcoin Forum
December 10, 2016, 01:17:13 AM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Noobie, please help!  (Read 4776 times)
jctusmc03
Jr. Member
*
Offline Offline

Activity: 31


View Profile
November 27, 2011, 05:34:44 AM
 #1

Hello everyone, I've recently decided to start solo mining bitcoins for personal uses mostly and I'm having some trouble getting everything running correctly. I've been trying, and reading different tutorials for around 4 hours.

When trying to start GUIMiner (v2011-08-24) I keep getting "Problems communicating with bitcoin RPC" error. None of the probably...4+ guides that I've tried out so far have fixed this problem. I feel like it's something stupid I'm missing, but I would rather just ask and look stupid then keep trying to figure this out.

Can anyone help me out, and maybe give me some suggestions?

Edit: This is my setup

|:| Lian-Li PC7F: Corsair 1000w PSU, EVGA E758-A1 - i7 920 D0 @ 3.8ghz(1.35v) w/ Corsair H50 - 6GB Corsair Dominator
|:| Video - 2X XFX 5870 1GB
|:| Storage: Kingston 128GB SSD - 2x 2TB WD Black - 2TB WD Green
1481332633
Hero Member
*
Offline Offline

Posts: 1481332633

View Profile Personal Message (Offline)

Ignore
1481332633
Reply with quote  #2

1481332633
Report to moderator
1481332633
Hero Member
*
Offline Offline

Posts: 1481332633

View Profile Personal Message (Offline)

Ignore
1481332633
Reply with quote  #2

1481332633
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
P4man
Hero Member
*****
Offline Offline

Activity: 504



View Profile
November 27, 2011, 09:44:43 AM
 #2

Post your bitcoin.conf and guiminer settings.

axelj
Newbie
*
Offline Offline

Activity: 16



View Profile WWW
November 27, 2011, 10:10:12 AM
 #3

i did had a similar problem a while ago..

Got alot of Alertpay chash, i can buy bitcoins for a 50% higher price then normal!
(You cant get scammed with alertpay because i send the money as "donation")

PM me!
tysat
Legendary
*
Offline Offline

Activity: 952


Keep it real


View Profile
November 27, 2011, 12:03:35 PM
 #4

I would really suggest mining with a pool, the odds of you discovering a block solo mining are very low.  I would suggest slush because of the merged mining aspect and it's easy to setup.
jctusmc03
Jr. Member
*
Offline Offline

Activity: 31


View Profile
November 27, 2011, 05:01:12 PM
 #5

Post your bitcoin.conf and guiminer settings.

This is my GUIMiner Settings:

{
    "profiles": [
        {
            "username": "(Removed)",
            "balance_auth_token": "",
            "name": "Default",
            "hostname": "localhost",
            "external_path": "",
            "affinity_mask": 255,
            "flags": "-v -w128",
            "autostart": false,
            "device": 0,
            "password": "(Removed)",
            "port": "8332"
        }
    ],
    "bitcoin_executable": "D:\\Bitcoin\\bitcoin-0.5.0-win32\\bitcoin-0.5.0-win32\\bitcoin-qt.exe",
    "show_console": false,
    "show_summary": false,
    "show_opencl_warning": true,
    "console_max_lines": 5000,
    "start_minimized": false,
    "window_position": [
        115,
        205,
        495,
        287
    ]
}

These are my BITCoin settings:

# bitcoin.conf configuration file. Lines beginning with # are comments.


# Network-related settings:

# Run on the test network instead of the real bitcoin network.
#testnet=1

# Connect via a socks4 proxy
#proxy=127.0.0.1:9050

# Use as many addnode= settings as you like to connect to specific peers
#addnode=69.164.218.197
#addnode=10.0.0.2:8333

# ... or use as many connect= settings as you like to connect ONLY
# to specific peers:
#connect=69.164.218.197
#connect=10.0.0.1:8333

# Do not use Internet Relay Chat (irc.lfnet.org #bitcoin channel) to
# find other peers.
#noirc=1

# Maximum number of inbound+outbound connections.
#maxconnections=


# JSON-RPC options (for controlling a running Bitcoin/bitcoind process)

# server=1 tells Bitcoin to accept JSON-RPC commands.
#server=1

# You must set rpcuser and rpcpassword to secure the JSON-RPC api
#rpcuser=Ulysseys
#rpcpassword=YourSuperGreatPasswordNumber_385593

# By default, only RPC connections from localhost are allowed.  Specify
# as many rpcallowip= settings as you like to allow connections from
# other hosts (and you may use * as a wildcard character):
#rpcallowip=10.1.1.34
#rpcallowip=(removed)

# Listen for RPC connections on this TCP port:
rpcport=8332

# You can use Bitcoin or bitcoind to send commands to Bitcoin/bitcoind
# running on another host using this option:
rpcconnect=127.0.0.1

# Use Secure Sockets Layer (also known as TLS or HTTPS) to communicate
# with Bitcoin -server or bitcoind
#rpcssl=1

# OpenSSL settings used when rpcssl=1
rpcsslciphers=TLSv1+HIGH:!SSLv2:!aNULL:!eNULL:!AH:!3DES:@STRENGTH
rpcsslcertificatechainfile=server.cert
rpcsslprivatekeyfile=server.pem


# Miscellaneous options

# Set gen=1 to attempt to generate bitcoins
gen=0

# Use SSE instructions to try to generate bitcoins faster.
#4way=1

# Pre-generate this many public/private key pairs, so wallet backups will be valid for
# both prior transactions and several dozen future transactions.
keypool=100

# Pay an optional transaction fee every time you send bitcoins.  Transactions with fees
# are more likely than free transactions to be included in generated blocks, so may
# be validated sooner.
paytxfee=0.00

# Allow direct connections for the 'pay via IP address' feature.
#allowreceivebyip=1


# User interface options

# Start Bitcoin minimized
#min=1

# Minimize to the system tray
#minimizetotray=1
P4man
Hero Member
*****
Offline Offline

Activity: 504



View Profile
November 27, 2011, 05:05:48 PM
 #6

edit: brainfart.

Need to see bitcoind.conf and make sure its running

jctusmc03
Jr. Member
*
Offline Offline

Activity: 31


View Profile
November 27, 2011, 05:18:28 PM
 #7

edit: brainfart.

Need to see bitcoind.conf and make sure its running

Here ya go.

.TH BITCOIN.CONF "5" "January 2011" "bitcoin.conf 3.19"
.SH NAME
bitcoin.conf \- bitcoin configuration file
.SH SYNOPSIS
All command-line options (except for '-datadir' and '-conf') may be specified in a configuration file, and all configuration file options may also be specified on the command line. Command-line options override values set in the configuration file.
.TP
The configuration file is a list of 'setting=value' pairs, one per line, with optional comments starting with the '#' character.
.TP
The configuration file is not automatically created; you can create it using your favorite plain-text editor. By default, bitcoind(1) will look for a file named bitcoin.conf(5) in the bitcoin data directory, but both the data directory and the configuration file path may be changed using the '-datadir' and '-conf' command-line arguments.
.SH LOCATION
bitcoin.conf should be located in $HOME/.bitcoin
.SH NETWORK-RELATED SETTINGS
.TP
.TP
\fBtestnet=\fR[\fI'1'\fR|\fI'0'\fR]
Enable or disable run on the test network instead of the real *bitcoin* network.
.TP
\fBproxy=\fR\fI'127.0.0.1:9050'\fR
Connect via a socks4 proxy.
.TP
\fBaddnode=\fR\fI'10.0.0.2:8333'\fR
Use as many *addnode=* settings as you like to connect to specific peers.
.TP
\fBconnect=\fR\fI'10.0.0.1:8333'\fR
Use as many *connect=* settings as you like to connect ONLY to specific peers.
.TP
\fBnoirc=\fR[\fI'1'\fR|\fI'0'\fR]
Use or Do not use Internet Relay Chat (irc.lfnet.org #bitcoin channel) to find other peers.
.TP
\fRmaxconnections=\fR\fI'value'\fR
Maximum number of inbound+outbound connections.
.SH JSON-RPC OPTIONS
.TP
\fBserver=\fR[\fI'1'\fR|\fI'0'\fR]
Tells *bitcoin* to accept or not accept JSON-RPC commands.
.TP
\fBrpcuser=\fR\fI'username'\fR
You must set *rpcuser* to secure the JSON-RPC api.
.TP
\fBrpcpassword=\fR\fI'password'\fR
You must set *rpcpassword* to secure the JSON-RPC api.
.TP
\fBrpctimeout=\fR\fI'30'\fR
How many seconds *bitcoin* will wait for a complete RPC HTTP request, after the HTTP connection is established.
.TP
\fBrpcallowip=\fR\fI'192.168.1.*'\fR
By default, only RPC connections from localhost are allowed. Specify as many *rpcallowip=* settings as you like to allow connections from other hosts (and you may use * as a wildcard character).
.TP
\fBrpcport=\fR\fI'8332'\fR
Listen for RPC connections on this TCP port.
.TP
\fBrpcconnect=\fR\fI'127.0.0.1'\fR
You can use *bitcoin* or *bitcoind(1)* to send commands to *bitcoin*/*bitcoind(1)* running on another host using this option.
.TP
\fBrpcssl=\fR\fI'1'\fR
Use Secure Sockets Layer (also known as TLS or HTTPS) to communicate with *bitcoin* '-server' or *bitcoind(1)*. Example of OpenSSL settings used when *rpcssl*='1':
.TP
\fBrpcsslciphers=\fR\fI'TLSv1+HIGH:!SSLv2:!aNULL:!eNULL:!AH:!3DES:@STRENGTH'\fR
.TP
\fBrpcsslcertificatechainfile=\fR\fI'server.cert'\fR
.TP
\fBrpcsslprivatekeyfile=\fR\fI'server.pem'\fR
.TP
.SH MISCELLANEOUS OPTIONS
.TP
\fBgen=\fR[\fI'0'\fR|\fI'1'\fR]
Enable or disable attempt to generate bitcoins.
.TP
\fB4way=\fR[\fI'0'\fR|\fI'1'\fR]
Enable or disable use SSE instructions to try to generate bitcoins faster.
.TP
\fBkeypool=\fR\fI'100'\fR
Pre-generate this many public/private key pairs, so wallet backups will be valid for both prior transactions and several dozen future transactions.
.TP
\fBpaytxfee=\fR\fI'0.00'\fR
Pay an optional transaction fee every time you send bitcoins. Transactions with fees are more likely than free transactions to be included in generated blocks, so may be validated sooner.
.TP
\fBallowreceivebyip=\fR\fI'1'\fR
Allow direct connections for the 'pay via IP address' feature.
.TP
.SH USER INTERFACE OPTIONS
.TP
\fBmin=\fR[\fI'0'\fR|\fI'1'\fR]
Enable or disable start bitcoind minimized.
.TP
\fBminimizetotray=\fR[\fI'0'\fR|\fI'1'\fR]
Enable or disable minimize to the system tray.
.SH "SEE ALSO"
bitcoind(1)
.SH AUTHOR
This manual page was written by Micah Anderson <micah@debian.org> for the Debian system (but may be used by others). Permission is granted to copy, distribute and/or modify this document under the terms of the GNU General Public License, Version 3 or any later version published by the Free Software Foundation.

On Debian systems, the complete text of the GNU General Public License can be found in /usr/share/common-licenses/GPL.
P4man
Hero Member
*****
Offline Offline

Activity: 504



View Profile
November 27, 2011, 08:54:01 PM
 #8

Thats not the conf file, but now Im unsure if you actually need a bitcoind.conf or not.
Are you running the daemon (bitcoind) or the GUI client?

If you use the client you have to edit your bitcoin.conf file, uncomment the user and password and set server=1 (which I think is the same as starting the daemon with  -daemon parameter)

jctusmc03
Jr. Member
*
Offline Offline

Activity: 31


View Profile
November 27, 2011, 09:09:58 PM
 #9

Thats not the conf file, but now Im unsure if you actually need a bitcoind.conf or not.
Are you running the daemon (bitcoind) or the GUI client?

If you use the client you have to edit your bitcoin.conf file, uncomment the user and password and set server=1 (which I think is the same as starting the daemon with  -daemon parameter)


Sorry, here is the bitcoin.conf from c-user-username-appdata-roaming-bitcoin, all I have of it at least: (I had to create this file because it was not there as I was following one of the guides.)

rpcuser=(I have my username here)
rpcpassword=(I have my password here)

Do I need more than that in the file? That's all it shows for me.

I've tried running bitcoind and all it does is open for around 5 seconds, this message shows:

"Error: To use bitcoind, you must set rpcpassword=<password>
in the configuration file: C:\Username\AppData\Roaming\Bitcoin\bitcoin.conf
If the file does not exist, create it with owner-readable-only file permissions."

I also don't know how to make a owner-readable-only file permission, there is no option for this that I could find besides the "read-only" check box at the bottom of properties and I've tried that and it still shows that "Error:" message. Also, it's still showing as a text document file. I've tried renaming it to .conf, and .cfg with now such luck changing it's type. Edit: I grabbed another .cfg file from somewhere else on the computer and tried naming it bitcoin.conf, and bitcoin.cfg and put the required information in it and it's still not working.

Please tell me this is something easy to fix, this is getting uber annoying. Haha.
cablepair
Hero Member
*****
Offline Offline

Activity: 854


https://btc-republic.com/index.php?ref=cablepair


View Profile WWW
November 27, 2011, 09:35:36 PM
 #10

heres an easy fix

open up windows explorer
in the path window type %appdata%
hit enter

then double click the Bitcoin directory

then open up bitcoin.conf with your favorite text editor (notepad will work)

delete everything in the file (yes seriously)

then add this

Quote
server=1
rpcallowip=*
rpcuser=miner
rpcpassword=miner
rpcport=8332

save that, then close Bitcoin and open it back up

you should be able to mine a crossed the network now, find out what that machines local network IP is
click start button > run
type cmd

then type ipconfig > hit enter

you should see something like

   IPv4 Address. . . . . . . . . . . : 192.168.1.3 <--- yours will very a little

this number thats the IP you put in guiminer

so with guiminer you put

 http://192.168.1.3 port 8332 username miner password miner


let me know how it turns out

jctusmc03
Jr. Member
*
Offline Offline

Activity: 31


View Profile
November 27, 2011, 10:23:45 PM
 #11

heres an easy fix

open up windows explorer
in the path window type %appdata%
hit enter

then double click the Bitcoin directory

then open up bitcoin.conf with your favorite text editor (notepad will work)

delete everything in the file (yes seriously)

then add this

Quote
server=1
rpcallowip=*
rpcuser=miner
rpcpassword=miner
rpcport=8332

save that, then close Bitcoin and open it back up

you should be able to mine a crossed the network now, find out what that machines local network IP is
click start button > run
type cmd

then type ipconfig > hit enter

you should see something like

   IPv4 Address. . . . . . . . . . . : 192.168.1.3 <--- yours will very a little

this number thats the IP you put in guiminer

so with guiminer you put

 http://192.168.1.3 port 8332 username miner password miner


let me know how it turns out



This is really becoming irritating more than anything, but it's still not working I'm still getting the "Problems communicating with bitcoin RPC 1 2, 2 2" errors.

Edit: I've tried adding all of the programs to MSE cleared list as well, adding exceptions to Windows firewall, and even turning both programs off and I still get the same error.
cablepair
Hero Member
*****
Offline Offline

Activity: 854


https://btc-republic.com/index.php?ref=cablepair


View Profile WWW
November 27, 2011, 11:05:41 PM
 #12

you did those steps exactly like I told you to?

if you pay me 5 btc I will remote access your computer and set it up for you


Theres nothing else I can explain to you to do... you must of missed something, only other thing you could try is turning your firewall off completely and see if that makes a difference.

tysat
Legendary
*
Offline Offline

Activity: 952


Keep it real


View Profile
November 27, 2011, 11:14:48 PM
 #13

Don't use your IP address in guiminer, 'localhost' should work just fine.
cablepair
Hero Member
*****
Offline Offline

Activity: 854


https://btc-republic.com/index.php?ref=cablepair


View Profile WWW
November 28, 2011, 12:31:08 AM
 #14

the instructions I gave where to solo mine from another computer on your network...

is the miner and bitcoind on the same machine?

in that case use IP : 127.0.0.1
paraipan
Legendary
*
Offline Offline

Activity: 924


Firstbits: 1pirata


View Profile WWW
November 28, 2011, 12:46:17 AM
 #15

i think you should uncomment the lines related to rpc connection from your bitcoin.conf file, remove the #

Code:
# JSON-RPC options (for controlling a running Bitcoin/bitcoind process)

# server=1 tells Bitcoin to accept JSON-RPC commands.
server=1

# You must set rpcuser and rpcpassword to secure the JSON-RPC api
rpcuser=Ulysseys
rpcpassword=YourSuperGreatPasswordNumber_385593

# By default, only RPC connections from localhost are allowed.  Specify
# as many rpcallowip= settings as you like to allow connections from
# other hosts (and you may use * as a wildcard character):
rpcallowip=10.1.1.34
rpcallowip=(removed)

BTCitcoin: An Idea Worth Saving - Q&A with bitcoins on rugatu.com - Check my rep
jctusmc03
Jr. Member
*
Offline Offline

Activity: 31


View Profile
November 28, 2011, 04:33:58 AM
 #16

the instructions I gave where to solo mine from another computer on your network...

is the miner and bitcoind on the same machine?

in that case use IP : 127.0.0.1

I messaged you, hopefully you got it since I'm new here. I'm just going to try to start from the top following your directions only and not trying others until I try yours. That way I don't have to worry about crap being messed up already before I apply your settings.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!