Bitcoin Forum
November 23, 2017, 03:12:50 PM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: SSH Hanging on Xubuntu 13.10 Headless  (Read 543 times)
Androidicus
Sr. Member
****
Offline Offline

Activity: 339


View Profile
March 27, 2014, 11:15:22 AM
 #1

Cannot find this particular issue in any other thread...

I have two particular rigs running Xubuntu 13.10 - different GPUs in each.

Both rigs have identical cgminer 3.7.2 compiled and apart from one XFX R9 270 being a bit fussy with settings, all ok.

My issue is that on one rig, I can reliably run an SSH session via Putty and do:

Code:
prompt$ screen -S mine  ./startMINERSCRIPT

then CTL+A d to detach, exit out of Putty - then hours later (when I get home from work) open a Putty session and do:

Code:
prompt$ screen -r mine

And I'm in there seeing my cgminer screen.

However, on the other rig - (after doing exactly as above) - when I try and Putty(SSH) in later it just times out. Can't ping the rig and 'no route to host' reported. Wierdly, I can ping the rig if I log into the firewall/router at home and ping its IP from the routers (Netgear) built in diagnostics screen... but not from box on the LAN

Only way to get back up regain SSH access is to hard reboot the rig. INTERESTINGLY - The rig carries on mining happily in isolation and is visible on the pool/s! Therefore, its still connected on the LAN, is still sending/receiving packets to pool but is deaf to ping and any other attempts to speak with it or control it...

I should add that the rig in question uses a USB Pi Hut Ralink WiFi dongle as link whereas the other rig (which is at work) is hard wired on LAN there...

Any thoughts good people?



Failure is success waiting to happen...
1511449970
Hero Member
*
Offline Offline

Posts: 1511449970

View Profile Personal Message (Offline)

Ignore
1511449970
Reply with quote  #2

1511449970
Report to moderator
1511449970
Hero Member
*
Offline Offline

Posts: 1511449970

View Profile Personal Message (Offline)

Ignore
1511449970
Reply with quote  #2

1511449970
Report to moderator
Join ICO Now Coinlancer is Disrupting the Freelance marketplace!
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1511449970
Hero Member
*
Offline Offline

Posts: 1511449970

View Profile Personal Message (Offline)

Ignore
1511449970
Reply with quote  #2

1511449970
Report to moderator
1511449970
Hero Member
*
Offline Offline

Posts: 1511449970

View Profile Personal Message (Offline)

Ignore
1511449970
Reply with quote  #2

1511449970
Report to moderator
Androidicus
Sr. Member
****
Offline Offline

Activity: 339


View Profile
March 27, 2014, 08:19:21 PM
 #2

Ok, no thoughts...

By way of an update, as mentioned, I can use the router admin diagnostics utility to ping the rig but nothing is getting through from LAN.

Re-booting router gets PING & SSH back via LAN

Woah - just tried and got ping and ssh back after leaving it over an hour (without re-booting router this time) - wierd...


Failure is success waiting to happen...
Androidicus
Sr. Member
****
Offline Offline

Activity: 339


View Profile
March 27, 2014, 08:21:52 PM
 #3

...and it's gone again...  Angry

Failure is success waiting to happen...
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!