Bitcoin Forum
December 03, 2016, 07:49:49 PM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: 2 wallets 1 hub (windows + linux + tor)  (Read 741 times)
GreenSheen
Newbie
*
Offline Offline

Activity: 5


View Profile
December 13, 2011, 02:21:27 PM
 #1

I have tor set-up on two machines, which are both connected to the same router. (both have the same public ip when I don't use tor or anything).
I configured tor and bitcoin the same way on both, the only difference is one is linux the other is windows.

Now to the problem:
Linux computer is stuck at synchronizing with network 0%. Even when I added connect=<ip of my main pc> in the config. (also how come when I open bitcoind, nothing happens and it disappears in the processes within a seconds?)

I just want bitcoin to work on my linux without leaking information. Is there a tutorial for non-pros? I can only find one about security, not anonymity. It would also be good to have some kind of way of verifying that the transfer is in fact anonymous.

[The two machiens use different wallets]

I think the essential information comes down to:
Which router configurations for ANONYMOUS wallet use?
What bitcoin settings?
What steps to verify?

Thanks in advance.
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1480794589
Hero Member
*
Offline Offline

Posts: 1480794589

View Profile Personal Message (Offline)

Ignore
1480794589
Reply with quote  #2

1480794589
Report to moderator
1480794589
Hero Member
*
Offline Offline

Posts: 1480794589

View Profile Personal Message (Offline)

Ignore
1480794589
Reply with quote  #2

1480794589
Report to moderator
1480794589
Hero Member
*
Offline Offline

Posts: 1480794589

View Profile Personal Message (Offline)

Ignore
1480794589
Reply with quote  #2

1480794589
Report to moderator
Flip Tulipcoin
Newbie
*
Offline Offline

Activity: 14


View Profile
December 13, 2011, 05:02:12 PM
 #2

The linux distribution you are using would be helpful to know.

I have had bitcoin open and close when it didn't like a setting I had changed in the bitcoin.conf file. You should find the file on at least one of two places, for example:

tmpfs # ls -l /etc/bitcoin/
total 16
-rw-r--r-- 1 root    root    4166 Dec  9 12:29 bitcoin.conf
-rw------- 1 bitcoin bitcoin   80 Aug 21 22:30 bitcoin.conf.ins
-rw-r--r-- 1 root    root    4014 Aug 21 22:36 bitcoin.conf.sample
lnx2 tmpfs # ls -l ~/.bitcoin/
total 1180992
-rw------- 1 root root     24576 Dec 13 09:15 __db.001
-rw------- 1 root root    589824 Dec 13 11:51 __db.002
-rw------- 1 root root    270336 Dec 13 11:51 __db.003
-rw------- 1 root root    163840 Dec 13 11:51 __db.004
-rw------- 1 root root   6307840 Dec 13 11:51 __db.005
-rw------- 1 root root     49152 Dec 13 11:51 __db.006
-rw------- 1 root root  45256704 Dec 13 11:51 addr.dat
lrwxrwxrwx 1 root root        25 Aug 26 07:39 bitcoin.conf -> /etc/bitcoin/bitcoin.conf
-rw-r--r-- 1 root root       113 Aug 23 06:20 bitcoin.conf.minimal
-rw------- 1 root root 820730796 Dec 13 11:28 blk0001.dat
-rw------- 1 root root 328019968 Dec 13 11:28 blkindex.dat
drwx------ 2 root root      4096 Dec 13 08:35 database
-rw------- 1 root root       236 Dec  4 16:09 db.log
-rw------- 1 root root   7961953 Dec 13 11:51 debug.log
-rw------- 1 root root   1503232 Dec 13 09:15 wallet.dat


Also, check the system log, which is often the file /var/log/messages, for example here's a message from mine:

tmpfs # grep bitcoin messages
Dec 13 08:35:43 lnx2 /etc/init.d/bitcoind[6052]: start-stop-daemon: 1 process refused to stop
Dec 13 08:35:43 lnx2 /etc/init.d/bitcoind[6043]: ERROR: bitcoind failed to stop




It's time for the U.S. to throw Israel under the bus. The pure avarice of a colonial land grab by European colonists after WWII has nothing to do with religious tolerance or freedom, to the contrary, it mocks both by hiding behind them.
GreenSheen
Newbie
*
Offline Offline

Activity: 5


View Profile
December 13, 2011, 05:45:21 PM
 #3

Hey, thanks for the reply.

I checked the system log, there's no mention of bitcoin.
And actually I realised that as long as I leave the socks proxy unchecked it works fine. As soon as I restart it with the default TOR socks data (127.0.0.1, at port 9050) it stops finding connections (zero), even though I can browse through tor at the same time just fine.

Maybe I could use a different port? But how would I do that still using tor?
Any other suggestions? I feel like I'm in a "This should definitely work, there's no reason it shouldn't, but it doesn't." situation.

I'm running ubuntu 10.04 32-bit.
Flip Tulipcoin
Newbie
*
Offline Offline

Activity: 14


View Profile
December 13, 2011, 06:05:11 PM
 #4

Hey, thanks for the reply.

I checked the system log, there's no mention of bitcoin.
And actually I realised that as long as I leave the socks proxy unchecked it works fine. As soon as I restart it with the default TOR socks data (127.0.0.1, at port 9050) it stops finding connections (zero), even though I can browse through tor at the same time just fine.

Maybe I could use a different port? But how would I do that still using tor?
Any other suggestions? I feel like I'm in a "This should definitely work, there's no reason it shouldn't, but it doesn't." situation.

I'm running ubuntu 10.04 32-bit.

Do you have anything else working with the Tor socks proxy? For example the browser SeaMonkey can be configured to use it. Check to see if Tor is listening on port 9050 ( in the example below I am using 9100 )

tmp # netstat -an|grep 9100
tcp        0      0 127.0.0.1:9100          0.0.0.0:*               LISTEN


It's time for the U.S. to throw Israel under the bus. The pure avarice of a colonial land grab by European colonists after WWII has nothing to do with religious tolerance or freedom, to the contrary, it mocks both by hiding behind them.
GreenSheen
Newbie
*
Offline Offline

Activity: 5


View Profile
December 13, 2011, 07:01:28 PM
 #5

Hey, thanks for the reply.

I checked the system log, there's no mention of bitcoin.
And actually I realised that as long as I leave the socks proxy unchecked it works fine. As soon as I restart it with the default TOR socks data (127.0.0.1, at port 9050) it stops finding connections (zero), even though I can browse through tor at the same time just fine.

Maybe I could use a different port? But how would I do that still using tor?
Any other suggestions? I feel like I'm in a "This should definitely work, there's no reason it shouldn't, but it doesn't." situation.

I'm running ubuntu 10.04 32-bit.

Do you have anything else working with the Tor socks proxy? For example the browser SeaMonkey can be configured to use it. Check to see if Tor is listening on port 9050 ( in the example below I am using 9100 )

tmp # netstat -an|grep 9100
tcp        0      0 127.0.0.1:9100          0.0.0.0:*               LISTEN



I tried:
netstat -an|grep 9050
netstat -anp|grep 9050
sudo netstat -an|grep 9050
sudo netstat -anp|grep 9050

(I'm linux newb)
didn't come back with anything (while bitcoin was running with socks 9050 port supposedly running).

I should also add that this is a very fresh format, so there's almost nothing on that machine.
GreenSheen
Newbie
*
Offline Offline

Activity: 5


View Profile
December 13, 2011, 07:14:02 PM
 #6

If it matters I found:

Prot  Recv-Q  Send-Q  Local Address    Foreign Address    State
tcp   0              0        0.0.0.0:8333      0.0.0.0:*          LISTEN

I know that 8333 is the default bitcoin port.
Flip Tulipcoin
Newbie
*
Offline Offline

Activity: 14


View Profile
December 13, 2011, 08:11:06 PM
 #7

If it matters I found:

Prot  Recv-Q  Send-Q  Local Address    Foreign Address    State
tcp   0              0        0.0.0.0:8333      0.0.0.0:*          LISTEN

I know that 8333 is the default bitcoin port.

Good, that's probably bitcoind listening. See if you can find some evidence of tor being installed or running, like the configuration file /etc/tor/torrc. If it is there there is a line in it that indicates the tor socks listener port, which defaults to 9050:


#SocksPort 9050 # what port to advertise for application connections


If this is present and either commented as above (to default to 9050) or set to 9050, see if you can find tor running, otherwise it looks like tor isn't running at all.

tmp # ps -eaf|grep tor

root      3022 11309  0 15:08 pts/4    00:00:00 grep --colour=auto tor

tor      17868     1  0 09:25 ?        00:00:07 /usr/bin/tor -f /etc/tor/torrc --runasdaemon 1 --PidFile /var/run/tor/tor.pid


It's time for the U.S. to throw Israel under the bus. The pure avarice of a colonial land grab by European colonists after WWII has nothing to do with religious tolerance or freedom, to the contrary, it mocks both by hiding behind them.
GreenSheen
Newbie
*
Offline Offline

Activity: 5


View Profile
December 13, 2011, 10:36:07 PM
 #8

Good shot, I think that's where the problem is.

SocksPort is set to 'auto'

and when I go into the visual menu of tor and change it to 9050 instead of auto it's reversed back to auto again upon restart. The same when I edit it in the torrc itself: upon restart SocksPort returns to 'auto'.

And in my windows tor it's set to manually 9050.

I'm trying to find some ways to 'keep' it. Maybe there is a way to make it read-only in linux? I'll play around with this a bit.
Flip Tulipcoin
Newbie
*
Offline Offline

Activity: 14


View Profile
December 13, 2011, 10:52:32 PM
 #9

Good shot, I think that's where the problem is.

SocksPort is set to 'auto'

and when I go into the visual menu of tor and change it to 9050 instead of auto it's reversed back to auto again upon restart. The same when I edit it in the torrc itself: upon restart SocksPort returns to 'auto'.

And in my windows tor it's set to manually 9050.

I'm trying to find some ways to 'keep' it. Maybe there is a way to make it read-only in linux? I'll play around with this a bit.

I recall having issues with some Tor gui software and settings several years ago, but I can't recall what they were. I do recall the upshot is that I only use the Tor service and edit the torrc manually. There is a gui application named vidalia I have used to observe the Tor network, but that and the SeaMonkey browser are my only GUI apps for Tor.

If you are behind a firewall or using NAT with a router you may need to forward port 8333 and the two Tor ports in the excerpt below from my torrc, I run both on a machine that has it's own firewall and has a public IP address so no forwarding is required.


#ORPort 49001
## If you want to listen on a port other than the one advertised
## in ORPort, uncomment the line below. You'll need to do ipchains
## or other port forwarding yourself to make this work.
#ORBindAddress 0.0.0.0:9090
#ORBindAddress 0.0.0.0:9001

## Uncomment this to mirror the directory for others (please do)
#DirPort 9030 # what port to advertise for directory connections

It's time for the U.S. to throw Israel under the bus. The pure avarice of a colonial land grab by European colonists after WWII has nothing to do with religious tolerance or freedom, to the contrary, it mocks both by hiding behind them.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!