Bitcoin Forum
December 13, 2017, 06:02:12 AM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: R9 290 display driver crashes on stock  (Read 1272 times)
whitetoo
Sr. Member
****
Offline Offline

Activity: 294



View Profile WWW
March 29, 2014, 04:21:18 PM
 #1

hi guys,

I have two of these cards:
http://www.sapphiretech.com/presentation/product/?cid=1&gid=3&sgid=1227&pid=2091&lid=1

After countless hours of tweaking and testing I cannot get these cards to mine scrypt.

Running AMD 13.11 Beta 9.2
I have tried AMD 13.12 but have the same behavior.

The cards can run fine from anywhere from 2 minutes to 2 hours and then the display driver crashes.
Can any guru shed some light on what I have missed? Thank you very much for any assistance in advance!

This is my current config

Quote
"intensity" : "20,20",
"vectors" : "1,1",
"worksize" : "512,512",
"lookup-gap" : "2,2",
"gpu-threads" : "1",
"thread-concurrency" : "24550,24550",
"gpu-engine" : "1000,1000",
"gpu-fan" : "40-77,40-77",
"gpu-memclock" : "1300,1300",
"temp-cutoff" : "95",
"temp-overheat" : "85",
"temp-target" : "75",
"api-mcast-port" : "4028",
"api-port" : "4028",
"expiry" : "120",
"failover-switch-delay" : "60",
"gpu-dyninterval" : "7",
"gpu-platform" : "1",
"log" : "5",
"log-dateformat" : "0",
"no-pool-disable" : true,
"queue" : "1",
"scan-time" : "60",
"temp-hysteresis" : "3",
"shares" : "0",
"scrypt" : true,
"kernel" : "scrypt,scrypt",
"kernel-path" : "/usr/local/bin"
1513144932
Hero Member
*
Offline Offline

Posts: 1513144932

View Profile Personal Message (Offline)

Ignore
1513144932
Reply with quote  #2

1513144932
Report to moderator
1513144932
Hero Member
*
Offline Offline

Posts: 1513144932

View Profile Personal Message (Offline)

Ignore
1513144932
Reply with quote  #2

1513144932
Report to moderator
The Bitcoin network protocol was designed to be extremely flexible. It can be used to create timed transactions, escrow transactions, multi-signature transactions, etc. The current features of the client only hint at what will be possible in the future.
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1513144932
Hero Member
*
Offline Offline

Posts: 1513144932

View Profile Personal Message (Offline)

Ignore
1513144932
Reply with quote  #2

1513144932
Report to moderator
1513144932
Hero Member
*
Offline Offline

Posts: 1513144932

View Profile Personal Message (Offline)

Ignore
1513144932
Reply with quote  #2

1513144932
Report to moderator
1513144932
Hero Member
*
Offline Offline

Posts: 1513144932

View Profile Personal Message (Offline)

Ignore
1513144932
Reply with quote  #2

1513144932
Report to moderator
gtraah
Sr. Member
****
Offline Offline

Activity: 420



View Profile
March 29, 2014, 04:41:33 PM
 #2

I feel your pain, I have been through it all  - and here are the common issues why this happens:

HEAT <<< Was my issue, Bought a industrial fan and faced it at my miners and BOOOM 5-7c lower - No more driver crashes
POWER<<< Lack of power via your PSU
DRIVER ISSUE<<<  - Uninstall all drivers - REmove everything from your computer ATI & AMD related (even manually going into system32 etc and deleting the files), then use CCcleaner and do the registry clean - keep running until all errors gone, Then re-install the latest drivers 13.12 ONLY DRIVERS Catalyst known to cause issues
UNDERCLOCK & INTENSITY<<< OK this is a very important one to try, Trust me on this I did this and kept on rising untill things went stable I actually found a awesome setting which reduced heat and power and hasrate was almost like it was at stock clocks but they were underclocked

Start at GPU Engine - 850
GPU MEMclock - 1000
Intensity - 16

^^^^ Yes these are below stock levels but just trust me here if you want to find out what your card can really do whilst mining, I am pretty sure GPU's are NOT intended to run at mining intensity 24/7 so even stock clocks can crash the card if they are weak.

(I found that -I 20 GPUengine 850 & GPUmemclk 1000 seemed to be nice and stable and gave me good WU almost as good as stock ) Then you ass the less power consumption and heat and it averages out the same.

If you decide to try -I 16 Eng 850 & MEM 1000 yes your hashrate will be less offcourse around 650-700KH per card but you will now keep increasing in increments until you see a driver crash.


some info above which I am positive you will get something out off and also learn more about your cards and get these things running stable
 

█ █ █ █ █
█ █ ● █ █
● █ █ █ █
█ ● █ █ █
█ █ █ █ ●
█ █ █ █ █
█ ● █ █ █
● █ █ ● █
█ █ █ █ █
█ █ █ █ █
█ ● █ █ █
● █ █ █ ●
█ █ █ █ █
               ▄▄█  █▄▄
            ▄█████  █████▄
       ▄  █▄ ▀▀███  ███▀▀ ▄█  ▄
   ▄▄███  ████▄▄ ▀  ▀ ▄▄████  ███▄▄

  ▀▀███  ████▀▀ ▄  ▄ ▀▀████  ███▀▀  ▄
███▄▄  ▀  ▀▀ ▄▄███  ███▄▄ ▀▀  ▀  ▄▄███
█████▀      ▀█████  █████▀      ▀█████
█▀▀  ▄▄█  ██▄▄ ▀▀█  █▀▀ ▄▄██  █▄▄  ▀▀█
   █████  ██████      ██████  █████
█▄▄  ▀▀█  ██▀▀ ▄▄█  █▄▄ ▀▀██  █▀▀  ▄▄█
█████▄      ▄█████  █████▄      ▄█████
███▀▀  ▄  ▄▄ ▀▀███  ███▀▀ ▄▄  ▄  ▀▀███
▀  ▄▄███  ████▄▄ ▀  ▀ ▄▄████  ███▄▄  ▀
   ▀▀███  ████▀▀ ▄  ▄ ▀▀████  ███▀▀
       ▀  █▀ ▄▄███  ███▄▄ ▀█  ▀
            ▀█████  █████▀
               ▀▀█  █▀▀
█ █ █ █ █
█ █ ● █ █
● █ █ █ █
█ ● █ █ █
█ █ █ █ ●
█ █ █ █ █
█ ● █ █ █
● █ █ ● █
█ █ █ █ █
█ █ █ █ █
█ ● █ █ █
● █ █ █ ●
█ █ █ █ █
A Blog That Discusses About
Artificial Intelligence   The Future   Ethics on AI   and more
█ █ █ █ █
█ █ ● █ █
● █ █ █ █
█ ● █ █ █
█ █ █ █ ●
█ █ █ █ █
█ ● █ █ █
● █ █ ● █
█ █ █ █ █
█ █ █ █ █
█ ● █ █ █
● █ █ █ ●
█ █ █ █ █
whitetoo
Sr. Member
****
Offline Offline

Activity: 294



View Profile WWW
March 30, 2014, 09:46:27 AM
 #3

Hi gtraah,

Thank you very much for taking the time to reply.

I followed your step as per your advice, the system seems a little more stable without the catalyst software so thank you for that.

I am still struggling with the hash rates however.

Start at GPU Engine - 850
GPU MEMclock - 1000
Intensity - 16

This brings in just 560khs per card, admittedly the drivers do not crash.
I am able to run at intensity 20 on these settings but I am bearly reaching 750khs even then and no shares are received. Nuts!!

I ran a BTC miner a year or so ago with 7970 cards and never had this much trouble.

Would you mind sharing your entire config so I can cross check numbers?

I have tried well over 50-60 different sets of settings over the past week and my braincells are starting to flag.

Thank you once again
Equate
Hero Member
*****
Offline Offline

Activity: 700


View Profile
March 30, 2014, 10:04:34 AM
 #4

play with the voltage of the card and see how it works.
Starscream
Sr. Member
****
Offline Offline

Activity: 280

All hail Lord Megatron!


View Profile
March 30, 2014, 11:45:07 AM
 #5

Worksize 512 has no meaning with r9 290, use 256.

Vectors have no meaning when it comes to scrypt mining.

Use the latest SGminer: http://sgminerwindows.com/

Go back to default clock speeds: 947/1250 (core/mem respectively).

Use AMD 13.12 drivers.

Make sure you have no undervolting or overvolting applied.

Run the miner. Does it work fine? (doesn't need to be at optimized speeds, but is it above 800KH/s?)

If all is well than it's time to tweak the settings: find which memory type you got (elpida, hynixafr, hynixmfr) and search for configuration that work well with it (mostly clock speeds).

TC value depends on the amount of system RAM you got.

The last step is to optimize your voltage once you found the speed you like.


 
 
           ▄████▄
         ▄████████▄
       ▄████████████▄
     ▄████████████████▄
    ████████████████████      ▄█▄                 ▄███▄                 ▄███▄                 ▄████████████████▀   ▄██████████

  ▄▄▄▀█████▀▄▄▄▄▀█████▀▄▄▄     ▀██▄             ▄██▀ ▀██▄             ▄██▀ ▀██▄             ▄██▀                   ██
▄█████▄▀▀▀▄██████▄▀▀▀▄█████▄     ▀██▄         ▄██▀     ▀██▄         ▄██▀     ▀██▄         ▄██▀        ▄█▄          ▀██████████████▄
████████████████████████████       ▀██▄     ▄██▀         ▀██▄     ▄██▀         ▀██▄     ▄██▀          ▀█▀                        ██
 ▀████████████████████████▀          ▀██▄ ▄██▀             ▀██▄ ▄██▀     ▄█▄     ▀██▄ ▄██▀                                       ██
   ▀████████████████████▀              ▀███▀                 ▀███▀       ▀█▀       ▀███▀      ▄███████████████████████████████████▀
     ▀████████████████▀
       ▀████████████▀
         ▀████████▀
           ▀████▀
║║


║║
.
.

║║
██
║║
.
.

║║
██
║║
.
║║


║║
whitetoo
Sr. Member
****
Offline Offline

Activity: 294



View Profile WWW
March 30, 2014, 07:13:46 PM
 #6

Hi guys,

Thanks for the info and help - I really appreciate it.

I am running the latest SGminer with AMD 13.12 drivers.
I am not under or overvolting the card at the moment.

With a default clock speeds of 947/1250 I am receiving only 450khs per card?
I have changed the worksize to 256.

What intensity should I be running here? I see many people saying that -I 13 should be fine, however the litecoin hardware comparison chart shows many settings in the -I 20 area.
I've read that this can damage the cards in other places. Any further pointers would be great if you have the time. Thank you!
Starscream
Sr. Member
****
Offline Offline

Activity: 280

All hail Lord Megatron!


View Profile
March 30, 2014, 07:54:33 PM
 #7

Hi guys,

Thanks for the info and help - I really appreciate it.

I am running the latest SGminer with AMD 13.12 drivers.
I am not under or overvolting the card at the moment.

With a default clock speeds of 947/1250 I am receiving only 450khs per card?
I have changed the worksize to 256.

What intensity should I be running here? I see many people saying that -I 13 should be fine, however the litecoin hardware comparison chart shows many settings in the -I 20 area.
I've read that this can damage the cards in other places. Any further pointers would be great if you have the time. Thank you!
The intensity levels you're talking about depends on the number of gpu threads that are being used. For R9 290 you're gonna use -g 1 (1 gpu thread - they don't play well with -g 2) which comes with higher intensities: -i 20, although you can go lower to -i 19, -i 18 and even -i 17.
-i 13 is for cards that use -g 2 like the 280x.


 
 
           ▄████▄
         ▄████████▄
       ▄████████████▄
     ▄████████████████▄
    ████████████████████      ▄█▄                 ▄███▄                 ▄███▄                 ▄████████████████▀   ▄██████████

  ▄▄▄▀█████▀▄▄▄▄▀█████▀▄▄▄     ▀██▄             ▄██▀ ▀██▄             ▄██▀ ▀██▄             ▄██▀                   ██
▄█████▄▀▀▀▄██████▄▀▀▀▄█████▄     ▀██▄         ▄██▀     ▀██▄         ▄██▀     ▀██▄         ▄██▀        ▄█▄          ▀██████████████▄
████████████████████████████       ▀██▄     ▄██▀         ▀██▄     ▄██▀         ▀██▄     ▄██▀          ▀█▀                        ██
 ▀████████████████████████▀          ▀██▄ ▄██▀             ▀██▄ ▄██▀     ▄█▄     ▀██▄ ▄██▀                                       ██
   ▀████████████████████▀              ▀███▀                 ▀███▀       ▀█▀       ▀███▀      ▄███████████████████████████████████▀
     ▀████████████████▀
       ▀████████████▀
         ▀████████▀
           ▀████▀
║║


║║
.
.

║║
██
║║
.
.

║║
██
║║
.
║║


║║
envym3
Newbie
*
Offline Offline

Activity: 11


View Profile
March 30, 2014, 11:46:49 PM
 #8

I have your same GPU's and have had your same issues, multiple times.

Here are my suggestions to alleviate driver crash:
*Use the AMD 14.3 Drivers
*Try these settings:
setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_USE_SYNC_OBJECTS 1
cgminer.exe --scrypt -o [your info] -u [your info] -p [your info] -g 1 -w 512 --lookup-gap 2 --thread-concurrency 24500 -I 20 --gpu-powertune 20

Important: Save these settings in your batch file. After you've saved your batch file, launch MSI afterburner. Set your core clock to 1000 and your mem clock to 1250, save your settings to profile 1 and click "apply over clocking at system startup." After that, go into the settings for MSI afterburner, and check off that the program launches at system startup. 

These steps will keep you from getting your clocks stuck and continuing the driver crash issue even after system reboot.

*When you get the "driver has crashed..." message, you can't just restart the computer, you need to shut it off via the PSU switch and then reboot.

*Make sure you are running nothing else on your rig except for SGminer/CGminer and MSI afterburner.

These steps should have you hashing around 820-850 kh/s with the Tri-x cards and stable. If you are unable to achieve stability with these steps and settings, it is probably a power issue.  Exactly what PSU are you using?

*I would also strongly suggest updating your motherboard BIOS. 

You can review a thread I posted where I was having the exact same issues as you are with the same setup:
http://www.overclock.net/t/1476740/i-may-have-just-fried-3x-r9-290

Lastly, don't give up and don't assume your cards are toast. You will figure this out, its just going to take a lot of patience and a lot of work. Trust me, I've been there.


Instagram: @wesdewayne

#turnt4cryptos
whitetoo
Sr. Member
****
Offline Offline

Activity: 294



View Profile WWW
April 02, 2014, 12:07:02 PM
 #9

Thanks for your help, I really appreciate it. After much testing I have found that a card in my rig was faulty and I will be receiving a replacement. This jippy card was tripping the other two.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!