Bitcoin Forum
September 22, 2017, 04:41:48 AM *
News: Latest stable version of Bitcoin Core: 0.15.0.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: The only output is fan noise and hot air  (Read 1241 times)
Proofer
Sr. Member
****
Offline Offline

Activity: 254


View Profile
December 17, 2011, 07:57:17 AM
 #1

EDIT:  Posted in wrong forum, and the forum won't let me delete it.  I am going to repost in the cgminer forum.

cgminer 2.0.8, Ubuntu 10.04

I first ran cgminer this evening on my newly-built 3x5970 rig.  I access the rig from a Mac on a LAN via SSH.  And since this was to be a first familiarization run, I started with solo mining, pointing cgminer at an instance of bitcoind on my Mac.

I use this small script to run it:
Code:
#!/bin/bash
now="`date +%Y%m%d%H%M%S`"
cd ~/miners
DISPLAY=:0 cgminer -c cgminer.conf 2> logs/$now.log

(Confidential to those helping me earlier today:  I was logged in on the rig, so I dropped the sudo.)

When cgminer starts, I notice two things immediately:
It outputs a line on the terminal saying it started;
The GPU fan speeds increase substantially.

I also notice a little later via ps that there are six cgminer processes, which I hope is normal at one per GPU core.  I also notice a file in the current directory:
-rw-r--r-- 1 root root 750880 2011-12-16 22:36 phatk110817Cypressbitalignv2w128long8.bin

The log file is created, but it's empty.  Nor is there any further console output.

Here's the thing:  it's not responsive to the keyboard.  Keypress commands such as P, G, or Q are merely echoed.  I wondered if this had something to do with using a remote terminal, so I tried running it locally.  Whoops, I had specified an -intensity of 8 for all six cores, so in effect I was locked out of my monitor.  (I know about "d" but the .conf was intended for remote use and I had forgotten that.)

So each time I ran it I stopped it (and dropped the GPU fan revs) by rebooting.

Here's the .conf file, based on the example that came with the source code:
Code:
{
"pools" : [
{
"url" : "http://192.168.168.123:8332",
"user" : "oboy",
"pass" : "supersekrit"
}
],

"intensity" : "8",
"gpu-engine" : "0-950",
"gpu-fan" : "0-85",
"temp-cutoff" : "95,95,95,95,95,95",
"temp-overheat" : "85,85,85,85,85,85",
"temp-target" : "75,75,75,75,75,75",

"auto-fan" : true,
"auto-gpu" : true,
"expiry" : "120",
"gpu-threads" : "2",
"log" : "5",
"queue" : "1",
"retry-pause" : "5",
"scan-time" : "60",
"temp-hysteresis" : "3",
"worksize" : "0",

"donation" : "0.00",
"shares" : "0",
"kernel-path" : "/usr/local/bin"
}

OK guys, I have braced myself for looking stupid:  why is it unresponsive to the terminal and producing no output?
1506055308
Hero Member
*
Offline Offline

Posts: 1506055308

View Profile Personal Message (Offline)

Ignore
1506055308
Reply with quote  #2

1506055308
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
P4man
Hero Member
*****
Offline Offline

Activity: 518



View Profile
December 17, 2011, 08:35:32 AM
 #2

There should only be 1 cgminer process.
First of all, may I suggest you install "screen" so you can attach and detach console sessions.

then do the following:

#!/bin/bash
now="`date +%Y%m%d%H%M%S`"
cd ~/miners
export DISPLAY=:0
screen ./cgminer -c cgminer.conf 2

(whats the purpose of the 2 ?)
You can ssh in to the machine and reattach the console to see whats going on with

screen -r
or
screen -r -d

Should that work, may I also suggest changing

"donation" : "0.00",
into
"donation" : "0.5",

Smiley

Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!