Bitcoin Forum
December 04, 2016, 08:19:18 PM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: 5.1 compile problems  (Read 18161 times)
cdnbcguy
Full Member
***
Offline Offline

Activity: 128


View Profile WWW
December 22, 2011, 09:56:24 AM
 #1

When I do the required packages installation I get this error

Package libdb4.8++-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

When I do the make I then get this error

src/net.cpp:18:32: fatal error: miniupnpc/miniwget.h: No such file or directory
compilation terminated.

I'm running Ubuntu Narwhal. Any ideas, please?


Annona ad! Please keep in mind that there is nothing wrong with Bitcoin itself. All it's scandals are caused by wonky websites and sleazy people exploiting it. The light attracts bugs.

When all this bullshit drys up and blows away, Bitcoin will be stronger than ever.
1480882758
Hero Member
*
Offline Offline

Posts: 1480882758

View Profile Personal Message (Offline)

Ignore
1480882758
Reply with quote  #2

1480882758
Report to moderator
1480882758
Hero Member
*
Offline Offline

Posts: 1480882758

View Profile Personal Message (Offline)

Ignore
1480882758
Reply with quote  #2

1480882758
Report to moderator
1480882758
Hero Member
*
Offline Offline

Posts: 1480882758

View Profile Personal Message (Offline)

Ignore
1480882758
Reply with quote  #2

1480882758
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1480882758
Hero Member
*
Offline Offline

Posts: 1480882758

View Profile Personal Message (Offline)

Ignore
1480882758
Reply with quote  #2

1480882758
Report to moderator
cdnbcguy
Full Member
***
Offline Offline

Activity: 128


View Profile WWW
December 28, 2011, 03:25:24 AM
 #2

No matter what I do, including deleting the bitcoin dir and re-cloning it from github, I still get

src/net.cpp:18:32: fatal error: miniupnpc/miniwget.h: No such file or directory
compilation terminated.


and that's with

make USE_UPNP=

However, I did notice that when I run qmake at the beginning it says this

qmake
Project MESSAGE: Building with UPNP support
Project MESSAGE: Building with UPNP support
Removed plural forms as the target language has less forms.
If this sounds wrong, possibly the target language is not set or recognized.

Is this important? Thanks for your time, by the way.

Annona ad! Please keep in mind that there is nothing wrong with Bitcoin itself. All it's scandals are caused by wonky websites and sleazy people exploiting it. The light attracts bugs.

When all this bullshit drys up and blows away, Bitcoin will be stronger than ever.
cdnbcguy
Full Member
***
Offline Offline

Activity: 128


View Profile WWW
December 28, 2011, 01:44:02 PM
 #3

Got it.

the trick was to run qmake with

qmake "USE_UPNP=-"

instead of

qmake "USE_UPNP="

Annona ad! Please keep in mind that there is nothing wrong with Bitcoin itself. All it's scandals are caused by wonky websites and sleazy people exploiting it. The light attracts bugs.

When all this bullshit drys up and blows away, Bitcoin will be stronger than ever.
coingarbler
Newbie
*
Offline Offline

Activity: 13


View Profile
April 18, 2013, 08:43:13 AM
 #4

I had similar problems with Ubuntu 12.10 (quantal), but it worked with:

sudo apt-get install libminiupnpc-dev libminiupnpc8


which installed all the necessary header/library files.
The versions for narwhal will probably be different -
You can:
apt-cache search libminiupnpc

to find them.
Remember remember the 5th of November
Legendary
*
Offline Offline

Activity: 1526

Reverse engineer from time to time


View Profile
April 18, 2013, 11:01:55 AM
 #5

When I do the required packages installation I get this error

Package libdb4.8++-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

When I do the make I then get this error

src/net.cpp:18:32: fatal error: miniupnpc/miniwget.h: No such file or directory
compilation terminated.

I'm running Ubuntu Narwhal. Any ideas, please?


Well duh, "fatal error: miniupnpc/miniwget.h: No such file or directory" was pretty self-explanatory, you apparently did not read after the first paragraph.

BTC:1AiCRMxgf1ptVQwx6hDuKMu4f7F27QmJC2
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!