Bitcoin Forum
December 04, 2016, 12:33:10 PM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Anyone try AMD Stream 2.4?  (Read 2204 times)
Dr. Arnold
Newbie
*
Offline Offline

Activity: 17


View Profile
April 08, 2011, 04:31:18 AM
 #1

I was wondering if anyone has tried AMD's new version of stream or as they now call it AMD Accelerated Parallel Processing (APP) 2.4

How does it affect your MH/s compared to older versions?

I was using 2.2 before I was forced to reformat my computer so I'm just going to continue with that. Hopefully it works good with catalyst 11.3.
1480854790
Hero Member
*
Offline Offline

Posts: 1480854790

View Profile Personal Message (Offline)

Ignore
1480854790
Reply with quote  #2

1480854790
Report to moderator
1480854790
Hero Member
*
Offline Offline

Posts: 1480854790

View Profile Personal Message (Offline)

Ignore
1480854790
Reply with quote  #2

1480854790
Report to moderator
1480854790
Hero Member
*
Offline Offline

Posts: 1480854790

View Profile Personal Message (Offline)

Ignore
1480854790
Reply with quote  #2

1480854790
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1480854790
Hero Member
*
Offline Offline

Posts: 1480854790

View Profile Personal Message (Offline)

Ignore
1480854790
Reply with quote  #2

1480854790
Report to moderator
1480854790
Hero Member
*
Offline Offline

Posts: 1480854790

View Profile Personal Message (Offline)

Ignore
1480854790
Reply with quote  #2

1480854790
Report to moderator
allinvain
Legendary
*
Offline Offline

Activity: 1988



View Profile
April 08, 2011, 04:38:32 AM
 #2

Hmm haven't tried 2.4 yet, but I did try to run 11.2 with SDK 2.1 which was utter failure..lol I guess you have to use the catalyst driver packages that actually contain a specific version of the SDK (in this case I desire 2.1). Installing the SDK on top of an existing catalyst driver package which already contains the SDK files fails..at least it did for me.

2.2 and 2.1 are supposedly the fastest. That's what I intend to use in a my new dedicated miner. I can't use it on my main desktop machine because I like to have the latest drivers for gaming reasons. But I'd imagine 2.4 is probably as fast as 2.3.

gjs278
Jr. Member
*
Offline Offline

Activity: 33


View Profile
April 08, 2011, 04:38:57 AM
 #3

I tried it here... poclbm wouldn't run after that
allinvain
Legendary
*
Offline Offline

Activity: 1988



View Profile
April 08, 2011, 04:40:50 AM
 #4

I tried it here... poclbm wouldn't run after that

So you're saying you tried 2.4 with 11.3?

11.3 still uses Stream 2.3 AFAIK.


gjs278
Jr. Member
*
Offline Offline

Activity: 33


View Profile
April 08, 2011, 04:44:07 AM
 #5

on linux, I have 11.3 for drivers, and I tried 2.4 stream. I just got an error message and it refuses to start, even after recompiling pyopencl.
allinvain
Legendary
*
Offline Offline

Activity: 1988



View Profile
April 08, 2011, 04:46:26 AM
 #6

on linux, I have 11.3 for drivers, and I tried 2.4 stream. I just got an error message and it refuses to start, even after recompiling pyopencl.

Ah ok. Never tried it in linux, but hmm you're probably going to need to reinstall 11.3. I guess it's a matter of waiting for 2.4 to be integrated into the catalyst driver package.

gjs278
Jr. Member
*
Offline Offline

Activity: 33


View Profile
April 08, 2011, 04:57:49 AM
 #7

yeah tried all that, no go. oh well, back to 2.2 for now.
Jaime Frontero
Full Member
***
Offline Offline

Activity: 126


View Profile
April 08, 2011, 07:32:51 AM
 #8

i dunno 'bout that.

i'm running SDK 2.1 on debian testing and Catalyst 11.2 on top of a couple'a 5850s loaded up with DiabloMiner.  it works.

in fact, it works real good.

i think i'll be waiting for some serious feedback from some serious folks before i change anything:

...even my underwear.   Shocked
nster
Full Member
***
Offline Offline

Activity: 126



View Profile
April 08, 2011, 07:45:30 AM
 #9

I had to run the sdk 2.2 package to uninstall it before I could install 2.4

167q1CHgVjzLCwQwQvJ3tRMUCrjfqvSznd Donations are welcome Smiley Please be kind if I helped
qed
Full Member
***
Offline Offline

Activity: 196


View Profile
April 08, 2011, 08:11:38 AM
 #10

I'll give it a try it later on linux. You do not need to "install" anything, just decompress it and replace the environmental variables on the current prompt.

EDIT: "Installed" without problems. Do not need to recompile the pyopencl for AMD cards, but you do need to replace the icd-registration files. I do not see any change from 2.3 on an HD6950.

Mobile App (Android)

Monitor miners, exchange rates and Bitcoin network stats.
gjs278
Jr. Member
*
Offline Offline

Activity: 33


View Profile
April 08, 2011, 09:18:58 AM
 #11

Traceback (most recent call last):
  File "./poclbm.py", line 27, in <module>
    platforms = cl.get_platforms()
pyopencl.LogicError: clGetPlatformIDs failed: invalid/unknown error code

is my output for 2.4
qed
Full Member
***
Offline Offline

Activity: 196


View Profile
April 08, 2011, 09:29:00 AM
 #12

Traceback (most recent call last):
  File "./poclbm.py", line 27, in <module>
    platforms = cl.get_platforms()
pyopencl.LogicError: clGetPlatformIDs failed: invalid/unknown error code

is my output for 2.4

You have to decompress the icd-registration.tgz file into the root directory.

Mobile App (Android)

Monitor miners, exchange rates and Bitcoin network stats.
sethsethseth
Sr. Member
****
Offline Offline

Activity: 256


Not trusting third parties with my private keys


View Profile
April 08, 2011, 09:23:05 PM
 #13

Running dual 5970's and 11.2 drivers and sdk 2.1 with crossfire enabled on win7 64bit and using http://bitcoinpool.com/ miner cause that seems to be the only one that works with sdk 2.1.  If someone posts that 2.4 is faster I'll try that.

SealsWithClubs poker room has  over 400 players online. Buy in from .01 to 60btc.      BTCSportsMatch lets you bet sports with vig free lines!  Best kept secret in bitcoin....          LocalBitcoins.com is very user-friendly now for bank transfers.  You don't have to live close to trade when in the same currency area.           
Electrum client is awesome. Try it. And please stop sending bitcoins to sites run by security newbies, or don't complain when you lose everything.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!