Bitcoin Forum
December 08, 2016, 06:37:49 PM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Ubuntu 11.04 - 5970 - No valid I/O port address  (Read 1394 times)
lamething
Newbie
*
Offline Offline

Activity: 5


View Profile
January 03, 2012, 11:48:38 PM
 #1

I have been mining quite consistently on a BAMT rig for the past 5-months. The setup has been an ASUS P5B with 4x Sapphire 5830s. I am using 3 - PCI 1x risers with 5v power and then a single PCI-E 16x slot.
Here comes the issue! I decied to pick up a Diamond 5970 and sold one of my 5830's to a friend. I replaced the 5830 in the PCI-E 16x slot with the new 5970.
Once booted I immediately started getting this:
Code:
lamething@miner2:/var/log$ aticonfig --odgt --adapter=all
ERROR - Get temperature failed for Adapter 0 - ATI Radeon HD 5900 Series
ERROR - Get temperature failed for Adapter 1 - ATI Radeon HD 5900 Series

Adapter 2 - ATI Radeon HD 5800 Series
            Sensor 0: Temperature - 25.00 C

Adapter 3 - ATI Radeon HD 5800 Series
            Sensor 0: Temperature - 26.50 C

Adapter 4 - ATI Radeon HD 5800 Series
            Sensor 0: Temperature - 27.50 C

I then did a :
Code:
lamething@miner2:/var/log$ aticonfig --initial -f --adapter=all
No protocol specified
Uninitialised file found, configuring.
Using /etc/X11/xorg.conf
Saving back-up to /etc/X11/xorg.conf.fglrx-1
I then rebooted (after the initialize) and still have the same issue. If I physically remove 2 of the 5830s the 5970 will come online and I am able to utilize it (read/set clocks, mine, etc) but naturally that is not ideal. Smiley
I have since moved the system to a Ubuntu 11.04 64-bit install and am now back in the exact same spot.
I currently am using the AMD 11.6 fglrx driver from here http://www2.ati.com/drivers/linux/ati-driver-installer-11-6-x86.x86_64.run I have also attempted to use the Ubuntu 11.04 repository fglrx, same issue and Catalyst 11.10 -- all driver installs have been done a clean Ubuntu 11.04 64bit installation.

Here is the device section of my xorg.conf:
Code:
Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID       "PCI:3:0:0"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[1]-0"
        Driver      "fglrx"
        BusID       "PCI:4:0:0"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[2]-0"
        Driver      "fglrx"
        BusID       "PCI:8:0:0"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[3]-0"
        Driver      "fglrx"
        BusID       "PCI:7:0:0"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[4]-0"
        Driver      "fglrx"
        BusID       "PCI:6:0:0"
EndSection

I believe this is the root issue in the Xorg.0.log:

Code:
[    13.991] (==) fglrx(0): NoAccel = NO
[    13.991] (==) fglrx(0): ATI 2D Acceleration Architecture enabled
[    13.992] (--) fglrx(0): Chipset: "ATI Radeon HD 5900 Series" (Chipset = 0x689c)
[    13.992] (--) fglrx(0): (PciSubVendor = 0x1002, PciSubDevice = 0x2542)
[    13.992] (==) fglrx(0): board vendor info: original ATI graphics adapter
[    13.992] (--) fglrx(0): Linear framebuffer (phys) at 0x40000000
[    13.992] (--) fglrx(0): MMIO registers at 0xff3c0000
[    13.992] (EE) fglrx(0): No valid I/O port address
[    13.992] (EE) fglrx(0): PreInitAdapter failed
[    13.992] (EE) fglrx(0): PreInit failed
The above issue happens for both cores of the 5970.

I verified that they PCI configuration is correct:
Code:
lamething@miner2:/var/log$ lspci -vv | grep Radeon

Code:
lamething@miner2:/var/log$ lspci -vv | grep Radeon
03:00.0 VGA compatible controller: ATI Technologies Inc Hemlock [ATI Radeon HD 5900 Series] (prog-if 00 [VGA controller])
03:00.1 Audio device: ATI Technologies Inc Cypress HDMI Audio [Radeon HD 5800 Series]
        Subsystem: ATI Technologies Inc Cypress HDMI Audio [Radeon HD 5800 Series]
04:00.0 Display controller: ATI Technologies Inc Hemlock [ATI Radeon HD 5900 Series]
06:00.0 VGA compatible controller: ATI Technologies Inc Radeon HD 5800 Series (Cypress LE) (prog-if 00 [VGA controller])
06:00.1 Audio device: ATI Technologies Inc Cypress HDMI Audio [Radeon HD 5800 Series]
07:00.0 VGA compatible controller: ATI Technologies Inc Radeon HD 5800 Series (Cypress LE) (prog-if 00 [VGA controller])
07:00.1 Audio device: ATI Technologies Inc Cypress HDMI Audio [Radeon HD 5800 Series]
08:00.0 VGA compatible controller: ATI Technologies Inc Radeon HD 5800 Series (Cypress LE) (prog-if 00 [VGA controller])
08:00.1 Audio device: ATI Technologies Inc Cypress HDMI Audio [Radeon HD 5800 Series]
After seeing this issue I decided to try an x86 Ubuntu 11.04 to no avail.
Any information/ideas is greatly appreciated. I have been troubleshooting this for 2-days straight now and am just at a loss.

Thanks!
1481222269
Hero Member
*
Offline Offline

Posts: 1481222269

View Profile Personal Message (Offline)

Ignore
1481222269
Reply with quote  #2

1481222269
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
lamething
Newbie
*
Offline Offline

Activity: 5


View Profile
January 04, 2012, 03:04:10 AM
 #2

Upon further investigation with lshw/lspci and reviewing /proc/interrupts while I removed video cards and re-added I noticed some weird IRQ issues.
I then had to go into my BIOS and enable ACPI 2.0 and disable APCI APIC support.
Then I went through and disabled EVERY possible peripheral device including the USB controller itself (managing the miner remotely).

And then boom! Everything showed up properly in /proc/interrupts and aticonfigs were working across all cards!

I guess that is what I get for using an old(ish) MB. Haha.

lamething
Newbie
*
Offline Offline

Activity: 5


View Profile
January 04, 2012, 11:46:10 AM
 #3

I used to fool with mining on ubuntu, but unity drove me away

#! for the win

thanks for the posts though, also, trying to get my newbie count up
Thanks for the reply, man!

I may have spoke too soon. It didn't run through the night.

I quickly did a:
Code:
apt-get install procinfo

Then ran procinfo:

Code:
irq   0:        135  timer               irq  22:         60  hda_intel
irq   1:          2  i8042               irq  23:         50  hda_intel
irq   2:          0  cascade             irq  24:         50  hda_intel
irq   6:          3  floppy              irq  25:         50  hda_intel
irq   8:          1  rtc0                irq  26:    1831187  fglrx[3]@PCI:3:0:
irq   9:          0  acpi                irq  27:      13551  fglrx[4]@PCI:4:0:
irq  10:      15570  ata_piix, ata_pii   irq  28:       9810  fglrx[0]@PCI:8:0:
irq  12:          4  i8042               irq  29:       8756  fglrx[1]@PCI:7:0:
irq  21:       6972  eth0                irq  30:       5015  fglrx[2]@PCI:6:0:

PCI-3 (my 5970) is showing pretty high interrupts. This unfortunately may not be a long term solution. Sad


P4man
Hero Member
*****
Offline Offline

Activity: 504



View Profile
January 04, 2012, 04:39:10 PM
 #4

Are you using 64 bit ubuntu? If you arent, you should.
You can also try disabling everything you dont need in the bios, like floppy, firewire, audio, etc.

casascius
Mike Caldwell
VIP
Legendary
*
Offline Offline

Activity: 1344


The Casascius 1oz 10BTC Silver Round (w/ Gold B)


View Profile WWW
January 04, 2012, 05:11:54 PM
 #5

I agree, I had issues with 3+ cards with 32bit ubuntu that magically vanished when I did nothing other than switch to 64-bit.  OP mentions already being 64-bit though.

Companies claiming they got hacked and lost your coins sounds like fraud so perfect it could be called fashionable.  I never believe them.  If I ever experience the misfortune of a real intrusion, I declare I have been honest about the way I have managed the keys in Casascius Coins.  I maintain no ability to recover or reproduce the keys, not even under limitless duress or total intrusion.  Remember that trusting strangers with your coins without any recourse is, as a matter of principle, not a best practice.  Don't keep coins online. Use paper wallets instead.
lamething
Newbie
*
Offline Offline

Activity: 5


View Profile
January 04, 2012, 11:36:35 PM
 #6

Are you using 64 bit ubuntu? If you arent, you should.
You can also try disabling everything you dont need in the bios, like floppy, firewire, audio, etc.

I originally was running 64bit but that was prior to me realizing it was IRQ issues.
All-in-all it looks like disabling every peripheral in the BIOS resolved the issue.
The interrupts still seem a little high on my first GPU of the 5970 but the system seems stable at least! Hooray!

DeathAndTaxes
Donator
Legendary
*
Offline Offline

Activity: 1218


Gerald Davis


View Profile
January 04, 2012, 11:40:32 PM
 #7

All-in-all it looks like disabling every peripheral in the BIOS resolved the issue.

Plus it saves a few watts.  Those IDE controllers, and USB 3.0 controllers, and onboard sound all pull some wasted wattage.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!