Bitcoin Forum
December 11, 2016, 10:23:32 AM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: [SOLVED] linux: 2nd gpu won't start  (Read 1668 times)
wazoo42
Jr. Member
*
Offline Offline

Activity: 42


View Profile
January 11, 2012, 10:44:27 PM
 #1

After multiple google searches and searches through this forum I haven't found a solution, so I apologize if I missed a previously posted answer.

I have 2 boxes with gentoo, kde-4, pyopencl-0.92, ati-stream-sdk-bin-2.5, ati-drivers-11.11, and phoenix-1.6.2. After updating @world the 2nd gpu won't mine on either box (they have both been mining properly since april). If I use pyopencl-0.92 then I get,

Code:
Invalid ELF header
FATAL kernel error: Failed to apply BFI_INT patch to kerne l! Is BFI_INT supported on this hardware?

If I use pyopencl-2011.2,
Code:
FATAL kernel error: Failed to load OpenCL kernel!

I have also ati-stream-sdk-2.4, the opencl included with ati-drivers, ati-drivers-11.12, and phoenix-1.73, and the above problem persists for all configurations. I call phoenix using,
Code:
python ./phoenix.py -u http://wazoo42:Enw8AqY9@bitcoinpool.com:8334/ -q 1 -k phatk2 DEVICE=1 VECTORS AGGRESSION=9 -v BFI_INT WORKSIZE=128

I have noticed that eselect only links libOpenCL.so.1 from /opt/amd-app-sdk/lib/x86_64 to /usr/lib64/libOpenCL.so.1, and I make a similar link to libOpenCL.so. Any thoughts as to what is broken and needs to be fixed? Thanks in advance.
1481451812
Hero Member
*
Offline Offline

Posts: 1481451812

View Profile Personal Message (Offline)

Ignore
1481451812
Reply with quote  #2

1481451812
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481451812
Hero Member
*
Offline Offline

Posts: 1481451812

View Profile Personal Message (Offline)

Ignore
1481451812
Reply with quote  #2

1481451812
Report to moderator
1481451812
Hero Member
*
Offline Offline

Posts: 1481451812

View Profile Personal Message (Offline)

Ignore
1481451812
Reply with quote  #2

1481451812
Report to moderator
wazoo42
Jr. Member
*
Offline Offline

Activity: 42


View Profile
January 11, 2012, 11:52:31 PM
 #2

One additional note. In the past, I only needed a monitor or dummy plug for the primary card and both would mine properly. I have tried having a monitor/dummy plug on both, but the 2nd card still won't start mining.
wazoo42
Jr. Member
*
Offline Offline

Activity: 42


View Profile
January 13, 2012, 09:24:54 PM
 #3

Here's another update. Aticonfig shows that I have two gpus, but when I run phoenix without DEVICE= then it shows one gpu and the cpu. This explains the error message regarding the ELF kernel and BFI_INT patching b/c phoenix is trying to apply this to the 1090T that shows up as device 1. How do I get phoenix to see my second gpu? I am guessing this is a pyopencl problem, given aticonfig sees both gpus.

Code:
No device specified or device not found, use DEVICE=ID to specify one of the following

    [0] Cypress                       
    [1] AMD Phenom(tm) II X6 1090T Processor

/opt/bin/aticonfig --list-adapters
* 0. 06:00.0 ATI Radeon HD 5800 Series 
  1. 02:00.0 ATI Radeon HD 5800 Series 

* - Default adapter
wazoo42
Jr. Member
*
Offline Offline

Activity: 42


View Profile
January 13, 2012, 09:49:03 PM
 #4

My bash script for starting the miners has export DISPLAY=:0.X, where X is 0 or 1, for setting the fan speeds. In the past that was good enough, but somewhere during my package upgrades it meant that ati-stream-sdk-bin no longer saw both cards when I used clinfo. As soon as I added export DISPLAY=:0 to my script (or in the screen session where phoenix is running) everything worked fine again.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!