Bitcoin Forum
November 17, 2018, 06:08:33 AM *
News: Latest Bitcoin Core release: 0.17.0 [Torrent].
   Home   Help Search Login Register More  
Pages: [1]
Author Topic: R9 290x Problem 400kh/s  (Read 375 times)
Offline Offline

Activity: 5
Merit: 0

View Profile
May 02, 2014, 07:35:02 PM

I have 5 r9 290x
Anyway long story short, 3 in one computer 2 in another.
About 3 weeks ago I stopped mining, prior to stopping all 5 cards were getting 750-890 kh/s scrypt; wu= 410-900  HW=0   per card, prior.

Now I am using the same cgminer and bat file, but the computer with 3, is only doing about 400kh/s a card

setx gpu_max_alloc_percent 100
cgminer --scrypt -o stratum+tcp:// -u Name -p dfsdsdfsfs -d 0,1 -I 20 -w 512 --thread-concurrency 32765

Also, with the computer with 3 cards.. when i try to use 32765 Thread-con it says there is not enough buffer memory.. however on my PC with 2 i get no errors.. I have to put the Thread-con to 8192 on the 3 pc machine... cards have 4gb of DDR5

Specs for the 3 card PC

(was a personal computer of mine,but )
Windows 7 64 bit
16 GB of ram
1090t 3.2Ghz hexacore amd
H80 corsair cooler
220mm and 140 mm fans blowing on gpu's with open case.
GPU Fans fluctuate depending on heat, capable of up to 4500-5k rpm per card
I use a fan controller, instead of setting it so, in cgminer -3.7.2
1200 watt gold psu
gpu-z reads the cards at about 217 watts at max per card. PSU about 4 months old, no signs that its failing.

I literally copied, the entire cgminer directory, over to the PC with 3.. and it still is saying there is not enough buffer... i have to lower it 8192... and that gives me around 400kh/s per card

AMD drivers are the same, across both systems both 13.12, both have sdk installed. I tried the new drivers.. still no good, catalyst and gpu-z both read the cards are 4gb

I did just notice that.. the intensity on my 2 card pc says 2, even though the bat says 20.. 
I am going to try to switch the cards around i guess.
see what happens.

Any advice would be greatly appreciated
Hero Member
Offline Offline

Posts: 1542434913

View Profile Personal Message (Offline)

Reply with quote  #2

Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
Sr. Member
Offline Offline

Activity: 364
Merit: 250

View Profile
May 02, 2014, 07:42:20 PM

Sounds like a wrong gpu-threads value.

Try adding "-g 1" (without quotes) to your bat file and check that your cfg file doesn't have "gpu-threads" : "2,2" anywhere and if it does than change it to "gpu-threads" : "1,1".
Pages: [1]
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!