Bitcoin Forum
December 11, 2016, 10:20:37 AM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: ATI Overdrive set clocks failing  (Read 6024 times)
CoinMan
Member
**
Offline Offline

Activity: 104



View Profile
April 22, 2011, 08:38:10 PM
 #1

I've been running ubuntu 10.10 x64 with a single HD 4850 the poclbm miner for a couple month's now and I just realized that my overclocking is no longer working (probably due to some recent updates).  I've lost about 10Mh/s and I can't seem to figure out WHY.  Any help would be appreciated.  I don't really know what else to look for to isolate the problem but here's what I have checked so far:

$ lspci -v
Code:
01:00.0 VGA compatible controller: ATI Technologies Inc M98L [Mobility Radeon HD 4850] (prog-if 00 [VGA controller])
Subsystem: XFX Pine Group Inc. Device 3000
Flags: bus master, fast devsel, latency 0, IRQ 44
Memory at d0000000 (64-bit, prefetchable) [size=256M]
Memory at feaf0000 (64-bit, non-prefetchable) [size=64K]
I/O ports at d000 [size=256]
Expansion ROM at feac0000 [disabled] [size=128K]
Capabilities: <access denied>
Kernel driver in use: fglrx_pci
Kernel modules: fglrx, radeon

$ fglrxinfo
Code:
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 4800 Series    
OpenGL version string: 3.3.10362 Compatibility Profile Context

$ cd /opt/ati-stream-sdk-v2.1-lnx64/samples/opencl/bin/x86_64/
/opt/ati-stream-sdk-v2.1-lnx64/samples/opencl/bin/x86_64$ ./CLInfo
Code:
Number of platforms: 1
  Platform Profile: FULL_PROFILE
  Platform Version: OpenCL 1.0 ATI-Stream-v2.1 (145)
  Platform Name: ATI Stream
  Platform Vendor: Advanced Micro Devices, Inc.
  Platform Extensions: cl_khr_icd


  Platform Name: ATI Stream
Number of devices: 2
  Device Type: CL_DEVICE_TYPE_CPU
  Device ID: 4098
  Max compute units: 2
  Max work items dimensions: 3
    Max work items[0]: 1024
    Max work items[1]: 1024
    Max work items[2]: 1024
  Max work group size: 1024
  Preferred vector width char: 16
  Preferred vector width short: 8
  Preferred vector width int: 4
  Preferred vector width long: 2
  Preferred vector width float: 4
  Preferred vector width double: 0
  Max clock frequency: 2900Mhz
  Address bits: 64
  Max memory allocation: 1073741824
  Image support: No
  Max size of kernel argument: 4096
  Alignment (bits) of base address: 1024
  Minimum alignment (bytes) for any datatype: 128
  Single precision floating point capability
    Denorms: Yes
    Quiet NaNs: Yes
    Round to nearest even: Yes
    Round to zero: No
    Round to +ve and infinity: No
    IEEE754-2008 fused multiply-add: No
  Cache type: Read/Write
  Cache line size: 64
  Cache size: 65536
  Global memory size: 3221225472
  Constant buffer size: 65536
  Max number of constant args: 8
  Local memory type: Global
  Local memory size: 32768
  Profiling timer resolution: 1
  Device endianess: Little
  Available: Yes
  Compiler available: Yes
  Execution capabilities:
    Execute OpenCL kernels: Yes
    Execute native function: No
  Queue properties:
    Out-of-Order: No
    Profiling : Yes
  Platform ID: 0x7f2e540c7228
  Name: AMD Athlon(tm) II X2 245 Processor
  Vendor: AuthenticAMD
  Driver version: 1.1
  Profile: FULL_PROFILE
  Version: OpenCL 1.0 ATI-Stream-v2.1 (145)
  Extensions: cl_khr_icd cl_amd_fp64 cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_int64_base_atomics cl_khr_int64_extended_atomics cl_khr_byte_addressable_store cl_khr_gl_sharing cl_ext_device_fission cl_amd_device_attribute_query cl_amd_printf
  Device Type: CL_DEVICE_TYPE_GPU
  Device ID: 4098
  Max compute units: 10
  Max work items dimensions: 3
    Max work items[0]: 256
    Max work items[1]: 256
    Max work items[2]: 256
  Max work group size: 256
  Preferred vector width char: 16
  Preferred vector width short: 8
  Preferred vector width int: 4
  Preferred vector width long: 2
  Preferred vector width float: 4
  Preferred vector width double: 0
  Max clock frequency: 0Mhz
  Address bits: 32
  Max memory allocation: 268435456
  Image support: No
  Max size of kernel argument: 1024
  Alignment (bits) of base address: 32768
  Minimum alignment (bytes) for any datatype: 128
  Single precision floating point capability
    Denorms: No
    Quiet NaNs: Yes
    Round to nearest even: Yes
    Round to zero: No
    Round to +ve and infinity: No
    IEEE754-2008 fused multiply-add: No
  Cache type: None
  Cache line size: 0
  Cache size: 0
  Global memory size: 268435456
  Constant buffer size: 65536
  Max number of constant args: 8
  Local memory type: Global
  Local memory size: 16384
  Profiling timer resolution: 1
  Device endianess: Little
  Available: Yes
  Compiler available: Yes
  Execution capabilities:
    Execute OpenCL kernels: Yes
    Execute native function: No
  Queue properties:
    Out-of-Order: No
    Profiling : Yes
  Platform ID: 0x7f2e540c7228
  Name: ATI RV770
  Vendor: Advanced Micro Devices, Inc.
  Driver version: CAL 1.4.900
  Profile: FULL_PROFILE
  Version: OpenCL 1.0 ATI-Stream-v2.1 (145)
  Extensions: cl_khr_icd cl_amd_fp64 cl_khr_gl_sharing cl_amd_device_attribute_query


Passed!

$ aticonfig --list-adapters
Code:
* 0. 01:00.0 ATI Radeon HD 4800 Series    

* - Default adapter

$ aticonfig --od-enable
Code:
ATI Overdrive(TM) enabled

$ aticonfig --odgc
Code:
Default Adapter - ATI Radeon HD 4800 Series    
                            Core (MHz)    Memory (MHz)
           Current Clocks :    625           993
             Current Peak :    625           993
  Configurable Peak Range : [625-700]     [993-1200]
                 GPU load :    99%

$ aticonfig --odsc 700,993
Code:
ERROR - Set clocks failed for Default Adapter - ATI Radeon HD 4800 Series    
        Please check that input values were valid

Code:
$ aticonfig --odsc=700,993
ERROR - Set clocks failed for Default Adapter - ATI Radeon HD 4800 Series    
        Please check that input values were valid

I have also tried $ aticonfig --odsc 700,993 --adapter=0 and various other clocking settings 700,1000 or 700, 1100 or 625,993

The thing is that 700,993 worked fine for a couple months :/  and my limited knowledge of this setup doesn't make clear to me where the problem is.

I'm offering 10 BTC to the good fellow who can get me back to overclocking my little miner Smiley

Thanks,

CoinMan

My Bitcoin Identity
Bitcoin: 183DFFQXR4xCyseBXzmh3XWc22izDWE5Dw
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
yrral
Member
**
Offline Offline

Activity: 79


View Profile
April 22, 2011, 09:18:08 PM
 #2

Try
aticonfig --od-setclock=700,993
CoinMan
Member
**
Offline Offline

Activity: 104



View Profile
April 22, 2011, 09:46:42 PM
 #3

Try
aticonfig --od-setclock=700,993

Code:
$ aticonfig --od-setclock=700,993
ERROR - Set clocks failed for Default Adapter - ATI Radeon HD 4800 Series    
        Please check that input values were valid
]

thanks for trying.

My Bitcoin Identity
Bitcoin: 183DFFQXR4xCyseBXzmh3XWc22izDWE5Dw
CoinMan
Member
**
Offline Offline

Activity: 104



View Profile
April 22, 2011, 09:48:59 PM
 #4

aticonfig --adapter=0 --odsc=700,993

will set you free


Code:
$ aticonfig --adapter=0 --odsc=700,993
ERROR - Set clocks failed for Adapter 0 - ATI Radeon HD 4800 Series    
        Please check that input values were valid
]

Thanks for trying.  I had never thought to try with the equals sign but it doesn't seem to have made a difference.  

My Bitcoin Identity
Bitcoin: 183DFFQXR4xCyseBXzmh3XWc22izDWE5Dw
gigabytecoin
Sr. Member
****
Offline Offline

Activity: 280


View Profile
April 22, 2011, 10:34:08 PM
 #5

Did you lose 10khash/sec or 10Mhash/sec?!

10khash/sec would hardly be noticeable.
CoinMan
Member
**
Offline Offline

Activity: 104



View Profile
April 23, 2011, 12:22:00 AM
 #6

Did you lose 10khash/sec or 10Mhash/sec?!

10khash/sec would hardly be noticeable.

Yes, sorry it is 10Mh/s ..you are right I wouldn't probably have noticed or cared otherwise Wink

My Bitcoin Identity
Bitcoin: 183DFFQXR4xCyseBXzmh3XWc22izDWE5Dw
CoinMan
Member
**
Offline Offline

Activity: 104



View Profile
April 23, 2011, 12:58:03 AM
 #7

maybe

mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak ; aticonfig --initial ; aticonfig --odsc=699,994

?

Thanks again for the help.  I tried this but same result.  I rebooted after the aticonfig --initial but it still didn't help. (nor did my original values of 700,993 or many other combo's that *should* be valid.  Really annoying issue!

I may just re-install this box fresh, do all the updates in Ubuntu and THEN reapply all the drivers and miners and see if that "fixes" it....sucks to resort to this though.  First....I'll go bbq a steak and hope someone comes up with a great idea! Smiley lol.

My Bitcoin Identity
Bitcoin: 183DFFQXR4xCyseBXzmh3XWc22izDWE5Dw
CoinMan
Member
**
Offline Offline

Activity: 104



View Profile
April 23, 2011, 06:54:01 AM
 #8

Well, I never figured out what exactly was wrong but I simply reinstalled everything from scratch starting with the O.S. and I made sure to get all the updates BEFORE I then started installing ATI drivers and SDK, etc. and I am now able to overclock once again Smiley

I do thank you guys who tried to help me out with this!

CoinMan

My Bitcoin Identity
Bitcoin: 183DFFQXR4xCyseBXzmh3XWc22izDWE5Dw
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!