Bitcoin Forum
December 10, 2016, 05:06:15 AM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: How to mine Litecoins behind a proxy on Windows?  (Read 6596 times)
Ali
Member
**
Offline Offline

Activity: 84


View Profile
February 13, 2012, 10:15:00 AM
 #1

I'm using cpuminer right now to mine Litecoins. I'm behind a proxy and "minerd --help" doesn't bring up any options to specify a proxy.
What am I supposed to do?
1481346375
Hero Member
*
Offline Offline

Posts: 1481346375

View Profile Personal Message (Offline)

Ignore
1481346375
Reply with quote  #2

1481346375
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481346375
Hero Member
*
Offline Offline

Posts: 1481346375

View Profile Personal Message (Offline)

Ignore
1481346375
Reply with quote  #2

1481346375
Report to moderator
1481346375
Hero Member
*
Offline Offline

Posts: 1481346375

View Profile Personal Message (Offline)

Ignore
1481346375
Reply with quote  #2

1481346375
Report to moderator
pooler
Hero Member
*****
Offline Offline

Activity: 644


View Profile
February 13, 2012, 01:39:25 PM
 #2

I'm using cpuminer right now to mine Litecoins. I'm behind a proxy and "minerd --help" doesn't bring up any options to specify a proxy.
What am I supposed to do?

According to the libcurl documentation, setting the environment variable http_proxy should do the trick.
This seems to work well under Linux:
Code:
export http_proxy=http://proxyaddress:port/
./minerd [usual options]
I don't have a Windows box to try it on, but I'm going to guess that
Code:
set http_proxy=http://proxyaddress:port/
minerd [usual options]
will work.

It may also be useful to know that some pools (Pool-X for instance) allow mining on port 80.

BTC: 15MRTcUweNVJbhTyH5rq9aeSdyigFrskqE · LTC: LTCPooLqTK1SANSNeTR63GbGwabTKEkuS7
Ali
Member
**
Offline Offline

Activity: 84


View Profile
February 13, 2012, 02:04:11 PM
 #3

Thank you. Setting the environment variable HTTP_PROXY helped. It is working now.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!