Bitcoin Forum
December 15, 2018, 01:22:02 AM *
News: Latest Bitcoin Core release: 0.17.0 [Torrent].
 
   Home   Help Search Login Register More  
Pages: [1]
  Print  
Author Topic: Problems with editing CGMiner for Antminer S1  (Read 2954 times)
basil3legs
Newbie
*
Offline Offline

Activity: 13
Merit: 0


View Profile
July 10, 2014, 11:44:52 PM
 #1

I have taken a copy of the latest CGMiner source and can cross-compile that fine to work on my Antminer S1, although the resulting file is larger than the corresponding, downloadable already build version but that's not an issue.  I also have a copy of the cgminer-openwrt-packages git for the makefile etc.

I would like to make a few minor changes to the software but am having trouble getting the resulting files to run at all.  It is not my coding at fault as even if I make the smallest change possible or just swap 2 independent consecutive lines around I get the same problem.

Basically the code still builds fine but when loaded into the S1, it won't run.  On restarting (or Submit Changes) CGMiner will not appear in the processes tab at all so no mining takes place.  I have tried making minor changes (that do absolutely nothing) to both the cgminer.C file and to one of the other .C files but get the same result.

I commit the changes to the git, make a new branch and give it a new number, alter the makefile accordingly with the new number and new MD5 and cross-compile which appears to go through without a hitch.  What am I missing?

If I undo the changes and rebuild the code, it all works fine again, even with a new number, so the cross compiling also appears to be correct.  Is there another checksum buried in there somewhere maybe?

Any ideas?
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!