Bitcoin Forum
December 04, 2016, 10:42:45 PM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1] 2 »  All
  Print  
Author Topic: 5830 @ [edit] 320 Mhash/s  (Read 7129 times)
twitcoins
Jr. Member
*
Offline Offline

Activity: 39


View Profile
April 30, 2011, 01:24:38 PM
 #1

I wanted to dabble with btc a bit, so around a week ago I slipped a 5830 into a spare box that was lying about, started reading up, tweaking it when I had time, etc.

I'm happy to say that thanks to years of practice at overclocking-while-poor I am now able to achieve a sustained rate of 312 MHash/s (peak 312.71) courtesy of everyone on the forums who posts such useful info Smiley

My setup:

 Ubuntu 10.04.2 LTS x86_64
 fglrx 8.801
 stream 2.1
 phoenix 1.3
 gpu @ 1000
 mem @ 195
 v @ 1.163
 fan @ 100
 temp @ 74.5

I know this isn't the most efficient rig energy-wise, but I wanted to see how much bang-for-the-buck I could get off an entry-level card.

If there's reason to suspect a newer fglrx or stream package would bump it even higher, I'm probably game to push a little harder.

Oh, and if anyone wants the details on how I arrived at this number, I could probably go through my browser and command history and piece it together.

Cheers, and thanks again everybody!
1480891365
Hero Member
*
Offline Offline

Posts: 1480891365

View Profile Personal Message (Offline)

Ignore
1480891365
Reply with quote  #2

1480891365
Report to moderator
1480891365
Hero Member
*
Offline Offline

Posts: 1480891365

View Profile Personal Message (Offline)

Ignore
1480891365
Reply with quote  #2

1480891365
Report to moderator
1480891365
Hero Member
*
Offline Offline

Posts: 1480891365

View Profile Personal Message (Offline)

Ignore
1480891365
Reply with quote  #2

1480891365
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1480891365
Hero Member
*
Offline Offline

Posts: 1480891365

View Profile Personal Message (Offline)

Ignore
1480891365
Reply with quote  #2

1480891365
Report to moderator
1480891365
Hero Member
*
Offline Offline

Posts: 1480891365

View Profile Personal Message (Offline)

Ignore
1480891365
Reply with quote  #2

1480891365
Report to moderator
1480891365
Hero Member
*
Offline Offline

Posts: 1480891365

View Profile Personal Message (Offline)

Ignore
1480891365
Reply with quote  #2

1480891365
Report to moderator
Anonymous
Guest

April 30, 2011, 01:42:53 PM
 #2

You could write up a howto and post it on http://witcoin.com and earn even more bitcoins Smiley
slurch
Member
**
Offline Offline

Activity: 70



View Profile WWW
April 30, 2011, 09:05:23 PM
 #3

That's REALLY nice. I'm pulling about 295 off of my XFX 5830 Windows 7 box, but this is my primary computer as well as my mining rig (because I am just THAT poor). I can't get the core clock much above 970 without losing system stability, and the whole computer crashes with the memory clock set to anything lower than 380. Can't seem to adjust the voltages on this card at all, either, even with an unlocked OC tool.

Seems like the 5830 is a decent card for an entry level hobbyist such as myself. I picked mine up for $109, and it was cheap enough that I got it in under the wife's radar. Tongue She's Bitcoin-friendly, anyway, but still...this little hobby can get expensive!

Donations accepted at: 1AXKzVc1tTmfC6VkWwBNSzKqThqhwsC5mY
For what, I have no idea...
Digigami
Sr. Member
****
Offline Offline

Activity: 460


View Profile
May 02, 2011, 02:08:20 AM
 #4

Wow those are some nice numbers for both of you! I have two Asus EAH5830's, seems the most I can pull is about 250Mhash/sec, and that's at 1000Mhz core, can't get any more out of it Sad Win 7 box..

Any suggestions? It is just a dual core @ 3.2 and it's seeing 100% CPU utilization, even though I'm only mining on the GPU's, could that be my issue?
slurch
Member
**
Offline Offline

Activity: 70



View Profile WWW
May 02, 2011, 07:18:07 AM
 #5

I've heard a lot about this issue...I'd be curious to see definitively what causes it.

Short of getting you to roll your Catalyst version back to something earlier and making sure you are running with SDK 2.1, I'm not sure what to tell you. What's your memory clock at?

...you don't have Generate Coins checked in the Bitcoin client, do you...?

Donations accepted at: 1AXKzVc1tTmfC6VkWwBNSzKqThqhwsC5mY
For what, I have no idea...
Digigami
Sr. Member
****
Offline Offline

Activity: 460


View Profile
May 02, 2011, 06:26:19 PM
 #6

Running catalyst suite version 11.4, no SDK kit as apparently this suite includes the directCU drivers, although that could be part of the issue I suppose..

I have the memory at stock 1000Mhz right now, I had tried dropping it down to around 400Mhz previously but it did not have any impact..

Double checked, Generate Coins is not checked off either. Just ran home from work to check on things during lunchtime here, when I'm back home tonight I might try a few different driver versions or the SDK kit and see what I can come up with. Both cards just cruising at 250mh/sec for now
slurch
Member
**
Offline Offline

Activity: 70



View Profile WWW
May 02, 2011, 07:52:40 PM
 #7

Huh...yeah...that's pretty strange. Give the Catalyst rollback a shot...I went with 10.7, and if you have a 5830 in a Windows box, that's what I'd recommend for you, too.

Donations accepted at: 1AXKzVc1tTmfC6VkWwBNSzKqThqhwsC5mY
For what, I have no idea...
twitcoins
Jr. Member
*
Offline Offline

Activity: 39


View Profile
May 03, 2011, 06:07:04 AM
 #8

Honestly the returns for going above say 975 aren't worth much.  I have it locked at 1000/90 basically just for fun (dedicated rig, test lab environment), and because I can Smiley  I want to try pushing the GPU further when I have some more time, but no hardmods.

WRT to the memory settings though, I saw definite gains when I moved downward from stock.
slurch
Member
**
Offline Offline

Activity: 70



View Profile WWW
May 03, 2011, 06:15:13 AM
 #9

I would definitely run it that fast if I could. 965 is the fastest stable speed for my system given the current configuration and the fact that I actually use my computer for stuff while it's mining. Reducing the memory clock to below 400 definitely helped too...though too low and I was freezing up.

Donations accepted at: 1AXKzVc1tTmfC6VkWwBNSzKqThqhwsC5mY
For what, I have no idea...
drcoin
Newbie
*
Offline Offline

Activity: 12


View Profile
May 03, 2011, 01:46:03 PM
 #10

I also have an xfx 5830 and after seeing this thread switched from puddinpop's miner to phoenix 1.4 (see details below). At a core clock of 970MHz I saw an increase from ~220 MHash/s to ~285 MHash/s.

OS Windows 7 64bit
Catalyst driver: 11.4
Stream version 2.4 (presumably - it's whatever comes with the 11.4 drivers. Anything less won't work for me, at all)
Core clock 970Mhz (somewhere between here and 1000Mhz things get unstable)
Mem clock 560Mhz (can't set it any lower in MSI Afterburner)
voltage is default (unable to change?)

Miner Phoenix 1.4 -k poclbm device=0 platform=1 WORKSIZE=128 AGGRESSION=12 BFI_INT VECTORS

Any suggestions for getting it higher? I seem to be stuck with stream SDK 2.4 and can't raise the core clock much more. For reference, I'm also running a nvidia 260 in the same computer.

1PnecfWugmwNW8affHCE2K22APrTZtcFw4
slurch
Member
**
Offline Offline

Activity: 70



View Profile WWW
May 03, 2011, 07:56:46 PM
 #11

I also have an xfx 5830 and after seeing this thread switched from puddinpop's miner to phoenix 1.4 (see details below). At a core clock of 970MHz I saw an increase from ~220 MHash/s to ~285 MHash/s.

OS Windows 7 64bit
Catalyst driver: 11.4
Stream version 2.4 (presumably - it's whatever comes with the 11.4 drivers. Anything less won't work for me, at all)
Core clock 970Mhz (somewhere between here and 1000Mhz things get unstable)
Mem clock 560Mhz (can't set it any lower in MSI Afterburner)
voltage is default (unable to change?)

Miner Phoenix 1.4 -k poclbm device=0 platform=1 WORKSIZE=128 AGGRESSION=12 BFI_INT VECTORS

Any suggestions for getting it higher? I seem to be stuck with stream SDK 2.4 and can't raise the core clock much more. For reference, I'm also running a nvidia 260 in the same computer.

This is strange. What happens when you try and downgrade the drivers?

Donations accepted at: 1AXKzVc1tTmfC6VkWwBNSzKqThqhwsC5mY
For what, I have no idea...
drcoin
Newbie
*
Offline Offline

Activity: 12


View Profile
May 04, 2011, 11:35:02 AM
 #12

I also have an xfx 5830 and after seeing this thread switched from puddinpop's miner to phoenix 1.4 (see details below). At a core clock of 970MHz I saw an increase from ~220 MHash/s to ~285 MHash/s.

OS Windows 7 64bit
Catalyst driver: 11.4
Stream version 2.4 (presumably - it's whatever comes with the 11.4 drivers. Anything less won't work for me, at all)
Core clock 970Mhz (somewhere between here and 1000Mhz things get unstable)
Mem clock 560Mhz (can't set it any lower in MSI Afterburner)
voltage is default (unable to change?)

Miner Phoenix 1.4 -k poclbm device=0 platform=1 WORKSIZE=128 AGGRESSION=12 BFI_INT VECTORS

Any suggestions for getting it higher? I seem to be stuck with stream SDK 2.4 and can't raise the core clock much more. For reference, I'm also running a nvidia 260 in the same computer.

This is strange. What happens when you try and downgrade the drivers?


I've tried both 10.3 with stream SDK 2.1 and 2.2 and 10.4 with SDK 2.1 and 2.2. Regardless of combination I get the same problem - whenever I try and run any OpenCL code it just crashes (the command window glazes over and the not responding box pops up). This happens when trying to run rpcminer-opencl.exe on any device (I don't think it even gets as far as finding any usable platforms) and also when I try and run any of the sample code that comes with the SDKs.

Switching back to the 11.4 package fixes the problem and miners and the code examples run fine. Do you reckon it's worth the effort to try and fix this problem and use 2.1 or 2.2? How much faster are they?

Cheers

1PnecfWugmwNW8affHCE2K22APrTZtcFw4
slurch
Member
**
Offline Offline

Activity: 70



View Profile WWW
May 04, 2011, 04:07:51 PM
 #13

10.3 and 10.4 seem a little old...I'd personally try 10.7 and see what happens from there. Smiley SDK 2.1 is what I'm using with your same OS with quite a bit of success. I'm getting very similar speeds to you while using my computer.

C:\Phoenix\phoenix.exe -u http://REDACTED@deepbit.net:8332 -k poclbm VECTORS BFI_INT FASTLOOP AGGRESSION=7 DEVICE=1

Edit: Try turning the Worksize off...BFI_INT seems to somehow mitigate the need to process the work in smaller pieces. At least, it feels that way. No change in speed at all after the new miners were installed.

Donations accepted at: 1AXKzVc1tTmfC6VkWwBNSzKqThqhwsC5mY
For what, I have no idea...
twitcoins
Jr. Member
*
Offline Offline

Activity: 39


View Profile
May 05, 2011, 12:47:26 AM
 #14

Forgot to mention, I kept seeing the MHash drop off when the screen would disable even though I configured Ubuntu to ignore all power saving settings; whenever I'd wake the screen up by jiggling the mouse or hitting a keystroke, it would be sub-300 but then on the next workunit jump right back up to 312+.

My solution, since this is a dedicated mining rig, was to set the session to xterm, and use AMDOverdrvCtrl with the -b flag to load a saved .ovdr profile followed by calling out Phoenix.  In this way I was able to eliminate the performance drop, and also since I have the system on UPS and set to auto-reboot / auto-logon, I basically have a bulletproof bitcoin dispenser Smiley
drcoin
Newbie
*
Offline Offline

Activity: 12


View Profile
May 05, 2011, 10:48:58 AM
 #15

10.3 and 10.4 seem a little old...I'd personally try 10.7 and see what happens from there. Smiley SDK 2.1 is what I'm using with your same OS with quite a bit of success. I'm getting very similar speeds to you while using my computer.

C:\Phoenix\phoenix.exe -u http://REDACTED@deepbit.net:8332 -k poclbm VECTORS BFI_INT FASTLOOP AGGRESSION=7 DEVICE=1

Edit: Try turning the Worksize off...BFI_INT seems to somehow mitigate the need to process the work in smaller pieces. At least, it feels that way. No change in speed at all after the new miners were installed.

Thanks for the suggestion, is it possible to install 2.1 with the 11.4 drivers perhaps? I could try that and narrow down whether it's the SDK or the drivers causing the problem.

Just for reference, my current setup gets about 278 MHash/s with aggression=7.

1PnecfWugmwNW8affHCE2K22APrTZtcFw4
drcoin
Newbie
*
Offline Offline

Activity: 12


View Profile
May 05, 2011, 10:55:16 AM
 #16

Forgot to mention, I kept seeing the MHash drop off when the screen would disable even though I configured Ubuntu to ignore all power saving settings; whenever I'd wake the screen up by jiggling the mouse or hitting a keystroke, it would be sub-300 but then on the next workunit jump right back up to 312+.

My solution, since this is a dedicated mining rig, was to set the session to xterm, and use AMDOverdrvCtrl with the -b flag to load a saved .ovdr profile followed by calling out Phoenix.  In this way I was able to eliminate the performance drop, and also since I have the system on UPS and set to auto-reboot / auto-logon, I basically have a bulletproof bitcoin dispenser Smiley

Are you sure the hash rate was actually dropping while the screen was off? I've noticed in Windows 7 that waking the screen by moving the mouse causes a brief ~10-20% dip in GPU utilization (seems to be true for both ATI and nvidia cards). I have no idea about Linux really, but could it be possible it's just a blip as the screen comes back on? Another workaround would just be to set the screen to always on and turn it off yourself - something I have to do because one of my Dell screens audibly beeps while in standby mode (?!)

1PnecfWugmwNW8affHCE2K22APrTZtcFw4
slurch
Member
**
Offline Offline

Activity: 70



View Profile WWW
May 05, 2011, 07:46:01 PM
 #17

10.3 and 10.4 seem a little old...I'd personally try 10.7 and see what happens from there. Smiley SDK 2.1 is what I'm using with your same OS with quite a bit of success. I'm getting very similar speeds to you while using my computer.

C:\Phoenix\phoenix.exe -u http://REDACTED@deepbit.net:8332 -k poclbm VECTORS BFI_INT FASTLOOP AGGRESSION=7 DEVICE=1

Edit: Try turning the Worksize off...BFI_INT seems to somehow mitigate the need to process the work in smaller pieces. At least, it feels that way. No change in speed at all after the new miners were installed.

Thanks for the suggestion, is it possible to install 2.1 with the 11.4 drivers perhaps? I could try that and narrow down whether it's the SDK or the drivers causing the problem.

Just for reference, my current setup gets about 278 MHash/s with aggression=7.

I haven't tried it, but it probably won't hurt. Tongue

Donations accepted at: 1AXKzVc1tTmfC6VkWwBNSzKqThqhwsC5mY
For what, I have no idea...
twitcoins
Jr. Member
*
Offline Offline

Activity: 39


View Profile
May 05, 2011, 08:05:26 PM
 #18

RE: OpenCL versions, I see a definite decline when I move to 2.2 SDK or later.  It's possible I could re-optimize for a different version, but even though this is an enjoyable hobby I don't have THAT much free time Smiley

RE: MHash/s vs. screen, yes this was a measured difference of about 10 MHash/s apparently caused by GDM's method for 'sleeping' the display.  Switching to an xterm session caused it to go away.
twitcoins
Jr. Member
*
Offline Offline

Activity: 39


View Profile
June 03, 2011, 07:16:53 PM
 #19

Personal best on this 5830 is stable at
320 Mhash/s
still 2.1 SDK
phoenix+poclbm
1025/320
90%

Still need to play with phatk, overvolt, flexible proxy miner, etc.  Fun little toy project Smiley  Card will in theory try to go up to 1200 GPU core, so I'd imagine I might in theory be able to get up to what... 350?  I don't think I can do that with stock cooler and volts though.
nyargh
Newbie
*
Offline Offline

Activity: 25


View Profile
June 03, 2011, 07:20:05 PM
 #20

Personal best on this 5830 is stable at
320 Mhash/s
still 2.1 SDK
phoenix+poclbm
1025/320
90%

Still need to play with phatk, overvolt, flexible proxy miner, etc.  Fun little toy project Smiley  Card will in theory try to go up to 1200 GPU core, so I'd imagine I might in theory be able to get up to what... 350?  I don't think I can do that with stock cooler and volts though.

How are you OCing the core above 875 in linux?  aticonfig is limited for me.
Pages: [1] 2 »  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!