Bitcoin Forum
September 23, 2017, 04:48:01 PM *
News: Latest stable version of Bitcoin Core: 0.15.0.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Bitcoind JSON-rpc and tor on php  (Read 1693 times)
bombartier357
Full Member
***
Offline Offline

Activity: 148


View Profile WWW
March 14, 2012, 02:27:50 AM
 #1

Does anyone have an idea how to get JSON-rpc running with tor?

I have jsonRPCClient.php in my public_html.  I have also configured the bitcoin.conf to the best of my knowledge on localhost.  Am I missing something?  When I try and run the code below it gives me blank screen.  I am fairly new to php and bitcoind in general so any help would be appreciated.  If coin will get me through this I can provide it.


 <?php
  require_once 'jsonRPCClient.php';
  // Replace with the username and password you set in bitcoin.conf earlier
  $bitcoin = new jsonRPCClient('http://username:password@127.0.0.1:8332/');
  print_r($bitcoin->getinfo());
?>
1506185281
Hero Member
*
Offline Offline

Posts: 1506185281

View Profile Personal Message (Offline)

Ignore
1506185281
Reply with quote  #2

1506185281
Report to moderator
1506185281
Hero Member
*
Offline Offline

Posts: 1506185281

View Profile Personal Message (Offline)

Ignore
1506185281
Reply with quote  #2

1506185281
Report to moderator
          ▄█████▄
        ▄█████████▄
      ▄████▀   ▀████▄
    ▄████▀   ▄ ▄█▀████▄
  ▄████▀   ▄███▀   ▀████▄
▄████▀   ▄███▀   ▄   ▀████▄
█████   ███▀   ▄███   █████
▀████▄   ▀██▄▄███▀   ▄████▀
  ▀████▄   ▀███▀   ▄████▀
    ▀████▄       ▄████▀
      ▀████▄   ▄████▀
        ▀███  ████▀
          ▀█▄███▀
.
|
.
|
          ▄█████▄
        ▄█████████▄
      ▄████▀   ▀████▄
    ▄████▀   ▄ ▄█▀████▄
  ▄████▀   ▄███▀   ▀████▄
▄████▀   ▄███▀   ▄   ▀████▄
█████   ███▀   ▄███   █████
▀████▄   ▀██▄▄███▀   ▄████▀
  ▀████▄   ▀███▀   ▄████▀
    ▀████▄       ▄████▀
      ▀████▄   ▄████▀
        ▀███  ████▀
          ▀█▄███▀
unthy
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
sergio
Sr. Member
****
Offline Offline

Activity: 307


View Profile WWW
March 15, 2012, 04:48:36 AM
 #2

since you are using http, you will problably have to disable https, to do that stop bitcoind, and add the line in bitcoin.conf  rpcssl=0 or comment out rpcssl=1, then restart the bitcoin daemon, and try again.
Let me know if this helped.
NothinG
Hero Member
*****
Offline Offline

Activity: 560



View Profile
March 15, 2012, 04:55:56 AM
 #3

Code:
// Replace with the username and password you set in bitcoin.conf earlier

Have you setup your bitcoin.conf already?

bombartier357
Full Member
***
Offline Offline

Activity: 148


View Profile WWW
April 26, 2012, 03:31:36 AM
 #4

I have my config setup properly.  Here it is if anyone wants to check it.

It has been ages since I have attempted this.  Time to get back on the wagon...





# bitcoin.conf configuration file. Lines beginning with # are comments.


# Network-related settings:

# Run on the test network instead of the real bitcoin network.
#testnet=1

# Connect via a socks4 proxy
#proxy=127.0.0.1:9050

# Use as many addnode= settings as you like to connect to specific peers
#addnode=69.164.218.197
#addnode=10.0.0.2:8333

# ... or use as many connect= settings as you like to connect ONLY
# to specific peers:
#connect=69.164.218.197
#connect=10.0.0.1:8333

# Do not use Internet Relay Chat (irc.lfnet.org #bitcoin channel) to
# find other peers.
#noirc=1

# Maximum number of inbound+outbound connections.
#maxconnections=


# JSON-RPC options (for controlling a running Bitcoin/bitcoind process)

# server=1 tells Bitcoin to accept JSON-RPC commands.
server=1

# You must set rpcuser and rpcpassword to secure the JSON-RPC api
rpcuser=username
rpcpassword=password

# By default, only RPC connections from localhost are allowed.  Specify
# as many rpcallowip= settings as you like to allow connections from
# other hosts (and you may use * as a wildcard character):
#rpcallowip=
#rpcallowip=

# Listen for RPC connections on this TCP port:
rpcport=9050

# You can use Bitcoin or bitcoind to send commands to Bitcoin/bitcoind
# running on another host using this option:
rpcconnect=127.0.0.1

# Use Secure Sockets Layer (also known as TLS or HTTPS) to communicate
# with Bitcoin -server or bitcoind
#rpcssl=1

# OpenSSL settings used when rpcssl=1
#rpcsslciphers=TLSv1+HIGH:!SSLv2:!aNULL:!eNULL:!AH:!3DES:@STRENGTH
#rpcsslcertificatechainfile=server.cert
#rpcsslprivatekeyfile=server.pem


# Miscellaneous options

# Set gen=1 to attempt to generate bitcoins
gen=0

# Use SSE instructions to try to generate bitcoins faster.
#4way=1

# Pre-generate this many public/private key pairs, so wallet backups will be valid for
# both prior transactions and several dozen future transactions.
keypool=100

# Pay an optional transaction fee every time you send bitcoins.  Transactions with fees
# are more likely than free transactions to be included in generated blocks, so may
# be validated sooner.
paytxfee=0.00

# Allow direct connections for the 'pay via IP address' feature.
#allowreceivebyip=1


# User interface options

# Start Bitcoin minimized
#min=1

# Minimize to the system tray
#minimizetotray=1
NothinG
Hero Member
*****
Offline Offline

Activity: 560



View Profile
April 28, 2012, 04:36:15 AM
 #5

Code:
# Listen for RPC connections on this TCP port:
rpcport=9050

bombartier357
Full Member
***
Offline Offline

Activity: 148


View Profile WWW
May 02, 2012, 02:38:10 PM
 #6

Code:
# Listen for RPC connections on this TCP port:
rpcport=9050

Should I change my rcp port to 8333?  I tied changing the port in the php code and got nothing.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!