Bitcoin Forum
December 07, 2016, 12:50:07 PM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: CGMiner - help accessing options and overclocking  (Read 8876 times)
ModusPwnd
Member
**
Offline Offline

Activity: 100



View Profile
March 14, 2012, 10:13:06 PM
 #1

Hello,

I have read the post here, https://bitcointalk.org/index.php?topic=28402.0  and many others.   I have followed this guide here, https://bitcointalk.org/index.php?topic=18313.msg712967#msg712967 and have everything working fairly well.  I am running p2pool, bitcoin and cgminer on a Windows 7 machine.

I cannot do this however,
Quote
WHILE RUNNING:

The following options are available while running with a single keypress:

[P]ool management [G]PU management [ S]ettings [D]isplay options [Q]uit

I press the keys, nothing happens.  I make sure that I click on the cgminer.exe window to make it the active window, still nothing.  How can I get these options?


My main concern is optimizing my GPU.  Before, when I would run GUIMiner I would get 340MH/s out of my 5850.  With cgminer, Im only getting 240MH/s.  I see this part in the guide which I think is relevant to me,
Quote
Add overclocking settings, GPU and fan control for all cards:

cgminer -o http://pool:port -u username -p password -I 9 --auto-fan --auto-gpu --gpu-engine 750-950 --gpu-memclock 300

But what does all that mean?  Is there a key or guide to using these settings?  Some like 'memclock' make sense, but others do not.  Also, where do I enter this in?  I pass it in via the shortcut I made right?  And how do I stipulate which settings go to which card? 

With GUIMiner I overclocked with afterburner and entered the flags into guiminer.  Do I enter flags into cgminer?


Thanks for any thoughts or ideas!
1481115007
Hero Member
*
Offline Offline

Posts: 1481115007

View Profile Personal Message (Offline)

Ignore
1481115007
Reply with quote  #2

1481115007
Report to moderator
1481115007
Hero Member
*
Offline Offline

Posts: 1481115007

View Profile Personal Message (Offline)

Ignore
1481115007
Reply with quote  #2

1481115007
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481115007
Hero Member
*
Offline Offline

Posts: 1481115007

View Profile Personal Message (Offline)

Ignore
1481115007
Reply with quote  #2

1481115007
Report to moderator
1481115007
Hero Member
*
Offline Offline

Posts: 1481115007

View Profile Personal Message (Offline)

Ignore
1481115007
Reply with quote  #2

1481115007
Report to moderator
DILLIGAF
Full Member
***
Offline Offline

Activity: 168



View Profile
March 14, 2012, 10:40:54 PM
 #2

Hello,

I have read the post here, https://bitcointalk.org/index.php?topic=28402.0  and many others.   I have followed this guide here, https://bitcointalk.org/index.php?topic=18313.msg712967#msg712967 and have everything working fairly well.  I am running p2pool, bitcoin and cgminer on a Windows 7 machine.

I cannot do this however,
Quote
WHILE RUNNING:

The following options are available while running with a single keypress:

[P]ool management [G]PU management [ S]ettings [D]isplay options [Q]uit

I press the keys, nothing happens.  I make sure that I click on the cgminer.exe window to make it the active window, still nothing.  How can I get these options?


My main concern is optimizing my GPU.  Before, when I would run GUIMiner I would get 340MH/s out of my 5850.  With cgminer, Im only getting 240MH/s.  I see this part in the guide which I think is relevant to me,
Quote
Add overclocking settings, GPU and fan control for all cards:

cgminer -o http://pool:port -u username -p password -I 9 --auto-fan --auto-gpu --gpu-engine 750-950 --gpu-memclock 300

But what does all that mean?  Is there a key or guide to using these settings?  Some like 'memclock' make sense, but others do not.  Also, where do I enter this in?  I pass it in via the shortcut I made right?  And how do I stipulate which settings go to which card?  

With GUIMiner I overclocked with afterburner and entered the flags into guiminer.  Do I enter flags into cgminer?


Thanks for any thoughts or ideas!

You can use a .conf file called cgminer.conf that has your settings contained in it on windows not sure where you put it but would imagine it would be in the same directory as the program itself on linux it goes in the .cgminer directory an example below with two cards four pools enabled along with an edit of your original showing two cards enabled. The settings for multiple cards are taken in the order they appear on the command line/.conf file. First card in your example runs at 750-950 300 second at 700-925 400 intensity of 9 for both in my edit shown here.

Quote
Add overclocking settings, GPU and fan control for all cards:

cgminer -o http://pool:port -u username -p password -I 9,9 --auto-fan --auto-gpu --gpu-engine 750-950,700-925 --gpu-memclock 300,400

Code:
cat ~/.cgminer/cgminer.conf
{
"pools" : [
{
"url" : "http://pool.org:8332",
"user" : "20",
"pass" : "worker"
},
{
"url" : "http://pool.co:8332/",
"user" : "20",
"pass" : "worker"
},
{
"url" : "http://pool.net:8332",
"user" : "20",
"pass" : "worker"
},
{
"url" : "http://pool.com:8332/",
"user" : "20",
"pass" : "worker"
}
],


"intensity" : "8,8",
"gpu-engine" : "0-925,0-925",
"gpu-memclock" : "1050,1200",
"gpu-threads" : "2",
"log" : "5",
"queue" : "1",
"retry-pause" : "5",
"scan-time" : "60",
"donation" : "0",
"shares" : "0",
"kernel-path" : "/usr/local/bin"

You would want to add before the "kernel-path" line.

"auto-fan" : "1",
"auto-gpu" : "1",

To the .conf file to have them enabled when using it.
jake262144
Full Member
***
Offline Offline

Activity: 210


View Profile
March 15, 2012, 09:54:34 AM
 #3

Code:
"donation" : "0",
FYI, the donation keyword has been removed - it doesn't work with any recent version of cgminer.
No reason to keep this line in the config file.
ordy
Jr. Member
*
Offline Offline

Activity: 59


View Profile
March 15, 2012, 03:37:09 PM
 #4

i run this on my 5850's and get a nice steady 362 Mh/s while staying stable, cool, and usable for other functions.  it may not be the best but works very well for me.

cgminer -o http://bla.net:xxxx -u username -p password -I 9 --auto-fan --auto-gpu --gpu-engine 750-900 --gpu-memclock 300 --temp-target 70
ModusPwnd
Member
**
Offline Offline

Activity: 100



View Profile
March 16, 2012, 01:30:43 AM
 #5

Thx all, you have been real helpful.  I have been able to fiddle some setting and get some other results.  My avg. is up to 312 MH/s now, higher than before but not as high as when I used GUIMiner.  I have more fiddling to do for sure.

I created the configuration file and only included this much,

"auto-fan" : "1",
"auto-gpu" : "1",


I think I can include my string like this "cgminer -o http://bla.net:xxxx -u username -p password -I 9 --auto-fan --auto-gpu --gpu-engine 750-900 --gpu-memclock 300 --temp-target 70" in the configuration file rather than in the shortcut? 

During only one of my runnings was I able to hit the single keys [G] for GPU management, etc.  Any idea why that is? 

I get the feeling I should ditch passing in the setting via the shortcut and include them in the config file. 

Thx again!  I will keep fiddling and will post here again with my results.
DILLIGAF
Full Member
***
Offline Offline

Activity: 168



View Profile
March 16, 2012, 06:49:22 AM
 #6

Thx all, you have been real helpful.  I have been able to fiddle some setting and get some other results.  My avg. is up to 312 MH/s now, higher than before but not as high as when I used GUIMiner.  I have more fiddling to do for sure.

I created the configuration file and only included this much,

"auto-fan" : "1",
"auto-gpu" : "1",


I think I can include my string like this "cgminer -o http://bla.net:xxxx -u username -p password -I 9 --auto-fan --auto-gpu --gpu-engine 750-900 --gpu-memclock 300 --temp-target 70" in the configuration file rather than in the shortcut? 

During only one of my runnings was I able to hit the single keys [G] for GPU management, etc.  Any idea why that is? 

I get the feeling I should ditch passing in the setting via the shortcut and include them in the config file. 

Thx again!  I will keep fiddling and will post here again with my results.

If you can get to the option in cgminer under the settings menu then you can save your config that is already loaded by using that option or try the one below which should do what you need once you have placed your settings for the pool in there.




Code:
{
"pools" : [
{
"url" : "http://bla.net:xxxx",
"user" : "username",
"pass" : "password"
}
],


"intensity" : "9",
"gpu-engine" : "750-900",
"gpu-memclock" : "300",
"gpu-threads" : "2",
"log" : "5",
"queue" : "1",
"retry-pause" : "5",
"scan-time" : "60",
"donation" : "0",
"shares" : "0",
"auto-fan" : "1",
"auto-gpu" : "1",
"temp-target" : "70"




David_Benz
Donator
Jr. Member
*
Offline Offline

Activity: 56

you got hacked bitch!


View Profile
May 07, 2012, 06:15:04 AM
 #7

i run this on my 5850's and get a nice steady 362 Mh/s while staying stable, cool, and usable for other functions.  it may not be the best but works very well for me.

cgminer -o http://bla.net:xxxx -u username -p password -I 9 --auto-fan --auto-gpu --gpu-engine 750-900 --gpu-memclock 300 --temp-target 70

I tried this ... currently getting ~394 per GPU with four 5850s running in one machine.

Thanks a bunch!

I am the Bitcoinica Hacker.
emma
Jr. Member
*
Offline Offline

Activity: 47


View Profile
January 27, 2013, 08:06:03 PM
 #8

With -I 9 --auto-fan --auto-gpu --gpu-engine 750-900 --gpu-memclock 300 --temp-target 70 On 2 5850 hmm ?

 GPU 0:  35.0C  47%    | 17.62K/19.34Kh/s | A:0 R:0 HW:0 U:0.00/m I: 9
 GPU 1:  39.0C  46%    | 1.630K/1.960Kh/s | A:0 R:0 HW:0 U:0.00/m I: 9
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!