Bitcoin Forum
December 05, 2016, 08:58:48 PM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Problem with poclbm  (Read 925 times)
Steve
Hero Member
*****
Offline Offline

Activity: 868



View Profile WWW
May 07, 2011, 12:22:13 AM
 #1

Teknohog, could you please try with Stream 2.1. I can't see why 'vectors' would give invalid results.

With SDK 2.1, the miner does not even compile with vectors Sad

Code:
/tmp/OCLQa31hL.cl(128): error: mixed vector-scalar operation not allowed
          unless up-convertable(scalar-type=>vector-element-type)
        sharound(E,F,G,H,A,B,C,D,R(36),0x650A7354);

But it gets stranger. After reinstalling 2.2, I am getting accepted results with vectors, using the latest version of poclbm. So this looks like an error in my system, and poclbm is fine Smiley

(Possible sources of error: overheated GPU, which is now cooler after the SDK changes; pyopencl, which is the only component I have to manually compile and install with every SDK change.)

I'm encountering this same issue (python 2.6.6 on Ubunu 10.10 with SDK 2.1 and the latest pyopencl (as of this writing)...I've tried uninstalling/reinstalling pyopencl...nothing seems to work.  Wondering if anyone else has had this problem and solved it.

Bumping this out of the poclbm thread in hopes someone might know of a quick fix.

(gasteve on IRC) Does your website accept cash? https://bitpay.com
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!