Bitcoin Forum
December 04, 2016, 10:29:46 AM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: HD 7750 on Windows 2008 R2 headless - unexplained hashing slowdown  (Read 1670 times)
Soros Shorts
Donator
Legendary
*
Offline Offline

Activity: 1455



View Profile
April 05, 2012, 03:50:13 PM
 #1

Hi,

I colo a rack of 2U servers as part of a side business. Electricity is "free", because I already pay by the number of 20 Amp circuits to the rack. To support the bitcoin network, I decided to outfit some of my servers with HD 7750 cards because they fit in the unused 16x slots and don't require power cables.

These servers are headless. With the new 12.2 and 12.3 drivers Diablo miner can see the GPUs and I can hash without a monitor or resistor plug. The problem is this:

1) I have a startup script where Windows will auto-login and start up the miner. I only get a 40 Mhs.
2) Similary starting the miner from remote desktop session I get 40 Mhs.
3) When I connect to the exisitng session using VNC (or any other console based remote control program) the hash rate jumps to the expected 120 Mhs.
4) Similarly when I start the miner from a VNC session I get 120 Mhs.

Another observation is that GPU Caps View shows a blank GPU tab when the rate is 40 Mhs (while this is happening it still sees the correct OpenCL information). When GPU Caps viewer sees the GPU, then I get the full 120 Mhs.

Can someone explain what is happening?

Thanks.

1480847386
Hero Member
*
Offline Offline

Posts: 1480847386

View Profile Personal Message (Offline)

Ignore
1480847386
Reply with quote  #2

1480847386
Report to moderator
1480847386
Hero Member
*
Offline Offline

Posts: 1480847386

View Profile Personal Message (Offline)

Ignore
1480847386
Reply with quote  #2

1480847386
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
nedbert9
Sr. Member
****
Offline Offline

Activity: 252

Inactive


View Profile
April 05, 2012, 05:45:59 PM
 #2

Hi,

I colo a rack of 2U servers as part of a side business. Electricity is "free", because I already pay by the number of 20 Amp circuits to the rack. To support the bitcoin network, I decided to outfit some of my servers with HD 7750 cards because they fit in the unused 16x slots and don't require power cables.

These servers are headless. With the new 12.2 and 12.3 drivers Diablo miner can see the GPUs and I can hash without a monitor or resistor plug. The problem is this:

1) I have a startup script where Windows will auto-login and start up the miner. I only get a 40 Mhs.
2) Similary starting the miner from remote desktop session I get 40 Mhs.
3) When I connect to the exisitng session using VNC (or any other console based remote control program) the hash rate jumps to the expected 120 Mhs.
4) Similarly when I start the miner from a VNC session I get 120 Mhs.

Another observation is that GPU Caps View shows a blank GPU tab when the rate is 40 Mhs (while this is happening it still sees the correct OpenCL information). When GPU Caps viewer sees the GPU, then I get the full 120 Mhs.

Can someone explain what is happening?

Thanks.




At first I was going to suggest to RDP using /admin to get console / session 0.  But in case 1 that you've outlined it appears that you are auto-logging in the console session.

Shrugs.  Strange stuff.  Have you attempted to launch the process in compatibility mode such as Win XP?

EDIT:  There are also reported issues with the WDDM driver model in 2008, specifically affecting Hyper-V VM's, and WDDM based graphics drivers.  Doubtful this would have anything to do with what you are experiencing.
Soros Shorts
Donator
Legendary
*
Offline Offline

Activity: 1455



View Profile
April 05, 2012, 07:15:37 PM
 #3

At first I was going to suggest to RDP using /admin to get console / session 0.  But in case 1 that you've outlined it appears that you are auto-logging in the console session.

Shrugs.  Strange stuff.  Have you attempted to launch the process in compatibility mode such as Win XP?

EDIT:  There are also reported issues with the WDDM driver model in 2008, specifically affecting Hyper-V VM's, and WDDM based graphics drivers.  Doubtful this would have anything to do with what you are experiencing.
Thanks for the response. Unfortunately there is no more RDP session 0 ever since Server 2008. Microsoft removed it for security reasons.

I also don't believe XP compatibility mode is possible on the Server 2008 R2 product (without a lot of hacking making it look more like Windows 7 which I don't want to do).

It is almost as though when the windows session does not see the GPU the card goes into some kind of low-power mode.
bangra
Jr. Member
*
Offline Offline

Activity: 43



View Profile
April 05, 2012, 09:07:21 PM
 #4

I "think" this is due to RDP using a software GPU as such to run the session, when you connect to the server using VNC/Teamviewer/Logmein it connects to the actual main session of the screen and uses a real GPU, once started in vnc it should stay running fine if you then login to RDP, the other option is to set it as a scheduled task maybe

Have i helped? 1Gm9NMJ2qn2XU1qc4Mps9GSCGe5cdetmpv
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!