Bitcoin Forum
October 21, 2017, 12:42:31 PM *
News: Latest stable version of Bitcoin Core: 0.15.0.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Alt coin client returning error: {"code":-32601,"message":"Method not found"}  (Read 2681 times)
cryptodruti
Full Member
***
Offline Offline

Activity: 182


View Profile
September 01, 2014, 12:16:51 AM
 #1

I've spent the weekend cloning alt coins for shits n' gigs, and was able to successfully clone a scrypt coin, and a few other simple coins. I decided to step it up today and tried cloning a PoW/PoS x13 coin, basically the same process and was able to get past mining the genesis block and connecting two nodes. However the client only accepts certain commands such as "getinfo", "getnewaddress" and a few others, but returns the error: {"code":-32601,"message":"Method not found"} for the command "setgenerate true" and a few other commands. Anyone have any idea whats causing this? I would really appreciate some help  Smiley
1508589751
Hero Member
*
Offline Offline

Posts: 1508589751

View Profile Personal Message (Offline)

Ignore
1508589751
Reply with quote  #2

1508589751
Report to moderator
1508589751
Hero Member
*
Offline Offline

Posts: 1508589751

View Profile Personal Message (Offline)

Ignore
1508589751
Reply with quote  #2

1508589751
Report to moderator
1508589751
Hero Member
*
Offline Offline

Posts: 1508589751

View Profile Personal Message (Offline)

Ignore
1508589751
Reply with quote  #2

1508589751
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1508589751
Hero Member
*
Offline Offline

Posts: 1508589751

View Profile Personal Message (Offline)

Ignore
1508589751
Reply with quote  #2

1508589751
Report to moderator
Remember remember the 5th of November
Legendary
*
Offline Offline

Activity: 1554

Reverse engineer from time to time


View Profile
September 01, 2014, 01:31:59 AM
 #2

setgenerate should be a deprecated API.

BTC:1AiCRMxgf1ptVQwx6hDuKMu4f7F27QmJC2
cryptodruti
Full Member
***
Offline Offline

Activity: 182


View Profile
September 01, 2014, 08:32:16 PM
 #3

setgenerate should be a deprecated API.
Not sure what you mean, but setgenerate and all the other API's are in bitrpc.py, so i'm not sure why it returns the error
rikkejohn
Hero Member
*****
Offline Offline

Activity: 644


View Profile
September 01, 2014, 09:16:18 PM
 #4

it's a pain, but the commands are spread about, and interlinked with other files.

1PkwpyTLo5TfagzCPgjdvQFNVzuEyHViGt
cryptodruti
Full Member
***
Offline Offline

Activity: 182


View Profile
September 02, 2014, 12:54:33 AM
 #5

it's a pain, but the commands are spread about, and interlinked with other files.
it looks like the dev of Aerocoin really tried to deter people from cloning his coin... Which is only fuelling my desire to successfully clone it LOL. I'm even having trouble connecting two nodes, which i think has to do with the Aero code, as i was able to do it with litecoin. If you have time, can you take a look at the aero code, and see if anything stands out as unusual?  Tongue

edit: I was using linux for both machines, tried using a mac in place of one of them.. couldn't even compile on .osx it spit out this error
make: *** No rule to make target `obj/fugue.o', needed by `XenoxCoind'.  Stop.  

edit:got two nodes running on the network now, still can't compile on mac tho..
PereguineBerty
Member
**
Offline Offline

Activity: 110


View Profile
September 06, 2014, 02:55:16 PM
 #6

Some of the features on X11 clones and subsequent version of 'X' don't have all the API calls of Scrypt or SHA-256 coins. The cloning guides are pretty old now and don't cover these eventualities.

Built-in CPU mining is one of these features so when trying to mine the genesis block with setgeneratetrue command, it won't work. If you haven't got a mining rig, you will have to download and compile a version of CPUminer for your system/VPS before you can start the blockchain running, which I see you've already done though.

You need to check if your yourcoin/makefile.osx has all the correct paths to the hash algorithms. If you compare the Linux makefile that works to the Mac one you may notice some of the hash paths are missing i.e. obj/fugue, obj/shavite etc.

arloseb
Hero Member
*****
Offline Offline

Activity: 868


View Profile
November 22, 2014, 10:45:01 AM
 #7

Hi,
I really apprecite if you could helpme. I'm getting stuck on mining first genesisblock in testnet. I'm trying to fork a x11 coin with some tutorials found here and there. Already made genesisblock and relative stuff.
And also started 2 linux machine,each with in testnet mode.

This is what i have done:
-run -testnet -connect xx.xx.xx.xx on first machine
-run -testnet -connect xx.xx.xx.xx on second machine
On .conf i only write user and password.


-Create wallet getnewaddress

Then:
-testnet getinfo
"version" : "v0.9.1.1-beta",
    "protocolversion" : 90011,
    "walletversion" : 60000,
    "balance" : 0.00000000,
    "newmint" : 0.00000000,
    "stake" : 0.00000000,
    "blocks" : 0,
    "timeoffset" : 0,
    "moneysupply" : 0.00000000,
   "connections" : 2, (good, i already see 2 pc connected)
    "proxy" : "",
   "ip" : "0.0.0.0", (don't know if good or not)
    "difficulty" : {
        "proof-of-work" : 0.00000000,
        "proof-of-stake" : 0.00000000
    },
    "testnet" : true,
    "keypoololdest" : 1416577037,
    "keypoolsize" : 101,
    "paytxfee" : 0.00001000,
    "mininput" : 0.00000000,
    "errors" : ""

then i do getpeerinfo:
 "addr" : "192.168.1.74:34466",
        "services" : "00000001",
        "lastsend" : 1416610880,
        "lastrecv" : 1416610880,
        "conntime" : 1416610879,
        "version" : 90011,
        "subver" : "/OPTii:0.9.1.1/",
        "inbound" : true,
        "startingheight" : 0,
        "banscore" : 0
    },
    {
        "addr" : "192.168.1.74",
        "services" : "00000001",
        "lastsend" : 1416610880,
        "lastrecv" : 1416610880,
        "conntime" : 1416610879,
        "version" : 90011,
        "subver" : "/OPTii:0.9.1.1/",
        "inbound" : false,
        "startingheight" : 0,
        "banscore" : 0
    },
    {
        "addr" : "192.168.1.74:47357",
        "services" : "00000001",
        "lastsend" : 1416610880,
        "lastrecv" : 1416610880,
        "conntime" : 1416610879,
        "version" : 90011,
        "subver" : "/OPTii:0.9.1.1/",
        "inbound" : false,
        "startingheight" : 0,
        "banscore" : 0


Then i do getmininginfo:

"blocks" : 0, (ok, i don't have already start to mine)
    "currentblocksize" : 1000,
    "currentblocktx" : 0,
    "difficulty" : {
        "proof-of-work" : 0.00000000,
        "proof-of-stake" : 0.00000000,
        "search-interval" : 1
    },
    "blockvalue" : 2500000000000, (FIRST BLOCK REWARDS)
    "netmhashps" : 0.00000013,
    "netstakeweight" : 0.00000000,
    "errors" : "",
    "pooledtx" : 0,
    "stakeweight" : {
        "minimum" : 0,
        "maximum" : 0,
        "combined" : 0
    },
    "stakeinterest" : 3000000,
    "testnet" : true

Then, i just need to write -testnet setgenerate true to finally try to mine first block and genesis block.
Here comes the ERROR:
{"code":-32601,"message":"Method not found"}

Here i get stuck. What's that error? He didn't find the command setgenerate true?
I have also downloaded xcoin-cpuminer, compiled and launch this command:
minerd -ax11 and as pool(but i'm in solo cause i need to mine genesis block) i have try to put every ip. My ip,seednode ip,127.0.0.1 and also made several attemp with several ports. But it doesn't work It say:

Bindind thread to cpu1
Binding thread to cpu0
After 20 second it stuck:
HTTP request failed: Operation timed out after 30000 milliseconds with 0 bytes received
[2014-11-22 11:43:42] json_rpc_call failed, retry after 30 seconds


P.s. In the conf.file io only setted user and password.





Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!