Bitcoin Forum
September 24, 2018, 02:49:14 PM *
News: ♦♦ New info! Bitcoin Core users absolutely must upgrade to previously-announced 0.16.3 [Torrent]. All Bitcoin users should temporarily trust confirmations slightly less. More info.
   Home   Help Search Donate Login Register  
Pages: [1]
Author Topic: [GUIDE] Taugeran's Antminer S1/S3 revival story guide  (Read 8128 times)
Hero Member
Offline Offline

Activity: 658
Merit: 500

CCNA: There i fixed the internet.

View Profile
September 09, 2014, 08:16:45 AM


With the upcoming sale for Antminer S1 upgrade kits, I got to thinking:
what are people going to do with all those S1 blades?

And so i had the brilliant idea to begin designing 2 products to repurpose old S1 blades:
  • a "hub" capable of controlling 4 S1 or 8 blades.
  • a usb key, about the size of a Nanofury, capable of controlling 1 S1, or 2 blades.

designs coming shortly, once i finish them!!


Anyway to help me design said items, i began poking around the S1 controller's filesystem
and managed to corrupt the two standard c library files used by normal operation. This had
the effect of rendering my S1 a several kilo brick.
So i was going: well, sh!t! what do i do now?

I tried everything i knew of to reset the S1 to no avail. I took a look at the schematics, and
behold the controller has a debug/serial port broken out on a (not so conveniently placed)
3 pin header which was (of F**king course) unpopulated.

My next thought was: do I even have a USB to UART adapter? NO!!!
To Ebay I went and purchased this lil guy: CP2102 USB to UART module

About a week later (Monday, Sept. Cool I got it in the mail, and promptly fired up my
windows machine for the first time in... wait was that date? 2012? dafuq?
anyway, I installed the drivers and opened it with putty using 115200,8,n,1,xon-xoff,
connected tx to rx and made sure it echoed.

Once that was set, I got to work preparing the controller by squeezing the four little
mounting clips to release it from the hashing board, disconnected all cables except power
(since i didnt have a 3.3V supply handy).

I searched through my parts drawer for a spare header of some sort. I ended up pulling
apart a 2x2 0.1" smd header to used the three pins at a 90deg angle. they dont need to be
soldered on, but it wouldn't hurt if you plan on doing a lot of poking around for whatever
reason like i am. I pressed the pins into the cables that came with the UART module,
hooked the module up and press fit the stubby part ( that would be soldered to a pad) of
the pins into the holes on the controller, minding the image above:
  • module tx <---> controller rx
  • module rx <---> controller tx
  • module gnd <---> controller gnd

open putty with 115200,8,n,1,xon-xoff settings for the bridge, Flip the power switch on
the PSU for the S1, and a moment later text should go flying across the screen. This is
the controllers serial debug console. YAY!!!!!!!!!!!!

So I thought I was going to have to go through the tricky process of completely
reflashing the controller from the U-boot bootloader commandline using tftp and all
that bullsh!t.
But there is a much much easier solution using what is called fail-safe mode. It is a
special mode of the OpenWRT operating system loaded on the controller that boots from
a read-only partition of memory (which i obviously had not corrupted). To enter this mode
power cycle your S1 (no need to restart putty, all will be well) and watch closely as the
text scrolls by. It will pause once or twice. First time is almost immediately after power
is applied:
something like: Autobooting in 1 second. Hit p to stop autoboot.

This is NOT what you want so let

The second time will be during the linux kernel boot sequence. there will be several
timestamps along the left edge of the screen. It will pause and directly mention
Fail-safe mode:

type F then enter/return to start into Failsafe mode.

then it should look like a "normal" linux command prompt (if you've ever seen one, I sure
hope so if you're following this story guide). From here on it is "relatively" easy.

let it finish, this is a software "factory" reset to a basic openwrt configuration.

vi /etc/config/network

make note of the IP address!!! More than likely it will be or
depending on which revision of the S1 you have.

mtd -r erase rootfs_data
This erases some semi-permanent data that could be affecting boot sequence. This will
restart the controller as part of the erase procedure. Let it scroll by and continue booting.
There may be several "errors" about flash storage. thats typically ok, though. It will then
reflash the flash storage with the factory image, allowing is to boot into a clean environment.
after it seems like activity has calmed down/stopped on the screen, hit Enter/Return.
This should activate the Linux Serial console. If it does and it says something like:


then we are back in business and ALMOST back in business. Go ahead and turn everything
off, clip the controller board back onto its retainer posts, reattach all cables ( wi-fi, enet,
flat data cables, flat power cable). Power on the S1. If all has gone well, after ~20 seconds
the lights on the ethernet jack should light up. Use a web browser to navigate to the IP address
you wrote down earlier (if its on the same subnet as your network, otherwise  Refer to
Section 3.1 in AntMiner Manual)

Again, if all has gone well, after navigating to, LuCI should load and present
the AntMiner Login screen. Password is

In another tab download the most recent S1 Firmware

Login to the S1. Click System Tab. Click Backup / Flash Firmware. Down toward the bottom
is a file upload section. Click it and select the S1 Firmware file and upload it (this will take a few)

The next screen is just a verification. Apply it. This should take you to a spinny screen while
the S1 applies the Firmware update. After this finishes, it should redirect back to the login screen.

Login, go to Miner configuration, Enter your particular credentials, Apply & Save, Hash away!!!

Bitfury HW & Habañero : 1.625Th/s
tips/Donations: 1NoS89H3Mr6U5CmP4VwWzU2318JEMxHL1
Come join Coinbase
Hero Member
Offline Offline

Posts: 1537800554

View Profile Personal Message (Offline)

Reply with quote  #2

Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
Sr. Member
Offline Offline

Activity: 289
Merit: 250

Scam-Busting PSA: Beware of Black Arrow Software

View Profile
September 09, 2014, 08:37:12 AM

You, sir, are worthy of praise for executing a fantastic idea! Nice work.
Offline Offline

Activity: 47
Merit: 0

View Profile
September 09, 2014, 12:18:02 PM

so..... as I am not technically minded (unfortunately) does this guy win the swag in the S1 reward thread?!

No idea if the above works, but major congrats for the effort put in - it looks complicated!
Hero Member
Offline Offline

Activity: 840
Merit: 1000

View Profile
September 09, 2014, 01:32:32 PM

Nice, I just bought a working S1 to backup the data and check how the control board could be unbricked on S1 and S3.
You were faster than me.

Custom Server PSU breakout boards, 1200w, 1300w, 2000w, 2880w
Btc: 1J4bberWs6f6XVQ53gn3BNc8qHAicmm7wu
Ltc: LNDmMBtzD3cduwjfxANm2wDrxt9jXRk5ZP
Offline Offline

Activity: 53
Merit: 0

View Profile
July 04, 2015, 09:07:21 AM

ok I'm on putty with the serial-USB and I'm getting a green flashing light but which IP do I enter and other info on putty to connect and reset the firmware on my s3+??

bitmain told me to do this
Connect a TTL cable like this to the 3 pin TTL header on the control card.
 Reboot it and press "p" right away to get the uboot command line.
 Connect a computer and run a TFTP server with the latest firmware on it from
 Run these 4 commands to flash the firmware:
 tftpboot 0x80000000 antMiner_S320150109.bin
 erase 0x9f020000 +0x7c0000
 cp.b 0x80000000 0x9f020000 0x7c0000

I have a COM3 window open but no response after the first line (changed the baud rate and parameters of the serial connection), if it's flashing green does that mean I have the right tx, rx connection?
I can type into the command prompt screen firstboot but no response it seems

does this mean my miner is destroyed?Huh s3+
Offline Offline

Activity: 5
Merit: 0

View Profile
April 13, 2016, 04:01:18 PM

Good morning I apologize for my bad English I am from Venezuela ,

See if you can help me I'm trying to follow your tutorial To A S3 to stop working after a round of light (very common in my country ) I did attempt BY putty and yes the stalls in

" [ 2.890000 ] Kernel panic - not syncing : VFS : Unable to mount root fs on unknown -block ( 0,0) "
 I can not get to the other commands to not resuscitate if something is doing wrong, I 'm trying to revive from windows 7 ...

Thank you
Offline Offline

Activity: 1554
Merit: 1000

View Profile
June 14, 2016, 02:10:47 PM

I wish the reset button just worked....
Pages: [1]
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!