Bitcoin Forum
December 04, 2016, 02:01:25 AM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: BAMT question!  (Read 1553 times)
craked5
Sr. Member
****
Offline Offline

Activity: 322

★YoBit.Net★ 350+ Coins Exchange & Dice


View Profile
May 03, 2012, 01:04:11 PM
 #1

Hello guys! ok so i decided to run BAMT on my 2 machines. The problem is after i configured my bamt.conf file it wont start mining, instead a red screen appears and it says "A fault as been found on GPU X".
Please help is really needed, Thanks Smiley

1480816885
Hero Member
*
Offline Offline

Posts: 1480816885

View Profile Personal Message (Offline)

Ignore
1480816885
Reply with quote  #2

1480816885
Report to moderator
1480816885
Hero Member
*
Offline Offline

Posts: 1480816885

View Profile Personal Message (Offline)

Ignore
1480816885
Reply with quote  #2

1480816885
Report to moderator
1480816885
Hero Member
*
Offline Offline

Posts: 1480816885

View Profile Personal Message (Offline)

Ignore
1480816885
Reply with quote  #2

1480816885
Report to moderator
There are several different types of Bitcoin clients. Header-only clients like MultiBit trust that the majority of mining power is honest for the purposes of enforcing network rules such as the 21 million BTC limit. Full clients do not trust miners in this way.
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1480816885
Hero Member
*
Offline Offline

Posts: 1480816885

View Profile Personal Message (Offline)

Ignore
1480816885
Reply with quote  #2

1480816885
Report to moderator
1480816885
Hero Member
*
Offline Offline

Posts: 1480816885

View Profile Personal Message (Offline)

Ignore
1480816885
Reply with quote  #2

1480816885
Report to moderator
01BTC10
VIP
Hero Member
*
Offline Offline

Activity: 742



View Profile
May 03, 2012, 03:39:12 PM
 #2

I would start by trying 1 GPU and start the rig. If everythings run smooth then add another GPU and restart. If BAMT report a faulty GPU then you know where to look for. Also try with stock speed if you are overcloking.

I had one GPU that didn't overclock and it was a faulty connection with the PCIe extender.
craked5
Sr. Member
****
Offline Offline

Activity: 322

★YoBit.Net★ 350+ Coins Exchange & Dice


View Profile
May 03, 2012, 05:16:44 PM
 #3

I did all that! i have two rigs, one with 3 5XXX cards and another with a 5870. It doesnt work in either rig.
I tried stock clocks, default miner settings, everything basically. It mines fine on Windows 7, so it really must be something im doing wrong.

01BTC10
VIP
Hero Member
*
Offline Offline

Activity: 742



View Profile
May 03, 2012, 06:17:28 PM
 #4

Try what I did. Send a donation to BAMT author and ask in the BAMT thread.
craked5
Sr. Member
****
Offline Offline

Activity: 322

★YoBit.Net★ 350+ Coins Exchange & Dice


View Profile
May 03, 2012, 06:24:03 PM
 #5

ok i have done that! thanks for the replies  Wink

craked5
Sr. Member
****
Offline Offline

Activity: 322

★YoBit.Net★ 350+ Coins Exchange & Dice


View Profile
May 03, 2012, 08:53:04 PM
 #6

Ok so i contacted the developer and he asks for high assistance fees. Can anyone else help me in this case please?

Red Emerald
Hero Member
*****
Offline Offline

Activity: 742



View Profile WWW
May 03, 2012, 10:21:02 PM
 #7

Ok so i contacted the developer and he asks for high assistance fees. Can anyone else help me in this case please?

Post your bamt.conf

craked5
Sr. Member
****
Offline Offline

Activity: 322

★YoBit.Net★ 350+ Coins Exchange & Dice


View Profile
May 03, 2012, 11:07:07 PM
 #8

 Cheesy
Code:
# Big A Miner Thing configuration
# /etc/bamt/bamt.conf
#
# When done editing, restart mining to make changes here take effect
# If you're just setting up BAMT, be sure to edit pools as well.
#
# As of 0.5, many less common options have been removed from this
# default config to make it easier on the noobs.
#
# You will find a complete example with all options described
# at /opt/bamt/examples/bamt.conf
#
# Note: This is a YAML file.  Indentation is significant.
#
# If you break things badly, a backup of this file in it's original
# form can be found at /opt/bamt/examples/bamt.conf.simple
#


---
settings:

  # miner_id is used to set hostname and identify this rig to munin and
  # other processes
  # IMPORTANT! miner_id must be a valid hostname: all lower case, no weird
  # characters, underscores, periods, or spaces. Dash and numbers are ok.

  miner_id: bamt-miner
  # loc is any additional string you wish to use to identify or group this rig

  miner_loc: unspecified location

  # should we monitor the cards? 1 = yes, 0 = no

  do_monitor: 1

  # if monitoring, how do we send email alerts?

  # these are required..

  # smtp_host: smtp.gmail.com
  # smtp_to: craked5@gmail.com
 
# these are optional..

  # smtp_from: somefrom@address
  # smtp_subject: I wanted a custom subject in my alerts...
  # smtp_port: 587
  # smtp_auth_user: user@where
  # smtp_auth_pass: secret
  # smtp_tls: 1
  # smtp_ssl: 1

 
 
# GPU Configurtation

# You'll need one gpuX: section per GPU installed.  Not sure what's installed,
# or the order?  Open a root shell and type:  aticonfig --list-adapters
#
# You can delete gpu sections if you don't have that many cards.. or add more
# if you find a way to run them



gpu0:

  # remove disabled: or set it to 0 to actually use this card..

  disabled: 0
 
  # overclocking.. all are optional 

  # optional command to execute prior to overclocking
  # any valid command (or the path to a script) is fine

  # pre_oc_cmd


  # (core/mem)_X = the value to set for this profile (0-2)
  # Profile 2 is used while mining, but setting values
  # in profile 2 that are *lower* than the values in the other
  # profiles is not allowed on some GPUs, so you have to adjust
  # the other profiles as well.
  # For instance, to get 300Mhz mem clock on my 5830s, I have
  # to set all 3 profiles to 300.


  # core_speed_0: 800
  # core_speed_1: 900
  # core_speed_2: 950
 
  # mem_speed_0: 188
  # mem_speed_1: 200
  # mem_speed_2: 320

  # core_voltage_0: 0.95
  # core_voltage_1: 1.020
  # core_voltage_2: 1.163

  # recommend to set and forget fan, preferably at 100
 
  fan_speed: 80

  # optional command to execute after overclocking
  # post_oc_cmd:


  # Phoenix mining setup (see full example for how to use cgminer instead)
  # We strongly recommend you use phoenix at, least until you are familiar
  # with BAMT

  # kernel to use.. one of:  phatk phatk2 poclbm
  # if in doubt, use phatk2

  kernel: phatk2

  # phoenix style kernel params.  *do not* include DEVICE=x, otherwise
  # exactly same as any phoenix setup. 
  # if in doubt: BFI_INT VECTORS AGGRESSION=11
  # (though 9 on GPU0 often makes using the GUI more pleasant)

  kernel_params: BFI_INT VECTORS FASTLOOP=false AGGRESSION=9


  # Pool file

  # IMPORTANT: pool_file must contain a list of pool URLs.. one at least, more if
  # you like.  You can share the same file for all GPUs, or have one for each.
  # Miner will start with first URL in file, however if no shares are accepted
  # for any reason in (pool_timeout) seconds, the miner will move to next URL
  # in the file.  Wraps around to first URL when last one fails.
  # You can also set pool specific values, see the example pools file.
  # if in doubt: /etc/bamt/pools

  pool_file: /etc/bamt/pools

  # max time to allow phoenix to run without finding a share..
  # exceed this and we kill phoenix, start a new instance with
  # next line in pools file

  pool_timeout: 180



  # monitoring limits, used by email alerts and gpumon
  # an alert is generated if the current value goes below a 'lo'
  # or above a 'hi'.

  # GPU temp sensor reading (in C)
  monitor_temp_lo: 45
  monitor_temp_hi: 80

  # GPU load (in %)
  monitor_load_lo: 80

  # average hashrate (in mh/s)
  monitor_hash_lo: 400

  # fam rpm (in rpm)
  monitor_fan_lo: 2000

  # effective reject rate (in % of total)
  monitor_reject_hi: 1



# OK.. hopefully you get the idea.  Stubs for additional GPUs below.
# There are many additional paramters to help you deal with various
# scenarios, see /opt/bamt/examples and the docs (if we write some)


gpu1:
  disabled: 0

  # core_speed_0: 800
  # core_speed_1: 850
  # core_speed_2: 950
  # mem_speed_0: 318
  # mem_speed_1: 319
  # mem_speed_2: 320
  # core_voltage_0: 1.120
  # core_voltage_1: 1.125
  # core_voltage_2: 1.163
 
  fan_speed: 80

  kernel: phatk2
  kernel_params: BFI_INT VECTORS FASTLOOP=false AGGRESSION=15

  pool_file: /etc/bamt/pools
  pool_timeout: 180

  monitor_temp_lo: 45
  monitor_temp_hi: 80
  monitor_load_lo: 80
  monitor_hash_lo: 125
  monitor_fan_lo: 2000
  monitor_reject_hi: 1


gpu2:
  disabled: 0

  # core_speed_0: 300
  # core_speed_1: 800
  # core_speed_2: 980
  # mem_speed_0: 300
  # mem_speed_1: 300
  # mem_speed_2: 300
  # core_voltage_0: 1.125
  # core_voltage_1: 1.126
  # core_voltage_2: 1.128

  fan_speed: 80

  kernel: phatk2
  kernel_params: BFI_INT VECTORS FASTLOOP=false AGGRESSION=11

  pool_file: /etc/bamt/pools
  pool_timeout: 180

  monitor_temp_lo: 45
  monitor_temp_hi: 80
  monitor_load_lo: 80
  monitor_hash_lo: 125
  monitor_fan_lo: 2000
  monitor_reject_hi: 1



gpu3:
  disabled: 1

  # core_speed_0: 300
  # core_speed_1: 800
  # core_speed_2: 980
  # mem_speed_0: 300
  # mem_speed_1: 300
  # mem_speed_2: 300
  # core_voltage_0: 1.125
  # core_voltage_1: 1.125
  # core_voltage_2: 1.125000

  fan_speed: 100

  kernel: phatk2
  kernel_params: BFI_INT VECTORS FASTLOOP=false AGGRESSION=11

  pool_file: /etc/bamt/pools
  pool_timeout: 180

  monitor_temp_lo: 45
  monitor_temp_hi: 80
  monitor_load_lo: 80
  monitor_hash_lo: 125
  monitor_fan_lo: 2000
  monitor_reject_hi: 1


gpu4:
  disabled: 1

  # core_speed_0: 300
  # core_speed_1: 800
  # core_speed_2: 980
  # mem_speed_0: 300
  # mem_speed_1: 300
  # mem_speed_2: 300
  # core_voltage_0: 1.125
  # core_voltage_1: 1.125
  # core_voltage_2: 1.125000

  fan_speed: 100

  kernel: phatk2
  kernel_params: BFI_INT VECTORS FASTLOOP=false AGGRESSION=11

  pool_file: /etc/bamt/pools
  pool_timeout: 180

  monitor_temp_lo: 45
  monitor_temp_hi: 80
  monitor_load_lo: 80
  monitor_hash_lo: 125
  monitor_shares_lo: 1


gpu5:
  disabled: 1

  # core_speed_0: 300
  # core_speed_1: 800
  # core_speed_2: 980
  # mem_speed_0: 300
  # mem_speed_1: 300
  # mem_speed_2: 300
  # core_voltage_0: 1.125
  # core_voltage_1: 1.125
  # core_voltage_2: 1.125000

  fan_speed: 100

  kernel: phatk2
  kernel_params: BFI_INT VECTORS FASTLOOP=false AGGRESSION=11

  pool_file: /etc/bamt/pools
  pool_timeout: 180

  monitor_temp_lo: 45
  monitor_temp_hi: 80
  monitor_load_lo: 80
  monitor_hash_lo: 125
  monitor_shares_lo: 1


gpu6:
  disabled: 1

  # core_speed_0: 300
  # core_speed_1: 800
  # core_speed_2: 980
  # mem_speed_0: 300
  # mem_speed_1: 300
  # mem_speed_2: 300
  # core_voltage_0: 1.125
  # core_voltage_1: 1.125
  # core_voltage_2: 1.125000

  fan_speed: 100

  kernel: phatk2
  kernel_params: BFI_INT VECTORS FASTLOOP=false AGGRESSION=11

  pool_file: /etc/bamt/pools
  pool_timeout: 180

  monitor_temp_lo: 45
  monitor_temp_hi: 80
  monitor_load_lo: 80
  monitor_hash_lo: 125
  monitor_shares_lo: 1


gpu7:
  disabled: 1

  # core_speed_0: 300
  # core_speed_1: 800
  # core_speed_2: 980
  # mem_speed_0: 300
  # mem_speed_1: 300
  # mem_speed_2: 300
  # core_voltage_0: 1.125
  # core_voltage_1: 1.125
  # core_voltage_2: 1.125000

  fan_speed: 100

  kernel: phatk2
  kernel_params: BFI_INT VECTORS FASTLOOP=false AGGRESSION=11

  pool_file: /etc/bamt/pools
  pool_timeout: 180

  monitor_temp_lo: 45
  monitor_temp_hi: 80
  monitor_load_lo: 80
  monitor_hash_lo: 125
  monitor_shares_lo: 1


Ok its basically the simple config file with some gpus configured.
Thanks

01BTC10
VIP
Hero Member
*
Offline Offline

Activity: 742



View Profile
May 03, 2012, 11:30:20 PM
 #9

Open a terminal and type:

Code:
sudo aticonfig --adapter=all --odgt

To see if you can access your card. You should see GPU model and temp.
Red Emerald
Hero Member
*****
Offline Offline

Activity: 742



View Profile WWW
May 03, 2012, 11:49:04 PM
 #10

Only thing about the config I see that might be causing trouble is AGGRESION=15

Also, I'd recommend either having monitor_load_lo OR monitor_hash_lo since one will probably never go off without the other also going off. I just have load enabled for me.

craked5
Sr. Member
****
Offline Offline

Activity: 322

★YoBit.Net★ 350+ Coins Exchange & Dice


View Profile
May 03, 2012, 11:54:11 PM
 #11

Open a terminal and type:

Code:
sudo aticonfig --adapter=all --odgt

To see if you can access your card. You should see GPU model and temp.

yes mate, i can see the cards and the corresponding temps!

craked5
Sr. Member
****
Offline Offline

Activity: 322

★YoBit.Net★ 350+ Coins Exchange & Dice


View Profile
May 03, 2012, 11:56:13 PM
 #12

Only thing about the config I see that might be causing trouble is AGGRESION=15

Also, I'd recommend either having monitor_load_lo OR monitor_hash_lo since one will probably never go off without the other also going off. I just have load enabled for me.

Well i tried with AGG=11/9 and its not doing anything. I will only enable load to check.
Thanks for the help!

craked5
Sr. Member
****
Offline Offline

Activity: 322

★YoBit.Net★ 350+ Coins Exchange & Dice


View Profile
May 04, 2012, 11:49:33 PM
 #13

Please guys! i really dont know what to do anymore! If anyone has had this problem and managed to solve it please say  Wink

btcnode
Jr. Member
*
Offline Offline

Activity: 39


View Profile
May 05, 2012, 05:13:48 PM
 #14

Are you sure your GPU isn't faulty?
TechCF
Member
**
Offline Offline

Activity: 109


View Profile
May 05, 2012, 06:22:50 PM
 #15

My suggestion is to switch to cgminer (bamt comes with it, just edit your bamt.conf file to enable it, and enable it on the gpus). BAMT with the default phoenix would not work for me (as one of my GPUs is an AMD APU unit). GPUMON will not show that you are mining, but press the 0 key and the screen session for cgminer will be shown.
Red Emerald
Hero Member
*****
Offline Offline

Activity: 742



View Profile WWW
May 05, 2012, 08:07:50 PM
 #16

My suggestion is to switch to cgminer (bamt comes with it, just edit your bamt.conf file to enable it, and enable it on the gpus). BAMT with the default phoenix would not work for me (as one of my GPUs is an AMD APU unit). GPUMON will not show that you are mining, but press the 0 key and the screen session for cgminer will be shown.
BAMT will show cgminer stats if you configure it properly.

Code: (/etc/bamt/cgminer.conf)
"api-allow" : "W:127.0.0.1"

Code: (/etc/bamt/bamt.conf)
settings:
  cgminer: 1
  cgminer_opts: --config /etc/bamt/cgminer.conf

Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!