Bitcoin Forum
December 06, 2016, 10:10:35 PM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: devcoin "11DbException" on fresh VPS install  (Read 1403 times)
01BTC10
VIP
Hero Member
*
Offline Offline

Activity: 742



View Profile
May 07, 2012, 11:06:19 PM
 #1

So I compiled devcoin from git but it dont start. I'm running ubuntu 10.04 and compiled BTC, NMC, LTC, I0C, IXC but the devcoin is the only one not working.

debug:
Code:
Bitcoin version 0.3.25.1-beta
Default data directory /root/.devcoin
Bound to port 6334
Loading addresses...
dbenv.open strLogDir=/root/.devcoin/database strErrorFile=/root/.devcoin/db.log


************************
EXCEPTION: 11DbException      
DbEnv::open: Invalid argument      
devcoin in AppInit()      

I've tried removing db.log without success.

I've read both thread about 11DbException but it's not the same situation as me.

Thank's!
1481062235
Hero Member
*
Offline Offline

Posts: 1481062235

View Profile Personal Message (Offline)

Ignore
1481062235
Reply with quote  #2

1481062235
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481062235
Hero Member
*
Offline Offline

Posts: 1481062235

View Profile Personal Message (Offline)

Ignore
1481062235
Reply with quote  #2

1481062235
Report to moderator
arby
Donator
Member
*
Offline Offline

Activity: 112


keybase.io/arblarg


View Profile
May 08, 2012, 06:09:23 AM
 #2

This was on Windows, but it looks like the same error:

https://bitcointalk.org/?topic=613.0%3Bwap2


Quote

sgtstein:
I've run into the same problem. Backup your wallet.dat if you haven't already. Try removing the "old" wallet and try again. If that doesn't work it means it is the database. If it is the database, you would need to remove the database folder and blk*.dat files and redownload the chain.

I haven't been able to figure it out yet. Trying to narrow it down myself.


Jabber/XMPP: arby@darkness.su
01BTC10
VIP
Hero Member
*
Offline Offline

Activity: 742



View Profile
May 08, 2012, 06:21:49 AM
 #3

Yeah thank's but it never started so I don't have any wallet or blockchain yet. But I created a devcoin.conf file.

This is what I get from the console:

Code:

root@crypto-tech:~# ./devcoind
devcoin server starting
root@crypto-tech:~#

************************
EXCEPTION: 11DbException       
DbEnv::open: Invalid argument       
devcoin in AppInit()       

terminate called after throwing an instance of 'DbException'
  what():  DbEnv::open: Invalid argument
arby
Donator
Member
*
Offline Offline

Activity: 112


keybase.io/arblarg


View Profile
May 08, 2012, 06:53:48 AM
 #4

Did you compile it against the right libraries?


Yeah thank's but it never started so I don't have any wallet or blockchain yet. But I created a devcoin.conf file.

This is what I get from the console:

Code:

root@crypto-tech:~# ./devcoind
devcoin server starting
root@crypto-tech:~#

************************
EXCEPTION: 11DbException       
DbEnv::open: Invalid argument       
devcoin in AppInit()       

terminate called after throwing an instance of 'DbException'
  what():  DbEnv::open: Invalid argument

Jabber/XMPP: arby@darkness.su
01BTC10
VIP
Hero Member
*
Offline Offline

Activity: 742



View Profile
May 08, 2012, 07:19:56 AM
 #5

I don't know. I installed every dependency mentioned the build-unix file. It compiled without error.

Maybe after some sleep I will find.
rapeghost
Sr. Member
****
Offline Offline

Activity: 406



View Profile WWW
May 08, 2012, 08:28:24 PM
 #6

Did you upgrade from a previous copy?

Old blockchain, etc

Those errors usually show when you copy data files from an old install. You can safely remove *db* files
rapeghost
Sr. Member
****
Offline Offline

Activity: 406



View Profile WWW
May 08, 2012, 08:28:45 PM
 #7

Also dont run things as root.
01BTC10
VIP
Hero Member
*
Offline Offline

Activity: 742



View Profile
May 09, 2012, 06:20:23 AM
 #8

You are right about root but I forgot to logout after compiling Devcoin on a fresh VPS. So no blockchain at all...
arby
Donator
Member
*
Offline Offline

Activity: 112


keybase.io/arblarg


View Profile
May 09, 2012, 09:12:00 AM
 #9

Because it says "invalid argument" I suspect its compatibility issue, maybe check if you have installed the exact versions of the packages specified.

Some times new packages are not always backward compatible with the old ones.

Jabber/XMPP: arby@darkness.su
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!