Bitcoin Forum
February 18, 2018, 10:40:35 PM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: CGMINER & FPGA still requires OPENCL.DLL?  (Read 6641 times)
Scared
Member
**
Offline Offline

Activity: 70
Merit: 10



View Profile
May 10, 2012, 07:04:47 PM
 #1

It appears that CGMINER requires opencl.dll to be installed. This is an issue for FPGA only mining. I'm running in a virtualized environment that does not support opencl.dll. Is there a way to run CGMINER without GPU mining functionality/opencl.dll dependency?

Thanks

[EDIT]

Figured it out
  Needed to install AMD SDK Even though i'm not using the GPU because the exe was linked to opencl.
  Also needed to use -G to disabled GPU mining.
1518993635
Hero Member
*
Offline Offline

Posts: 1518993635

View Profile Personal Message (Offline)

Ignore
1518993635
Reply with quote  #2

1518993635
Report to moderator
Automated Bitcoin Fork Extraction Tool WE DO TOUGH WALLETS: BCH | BTG | BCD | SBTC | UBTC | B2X | BCX | BTF Electrum 2FA, Trezor, Ledger, SegWit, Bech32
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1518993635
Hero Member
*
Offline Offline

Posts: 1518993635

View Profile Personal Message (Offline)

Ignore
1518993635
Reply with quote  #2

1518993635
Report to moderator
1518993635
Hero Member
*
Offline Offline

Posts: 1518993635

View Profile Personal Message (Offline)

Ignore
1518993635
Reply with quote  #2

1518993635
Report to moderator
af_newbie
Legendary
*
Offline Offline

Activity: 1274
Merit: 1000



View Profile
May 10, 2012, 07:14:48 PM
 #2

It appears that CGMINER requires opencl.dll to be installed. This is an issue for FPGA only mining. I'm running in a virtualized environment that does not support opencl.dll. Is there a way to run CGMINER without GPU mining functionality/opencl.dll dependency?

Thanks

No. cl*() calls are linked.  You would need to change the code to load opencl.dll dynamically.
Maybe bfgminer is doing it, if not, it probably should.


Compile/Configure option maybe? Check if there is one to disable opencl

EDIT: try building it with --disable-opencl --enable-bitforce or --disable-opencl --enable-icarus
I just tried.  It works!
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!