Bitcoin Forum
December 04, 2016, 10:20:14 AM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Trouble compiling bitcoind on OSX with homebrew  (Read 1098 times)
ashleyconnor
Jr. Member
*
Offline Offline

Activity: 38


View Profile
May 14, 2012, 06:41:23 PM
 #1

I've read the README on the bitcoin github page which instructs you to install the following libraries using MacPorts - boost db48 dbus openssl.

I have these installed using homebrew which I use instead of macports. They are also the correct versions as homebrew installs, later, incompatible versions.

With these installed I edited the make to point to the libraries homebrew installed namely DEPSDIR=/usr/local and adding -I"$(DEPSDIR)/Cellar/berkeley-db4/4.8.30/include" to INCLUDEPATHS

However I'm getting this compiler error which is cryptic to me:

http://pastebin.com/6ey859uK

Has anybody managed to get this working?
1480846814
Hero Member
*
Offline Offline

Posts: 1480846814

View Profile Personal Message (Offline)

Ignore
1480846814
Reply with quote  #2

1480846814
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1480846814
Hero Member
*
Offline Offline

Posts: 1480846814

View Profile Personal Message (Offline)

Ignore
1480846814
Reply with quote  #2

1480846814
Report to moderator
Red Emerald
Hero Member
*****
Offline Offline

Activity: 742



View Profile WWW
August 27, 2012, 07:56:32 AM
 #2

I've setup a brew-tap that makes this super easy.

Code:
brew tap WyseNynja/bitcoin
brew install wysenynja/bitcoin/bitcoind

Right now it installs version 0.6.3 (or head if you pass --head).  I'm not sure how to have it allow multiple versions; I'm still reading the docs.

I'm also about to add "bitcoind-next-test"

Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!