Bitcoin Forum
December 11, 2016, 10:08:09 AM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 [2]  All
  Print  
Author Topic: 0.6.2 and Ubuntu 12.04 not playing nice  (Read 8111 times)
P4man
Hero Member
*****
Offline Offline

Activity: 504



View Profile
May 22, 2012, 04:59:52 PM
 #21

Are you guys starting bitcoin automatically on startup?

Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481450889
Hero Member
*
Offline Offline

Posts: 1481450889

View Profile Personal Message (Offline)

Ignore
1481450889
Reply with quote  #2

1481450889
Report to moderator
1481450889
Hero Member
*
Offline Offline

Posts: 1481450889

View Profile Personal Message (Offline)

Ignore
1481450889
Reply with quote  #2

1481450889
Report to moderator
1481450889
Hero Member
*
Offline Offline

Posts: 1481450889

View Profile Personal Message (Offline)

Ignore
1481450889
Reply with quote  #2

1481450889
Report to moderator
Raoul Duke
aka psy
Legendary
*
Offline Offline

Activity: 1442



View Profile
May 22, 2012, 05:27:07 PM
 #22

Are you guys starting bitcoin automatically on startup?

Not me.
Lucky for me I didn't check that box on the Options or else I would be stuck with it, just like I'm stuck with the Minimize to tray on close lol

tiptopgemdotcom
Legendary
*
Offline Offline

Activity: 1218


fine gemstones and jewelry directly to you


View Profile
May 22, 2012, 07:43:43 PM
 #23

I'm not either.
qdi
Hero Member
*****
Offline Offline

Activity: 602



View Profile
May 28, 2012, 10:18:55 AM
 #24

Just upgraded the client to 0.6.2 and the icon is no longer in the system tray (notification area?) when bitcoin is running.  It is also absent from the menu bar.  Hmmmm.  I guess I could choose to never minimize it but that doesn't seem practical.

Anyone?
restore program focus
terminal:> wmctrl -a bitcoin
tiptopgemdotcom
Legendary
*
Offline Offline

Activity: 1218


fine gemstones and jewelry directly to you


View Profile
May 28, 2012, 10:29:02 AM
 #25

Just upgraded the client to 0.6.2 and the icon is no longer in the system tray (notification area?) when bitcoin is running.  It is also absent from the menu bar.  Hmmmm.  I guess I could choose to never minimize it but that doesn't seem practical.

Anyone?
restore program focus
terminal:> wmctrl -a bitcoin


Darn!  I was so hopeful when I saw this.  But no, it doesn't work at all.  Nothing happens.
Raoul Duke
aka psy
Legendary
*
Offline Offline

Activity: 1442



View Profile
May 31, 2012, 02:40:25 PM
 #26

tiptopgem, do you by any chance have Bitcoin pinned on the Laucher?
As soon as I unpinned mine from the sidebar launcher I got the menus back. Now at least I could change the options to close it instead of minimizing to tray lol

EDIT: Fixed it.
As soon as I unpinned it the icon never again showed up on the launcher sidebar. Here's what I did to fix all of the problems.
Open dash, type Bitcoin. Get your mouser over the Bitcoin icon and drag it to your desktop, it will create an icon/shortcut on the desktop. You can drag that shortcut to the launcher sidebar if you wish and voilá, whenever you use it, be it on the desktop or on the sidebar launcher, you will have the menus and system tray icon back Wink

For some strange reason, when I added the desktop shortcut to the sidebar launcher, it remained there but it didn't had the little arrow that open apps have. After a couple restarts I managed to drag the Bitcoin shortcut from the dash to the launcher sidebar and now it works as intended, menus and tray icon included, having the arrow on the side od the icon when the client is open.

Some odd shit, I'll tell you that lol

dirtycat
Sr. Member
****
Offline Offline

Activity: 455



View Profile
August 30, 2012, 07:08:45 AM
 #27

tiptopgem, do you by any chance have Bitcoin pinned on the Laucher?
As soon as I unpinned mine from the sidebar launcher I got the menus back. Now at least I could change the options to close it instead of minimizing to tray lol

EDIT: Fixed it.
As soon as I unpinned it the icon never again showed up on the launcher sidebar. Here's what I did to fix all of the problems.
Open dash, type Bitcoin. Get your mouser over the Bitcoin icon and drag it to your desktop, it will create an icon/shortcut on the desktop. You can drag that shortcut to the launcher sidebar if you wish and voilá, whenever you use it, be it on the desktop or on the sidebar launcher, you will have the menus and system tray icon back Wink

For some strange reason, when I added the desktop shortcut to the sidebar launcher, it remained there but it didn't had the little arrow that open apps have. After a couple restarts I managed to drag the Bitcoin shortcut from the dash to the launcher sidebar and now it works as intended, menus and tray icon included, having the arrow on the side od the icon when the client is open.

Some odd shit, I'll tell you that lol

Am I the only one still have problems with this?  Tried everything you said psy.. no luck.  I noticed the when I open 2 instances of the client I get the "bitcoin is probably already runing" error and I get the tray icon back but when I hit ok.. poof its gone again lol.

NOTE: As I was typing this post I opened it again and BAM! I got the tray icon back.. seems to be working everytime I open again.. definitely "Some odd shit"

poop!
dirtycat
Sr. Member
****
Offline Offline

Activity: 455



View Profile
August 30, 2012, 07:11:24 AM
 #28

And... now its gone again.  Guess I'll just stick with the command line until this is resolved.

poop!
Raoul Duke
aka psy
Legendary
*
Offline Offline

Activity: 1442



View Profile
August 30, 2012, 01:09:52 PM
 #29

And... now its gone again.  Guess I'll just stick with the command line until this is resolved.

The only way I found it to be working 100% of the time is to launch Bitcoin-qt using the shortcut on the desktop.
Shortcuts on the launcher always go on and off as they please.

dirtycat
Sr. Member
****
Offline Offline

Activity: 455



View Profile
August 31, 2012, 01:38:52 AM
 #30

And... now its gone again.  Guess I'll just stick with the command line until this is resolved.

The only way I found it to be working 100% of the time is to launch Bitcoin-qt using the shortcut on the desktop.
Shortcuts on the launcher always go on and off as they please.

I got the shortcut on the desktop but it seems to decide by itself when it wants to show me its tray icon.. what a tease.  Gotta cross my fingers everytime I run it.

poop!
coinpeculiator
Newbie
*
Offline Offline

Activity: 27


View Profile
September 14, 2012, 09:48:58 AM
 #31

I have the same issue of no file menu and no tray icon, I installed via the repo ppa:bitcoin/bitcoin.
I'm considering removing bitcoin-qt and installing it again but I'm worried I won't backup my wallet and chain data files correctly.
dirtycat
Sr. Member
****
Offline Offline

Activity: 455



View Profile
September 14, 2012, 09:52:50 AM
 #32

I have the same issue of no file menu and no tray icon, I installed via the repo ppa:bitcoin/bitcoin.
I'm considering removing bitcoin-qt and installing it again but I'm worried I won't backup my wallet and chain data files correctly.

oh forgot to post an update here.. if you compile from source everything is fine.

poop!
Raoul Duke
aka psy
Legendary
*
Offline Offline

Activity: 1442



View Profile
April 25, 2013, 11:30:03 AM
 #33

For people who don't want to compile from source, here's the solution:
https://bitcointalk.org/index.php?topic=187302.0

Gator-hex
Hero Member
*****
Offline Offline

Activity: 490


View Profile
April 25, 2013, 11:54:19 AM
 #34

I don't know if this will help, but this is what I did with Ubuntu 12.04LTS and older version of Bitcoin-QT (not sure version but < 0.8.1)

Quote
Click on the top icon in the side tray.
Type "Bitcoin".
Click on the icon that looks like pencils,pen,ruler near the bottom if nothing shows.
It should come up with a Bitcoin icon that you can drag and drop into the side bar.
After launching it from the side bar, if you minimize, the sidebar gets a small white arrow, click this maximizes it again.
The menu bar is attached to the top of the screen, you need to click on the window to get focus before it shows the correct menu items though. If it don't work close bitcoin and start it again.

I hate Unity too!  Wink

You're welcome to donate to 1LUF4Jp8PprpHcQVwXyLjCrdbSjFuaycUs if this helped you avoid pulling your hair out in anger. Thanks.

P4man
Hero Member
*****
Offline Offline

Activity: 504



View Profile
April 25, 2013, 01:54:14 PM
 #35

I hate Unity too.  Wink

Then give elementary OS a try. its based on ubuntu, runs all ubuntu apps but has the best UI Ive come across so far.
oh and no problems with bitcoin-qt

Pages: « 1 [2]  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!