Bitcoin Forum
October 22, 2017, 10:46:12 AM *
News: Latest stable version of Bitcoin Core: 0.15.0.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: BAMT not working when deleting # in front of overclocking settings in .conf file  (Read 1460 times)
katsaplias
Newbie
*
Offline Offline

Activity: 10


View Profile
May 27, 2012, 12:44:26 PM
 #1

When I try to overclock through the config file and delete the comment symbol nothing works. GPUmon just auto closes the moment i open it so does everything else.

I'm pretty sure my clocks are set correctly 

So for example on my 5870:

  # core_speed_0: 300
  # core_speed_1: 800
  # core_speed_2: 900
  # mem_speed_0: 300
  # mem_speed_1: 300
  # mem_speed_2: 300
  # core_voltage_0: 1.125
  # core_voltage_1: 1.125
  # core_voltage_2: 1.125000


once I delete the # in front of the lines NOTHING works.
Even if i remove all other GPU's except 1 this problem still occurs.

I'm using a Gigabyte 990fxa-ud7 (7XGPUS) with the boot workaround mentioned here (in the second post) : http://www.bitcointrading.com/forum/index.php?topic=416.0

Bamt is booting correctly (But not always. Sometimes it fails to load x-server which is the GUI) and I'm beginning to wonder if despite the workaround to boot on the gigabyte board, It still has problems running linux from a usb... 

ANY HELP would be HUGELY appreciated THANX!!!

1508669172
Hero Member
*
Offline Offline

Posts: 1508669172

View Profile Personal Message (Offline)

Ignore
1508669172
Reply with quote  #2

1508669172
Report to moderator
1508669172
Hero Member
*
Offline Offline

Posts: 1508669172

View Profile Personal Message (Offline)

Ignore
1508669172
Reply with quote  #2

1508669172
Report to moderator
1508669172
Hero Member
*
Offline Offline

Posts: 1508669172

View Profile Personal Message (Offline)

Ignore
1508669172
Reply with quote  #2

1508669172
Report to moderator
No Gods or Kings. Only Bitcoin
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1508669172
Hero Member
*
Offline Offline

Posts: 1508669172

View Profile Personal Message (Offline)

Ignore
1508669172
Reply with quote  #2

1508669172
Report to moderator
1508669172
Hero Member
*
Offline Offline

Posts: 1508669172

View Profile Personal Message (Offline)

Ignore
1508669172
Reply with quote  #2

1508669172
Report to moderator
1508669172
Hero Member
*
Offline Offline

Posts: 1508669172

View Profile Personal Message (Offline)

Ignore
1508669172
Reply with quote  #2

1508669172
Report to moderator
katsaplias
Newbie
*
Offline Offline

Activity: 10


View Profile
May 27, 2012, 01:18:13 PM
 #2

The main reason this is so important is because I want to lower the mem clocks so I can have lower temps and lower consumption
katsaplias
Newbie
*
Offline Offline

Activity: 10


View Profile
May 27, 2012, 02:50:56 PM
 #3

Out of curiosity since I haven't gotten a single reply yet.

Am I doing something wrong? Or am I following the correct procedure but no one can figure out what the problem is?
BookLover
Hero Member
*****
Offline Offline

Activity: 535


^Bitcoin Library of Congress.


View Profile
May 27, 2012, 03:18:10 PM
 #4

Try posting your whole BAMT.conf, and any other information you think would be useful.

katsaplias
Newbie
*
Offline Offline

Activity: 10


View Profile
May 27, 2012, 03:34:55 PM
 #5

Well Here it is!


# Big A Miner Thing configuration
# /etc/bamt/bamt.conf
#
# When done editing, restart mining to make changes here take effect
# If you're just setting up BAMT, be sure to edit pools as well.
#
# As of 0.5, many less common options have been removed from this
# default config to make it easier on the noobs.
#
# You will find a complete example with all options described
# at /opt/bamt/examples/bamt.conf
#
# Note: This is a YAML file.  Indentation is significant.
#
# If you break things badly, a backup of this file in it's original
# form can be found at /opt/bamt/examples/bamt.conf.simple
#


---
settings:

  # miner_id is used to set hostname and identify this rig to munin and
  # other processes
  # IMPORTANT! miner_id must be a valid hostname: all lower case, no weird
  # characters, underscores, periods, or spaces. Dash and numbers are ok.

  miner_id: dewie-miner

  # loc is any additional string you wish to use to identify or group this rig

  miner_loc: unspecified location

  # should we monitor the cards? 1 = yes, 0 = no

  do_monitor: 0

  # if monitoring, how do we send email alerts?

  # these are required..

  # smtp_host: smtp.gmail.com
  # smtp_to: you@yourmail.com
 
  # these are optional..

  # smtp_from: somefrom@address
  # smtp_subject: I wanted a custom subject in my alerts...
  # smtp_port: 587
  # smtp_auth_user: user@where
  # smtp_auth_pass: secret
  # smtp_tls: 1
  # smtp_ssl: 1

 
 
# GPU Configurtation

# You'll need one gpuX: section per GPU installed.  Not sure what's installed,
# or the order?  Open a root shell and type:  aticonfig --list-adapters
#
# You can delete gpu sections if you don't have that many cards.. or add more
# if you find a way to run them



gpu0:

  # remove disabled: or set it to 0 to actually use this card..

  disabled: 0

 
  # overclocking.. all are optional 

  # optional command to execute prior to overclocking
  # any valid command (or the path to a script) is fine

  # pre_oc_cmd:


  # (core/mem)_X = the value to set for this profile (0-2)
  # Profile 2 is used while mining, but setting values
  # in profile 2 that are *lower* than the values in the other
  # profiles is not allowed on some GPUs, so you have to adjust
  # the other profiles as well.
  # For instance, to get 300Mhz mem clock on my 5830s, I have
  # to set all 3 profiles to 300.


  # core_speed_0: 300
  # core_speed_1: 800
  # core_speed_2: 980
 
  # mem_speed_0: 300
  # mem_speed_1: 300
  # mem_speed_2: 300

  # core_voltage_0: 1.125
  # core_voltage_1: 1.125
  # core_voltage_2: 1.125000

  # recommend to set and forget fan, preferably at 100
 
  fan_speed: 70

  # optional command to execute after overclocking
  # post_oc_cmd:


  # Phoenix mining setup (see full example for how to use cgminer instead)
  # We strongly recommend you use phoenix at, least until you are familiar
  # with BAMT

  # kernel to use.. one of:  phatk phatk2 poclbm
  # if in doubt, use phatk2

  kernel: phatk2

  # phoenix style kernel params.  *do not* include DEVICE=x, otherwise
  # exactly same as any phoenix setup. 
  # if in doubt: BFI_INT VECTORS AGGRESSION=11
  # (though 9 on GPU0 often makes using the GUI more pleasant)

  kernel_params: BFI_INT VECTORS AGGRESSION=7 worksize=128


  # Pool file

  # IMPORTANT: pool_file must contain a list of pool URLs.. one at least, more if
  # you like.  You can share the same file for all GPUs, or have one for each.
  # Miner will start with first URL in file, however if no shares are accepted
  # for any reason in (pool_timeout) seconds, the miner will move to next URL
  # in the file.  Wraps around to first URL when last one fails.
  # You can also set pool specific values, see the example pools file.
  # if in doubt: /etc/bamt/pools

  pool_file: /etc/bamt/pools

  # max time to allow phoenix to run without finding a share..
  # exceed this and we kill phoenix, start a new instance with
  # next line in pools file

  pool_timeout: 180



  # monitoring limits, used by email alerts and gpumon
  # an alert is generated if the current value goes below a 'lo'
  # or above a 'hi'.

  # GPU temp sensor reading (in C)
  monitor_temp_lo: 45
  monitor_temp_hi: 80

  # GPU load (in %)
  monitor_load_lo: 80

  # average hashrate (in mh/s)
  monitor_hash_lo: 125

  # fam rpm (in rpm)
  monitor_fan_lo: 2000

  # effective reject rate (in % of total)
  monitor_reject_hi: 2



# OK.. hopefully you get the idea.  Stubs for additional GPUs below.
# There are many additional paramters to help you deal with various
# scenarios, see /opt/bamt/examples and the docs (if we write some)


gpu1:
  disabled: 0

  # core_speed_0: 300
  # core_speed_1: 800
  # core_speed_2: 1060
  # mem_speed_0: 300
  # mem_speed_1: 300
  # mem_speed_2: 1120
  # core_voltage_0: 1.125
  # core_voltage_1: 1.125
  # core_voltage_2: 1.125000

  fan_speed: 75

  kernel: phatk2
  kernel_params: BFI_INT VECTORS AGGRESSION=7 worksize=128

  pool_file: /etc/bamt/pools
  pool_timeout: 180

  monitor_temp_lo: 45
  monitor_temp_hi: 80
  monitor_load_lo: 80
  monitor_hash_lo: 125
  monitor_fan_lo: 2000
  monitor_reject_hi: 1


gpu2:
  disabled: 0

  # core_speed_0: 300
  # core_speed_1: 800
  # core_speed_2: 980
  # mem_speed_0: 300
  # mem_speed_1: 300
  # mem_speed_2: 300
  # core_voltage_0: 1.125
  # core_voltage_1: 1.125
  # core_voltage_2: 1.125000

  fan_speed: 75

  kernel: phatk2
  kernel_params: BFI_INT VECTORS AGGRESSION=7 worksize=128

  pool_file: /etc/bamt/pools
  pool_timeout: 180

  monitor_temp_lo: 45
  monitor_temp_hi: 80
  monitor_load_lo: 80
  monitor_hash_lo: 125
  monitor_fan_lo: 2000
  monitor_reject_hi: 1



gpu3:
  disabled: 0

  # core_speed_0: 300
  # core_speed_1: 800
  # core_speed_2: 980
  # mem_speed_0: 300
  # mem_speed_1: 300
  # mem_speed_2: 300
  # core_voltage_0: 1.125
  # core_voltage_1: 1.125
  # core_voltage_2: 1.125000

  fan_speed: 60

  kernel: phatk2
  kernel_params: BFI_INT VECTORS AGGRESSION=7 worksize=128

  pool_file: /etc/bamt/pools
  pool_timeout: 180

  monitor_temp_lo: 45
  monitor_temp_hi: 80
  monitor_load_lo: 80
  monitor_hash_lo: 125
  monitor_fan_lo: 2000
  monitor_reject_hi: 1


gpu4:
  disabled: 0

  # core_speed_0: 300
  # core_speed_1: 800
  # core_speed_2: 980
  # mem_speed_0: 300
  # mem_speed_1: 300
  # mem_speed_2: 300
  # core_voltage_0: 1.125
  # core_voltage_1: 1.125
  # core_voltage_2: 1.125000

  fan_speed: 60

  kernel: phatk2
  kernel_params: BFI_INT VECTORS AGGRESSION=7 worksize=128

  pool_file: /etc/bamt/pools
  pool_timeout: 180

  monitor_temp_lo: 45
  monitor_temp_hi: 80
  monitor_load_lo: 80
  monitor_hash_lo: 125
  monitor_shares_lo: 1


gpu5:
  disabled: 0

  # core_speed_0: 300
  # core_speed_1: 800
  # core_speed_2: 980
  # mem_speed_0: 300
  # mem_speed_1: 300
  # mem_speed_2: 300
  # core_voltage_0: 1.125
  # core_voltage_1: 1.125
  # core_voltage_2: 1.125000

  fan_speed: 60

  kernel: phatk2
  kernel_params: VECTORS BFI_INT AGGRESSION=13 FASTLOOP=false WORKSIZE=256

  pool_file: /etc/bamt/pools
  pool_timeout: 180

  monitor_temp_lo: 45
  monitor_temp_hi: 80
  monitor_load_lo: 80
  monitor_hash_lo: 125
  monitor_shares_lo: 1


gpu6:
  disabled: 0

  # core_speed_0: 300
  # core_speed_1: 800
  # core_speed_2: 980
  # mem_speed_0: 300
  # mem_speed_1: 300
  # mem_speed_2: 300
  # core_voltage_0: 1.125
  # core_voltage_1: 1.125
  # core_voltage_2: 1.125000

  fan_speed: 60

  kernel: phatk2
  kernel_params: VECTORS BFI_INT AGGRESSION=13 FASTLOOP=false WORKSIZE=256

  pool_file: /etc/bamt/pools
  pool_timeout: 180

  monitor_temp_lo: 45
  monitor_temp_hi: 80
  monitor_load_lo: 80
  monitor_hash_lo: 125
  monitor_shares_lo: 1


gpu7:
  disabled: 1

  # core_speed_0: 300
  # core_speed_1: 800
  # core_speed_2: 980
  # mem_speed_0: 300
  # mem_speed_1: 300
  # mem_speed_2: 300
  # core_voltage_0: 1.125
  # core_voltage_1: 1.125
  # core_voltage_2: 1.125000

  fan_speed: 60

  kernel: phatk2
  kernel_params: VECTORS BFI_INT AGGRESSION=13 FASTLOOP=false WORKSIZE=256

  pool_file: /etc/bamt/pools
  pool_timeout: 180

  monitor_temp_lo: 45
  monitor_temp_hi: 80
  monitor_load_lo: 80
  monitor_hash_lo: 125
  monitor_shares_lo: 1
katsaplias
Newbie
*
Offline Offline

Activity: 10


View Profile
May 27, 2012, 03:37:07 PM
 #6

Also When I tried copy pasting What was in my conf file to a text file on windows and then copy pasting that text back into my conf file in BAMT from a usb storage the same thing happens: GPUmon auto closes like everything else. Which leads me to think this isn't simply a text file? Is there more than meets the eye?
Michail1
Legendary
*
Offline Offline

Activity: 1098


Www.Michail.Com


View Profile WWW
June 15, 2012, 05:07:26 PM
 #7

I had the same problem with a conf file.  Just seem corrupt.  So, I just made a new one.

Do you really have 7 GPUs in the one machine?

And, did you try updating the BIOS?  It solved a similar issue I was having on an MSI mobo (even though the other 4 rigs (same mobos) didn't have the problem.

Michail

BookLover
Hero Member
*****
Offline Offline

Activity: 535


^Bitcoin Library of Congress.


View Profile
June 24, 2012, 01:12:00 AM
 #8

Try just using core_speed etc instead of core_speed_0 core_speed_1 core_speed_2.  You want to set core_speed to the clock you want to use while mining.  You can do this for memory and voltage too.  You may want to try a lower clock too, like 750.  I believe >900 is pretty high for a 5870.

I hope this helps,
BookLover


pazor
Legendary
*
Offline Offline

Activity: 966



View Profile
August 23, 2012, 08:06:23 AM
 #9

hey katsaplias,

did you got a solution for your problem ?
removing # from bamt.conf can you now set the gpu values ?

regards
pazor

treuhand-Dienst gewünscht? - frag per PM an
BTC 174X17nR7vEQBQo4GXKRGMGaTmB49Gf1yT
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!