Bitcoin Forum
December 05, 2016, 04:44:25 PM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Command-line ATI Overdrive Utility (with memory adjustments)?  (Read 2603 times)
fpgaminer
Hero Member
*****
Offline Offline

Activity: 546



View Profile WWW
May 15, 2011, 10:02:36 PM
 #1

Is there a command-line driven ATI OverDrive Utility that allows properly adjusting the memory clock? aticonfig won't let me set the memory clock lower than the default 1000. So far I have used AMDOverdriveCtrl to set everything up, and it's great, but it requires a GUI. I want to be able to SSH into the rigs and set everything up, or even script stuff.

EDIT: Oh, looks like AMDOverdriveCtrl lets you run a "batch-mode" and specify a profile. That's pretty decent for scripting. Not ideal, but a good work around.

Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
shivansps
Sr. Member
****
Offline Offline

Activity: 346


View Profile
May 15, 2011, 10:06:16 PM
 #2

ist easier to just flash the cards with the OC/mem underclock clocks???

1NEvmZTwLhqBgr3h7LwZap1sEHsyf3QFuv
trentzb
Sr. Member
****
Offline Offline

Activity: 406


View Profile
May 15, 2011, 10:12:41 PM
 #3

I've been hacking on glakkeclock a bit. I can manually set mem clocks outside BIOS limits but still have adapter index issues and core clock settings still need work. I just noted he submitted some changes over last few days which may fix some of these issues that I have been working on in my tree. Jump in and help out if you can. It uses the ADL SDK.

https://github.com/Glakke/glakkeclock
grndzero
Sr. Member
****
Offline Offline

Activity: 392


View Profile
May 17, 2011, 01:49:50 PM
 #4

I manually set FAN_SETTING percentage and FAN_CTRL enabled to no then removed everything else below that.

Code:
<OVERDRIVE_PROFILE>
  <PERFORMANCE_LEVEL level="2" gpu="90000" mem="30000" voltage="1088"/>
  <PERFORMANCE_LEVEL level="1" gpu="55000" mem="30000" voltage="1038"/>
  <PERFORMANCE_LEVEL level="0" gpu="15700" mem="30000" voltage="1000"/>
  <FAN_SETTING percentage="75"/>
  <FAN_CTRL enabled="no"/>
</OVERDRIVE_PROFILE>

then made a shell script to run overdrive on each card

Code:

export DISPLAY=:0.0
aticonfig --od-enable
AMDOverdriveCtrl -b -i 0 AMDOverDrive
AMDOverdriveCtrl -b -i 3 AMDOverDrive
AMDOverdriveCtrl -b -i 6 AMDOverDrive

works from an ssh session just fine as long as X, fglrx, and opencl are working properly

and once it's enabled aticonfig --odgc --adapter=all should show the memory going all the way down to the lowest point and be changeable with --odsc

Ubuntu Desktop x64 -  HD5850 Reference - 400Mh/s w/ cgminer  @ 975C/325M/1.175V - 11.6/2.1 SDK
Donate if you find this helpful: 1NimouHg2acbXNfMt5waJ7ohKs2TtYHePy
jondecker76
Full Member
***
Offline Offline

Activity: 238


View Profile
May 17, 2011, 03:09:09 PM
 #5

So if I set the core and memory clocks using amdoverdrivectrl, the settings don't persist?

RollerBot Advanced Trading Platform
https://bitcointalk.org/index.php?topic=447727.0
BTC Donations for development: 1H36oTJsi3adFh68wwzz95tPP2xoAoTmhC
grndzero
Sr. Member
****
Offline Offline

Activity: 392


View Profile
May 17, 2011, 11:18:23 PM
 #6

So if I set the core and memory clocks using amdoverdrivectrl, the settings don't persist?


--odcc is supposed to commit clock speeds, I have never used it. I don't think it will work while using amdoverdrivectrl to lower the mem clock below the standard bios limit though. That's why I have it in a shell script.

Ubuntu Desktop x64 -  HD5850 Reference - 400Mh/s w/ cgminer  @ 975C/325M/1.175V - 11.6/2.1 SDK
Donate if you find this helpful: 1NimouHg2acbXNfMt5waJ7ohKs2TtYHePy
Prze_koles
Full Member
***
Offline Offline

Activity: 153



View Profile
June 04, 2011, 11:33:52 PM
 #7

I manually set FAN_SETTING percentage and FAN_CTRL enabled to no then removed everything else below that.

Code:
<OVERDRIVE_PROFILE>
  <PERFORMANCE_LEVEL level="2" gpu="90000" mem="30000" voltage="1088"/>
  <PERFORMANCE_LEVEL level="1" gpu="55000" mem="30000" voltage="1038"/>
  <PERFORMANCE_LEVEL level="0" gpu="15700" mem="30000" voltage="1000"/>
  <FAN_SETTING percentage="75"/>
  <FAN_CTRL enabled="no"/>
</OVERDRIVE_PROFILE>



Wait, where did you set this?

Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!